Results 1 to 5 of 5

Thread: Can't install for Mac non-admin users

  1. #1
    HLCTech is offline Member
    Join Date
    Feb 2009
    Posts
    11
    Rep Power
    6

    Exclamation Can't install for Mac non-admin users

    I know this is a known issue, but it's turning out to be a HUGE problem in our environment. We're running everyone on OS X 10.5.6 and using ZD 1.0. Most of our users are running as "standard" (i.e., non-admin) users as part of our policy, as it keeps them from installing things we don't know about.

    In order to install Zimbra Desktop for a user, I have to go to their machine and:

    1) Make them an admin user
    2) Log out and in again
    3) Run the ZD installer
    4) Set them back to a non-admin user
    5) Log out and in again

    The big problem is that for several users, when I set them back to being a non-admin, ZD won't start up--I get the "Can't start, try again later" message. For at least one other user, it doesn't seem to care whether or not they're an admin.

    I'm told I MUST get this fixed, as many users have laptops and often need access to mail and calendars while offline.

    Is there somewhere that explains what's actually happening during the installation process? I can see where it puts most of the files, but I'm trying to determine if maybe I need to change some permissions to make things work properly. Also, is it neceassary for me to put the "zimbra" folder in the user's home directory, or could it go somewhere else? Do they need R/W access to items in that "zimbra" folder? (Sorry if these are dumb questions; I've never had any experience with how Java works and what it needs to install where.)

    Any help would be appreciated!

  2. #2
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Yes, it's better to install under user's home directory - they do need RW permission for zimbra directory.

    By the way, in your case, you may also want to disable auto update for your users - since updater also prompts for password. Look for this file: extensions/prism-runtime@developer.mozilla.org/defaults/preferences/preferences.js, and set this key to be false: pref("app.update.enabled", false)

    Allowing non-admin user to run ZD is a feature that's already on our road map.

  3. #3
    HLCTech is offline Member
    Join Date
    Feb 2009
    Posts
    11
    Rep Power
    6

    Default Some non-admins DO work OK

    I have at least two users running 1.0 who are working as non-admins, and another one I found today who's running 0.91 and works OK too. So it's not that nobody can run if they're a non-admin; it's inconsistent.

    Thanks for the tip on disabling the auto-update; I guess I need to do that. One of those users called me this morning about receiving the notice to update to build 1513, but she can't run it because she's not an admin.

    From my perspective, the ideal situation would be if the installer was available as an Apple installer package (.pkg) file that I could push out to all of our users as needed. That would allow me to test it first, then easily distribute it to everyone. But I don't know if that would be possible, as ZD doesn't seem to be like a "normal" Mac application; perhaps that has to do with its Java underpinnings. I'll keep my fingers crossed.

    Anyone else have any comments on the whole ZD installation process?

  4. #4
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Yes, we are planning to do some rework on ZD's installer - to make it more "native" to each platform we support.

  5. #5
    HLCTech is offline Member
    Join Date
    Feb 2009
    Posts
    11
    Rep Power
    6

    Smile One fix, at least

    Another thread I started came up with an answer to fix another issue, but it seems to have helped this one, too. While I still have to make the user an admin to do the installation, I can make Zimbra Desktop start up properly by doing the following:

    cd /Users/username/Library
    sudo chmod 755 LaunchAgents

    I had permissions of 777 on that folder, and the Mac OS wouldn't run anything in it until I changed them to 755 (rwxr-xr-x). That folder contains the plist that starts up the background process that ZD needs to access the server, and once it started running, everything worked great.

    Still need a better way to install, but at least this helped.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SSL error right after install, can't get into Admin UI
    By robotrock in forum Installation
    Replies: 5
    Last Post: 03-01-2009, 11:46 PM
  2. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  3. INSTALLATION PROBLEM ON Centos 4.3 x_86-64Bit.
    By jawad@cogilent.com in forum Installation
    Replies: 11
    Last Post: 07-09-2007, 08:09 AM
  4. Install worked, admin login not working
    By gribbler in forum Installation
    Replies: 2
    Last Post: 10-17-2005, 01:42 PM
  5. Admin URL not working after install
    By kennyfordham in forum Administrators
    Replies: 12
    Last Post: 10-07-2005, 02:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •