Results 1 to 9 of 9

Thread: Exchange IMAP Error - extended server path not working

  1. #1
    bmw
    bmw is offline Special Member
    Join Date
    Dec 2008
    Location
    San Rafael, CA
    Posts
    113
    Rep Power
    6

    Thumbs down Exchange IMAP Error - extended server path not working

    Hi! I am getting folks in my office trying Desktop now while still pricing out new servers to install Collaboration Suite.

    Running an Exchange 2003 Server with IMAP and OWA activated and valid SSL. The server path is https://mail.domainname.com/exchange . I am able to connect mobile devices, remote Outlook/Entourage and web services without a hitch.

    When I try to create an account in Zimbra Desktop it won't allow the extended path, ../exchange .

    Keep getting an error to fix it. Any thoughts?
    Thanx in advance.

    Bruce

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,473
    Rep Power
    56

    Default

    The address of your server is mail.domainname.com - that's all you need enter.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    bmw
    bmw is offline Special Member
    Join Date
    Dec 2008
    Location
    San Rafael, CA
    Posts
    113
    Rep Power
    6

    Question Exchange IMAP Error - extended server path not working

    That seems to not be the problem. Upon checking the access logs at the router and firewall, looks like Zimbra Desktop is sending a very high port and the router firewall is accepting it okay but the return is not being accepted by ZD.

    I get this error message:
    SSL connection failure. Please check host and port settings.

    On new profile and trying to validate this many times. As follows:
    Dec 27 12:28:32 2008 Connection Accepted TCP 69.xxx.xxx.xxx:60636->10.0.1.10:993 on ixp2
    Dec 27 12:28:35 2008 Connection Accepted TCP 69.xxx.xxx.xxx:60637->10.0.1.10:993 on ixp2
    Dec 27 12:28:37 2008 Connection Accepted TCP 69.xxx.xxx.xxx:60638->10.0.1.10:993 on ixp2
    Dec 27 12:28:39 2008 Connection Accepted TCP 69.xxx.xxx.xxx:60639->10.0.1.10:993 on ixp2
    Dec 27 12:28:40 2008 Connection Accepted TCP 69.xxx.xxx.xxx:60640->10.0.1.10:993 on ixp2
    Dec 27 12:28:42 2008 Connection Accepted TCP 69.xxx.xxx.xxx:60641->10.0.1.10:993 on ixp2

    Seems like it is connecting properly. ZD doesn't seem to connect to SSL well.
    Exchange OWA, Outlook/Entourage and Evolution connects perfectly. Plus, other regular IMAP accounts accept SSL just fine.

    Please advise. Thanks in advance.
    Last edited by bmw; 12-27-2008 at 03:21 PM. Reason: Update

  4. #4
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    I'm not sure what you are trying to do. Are you trying to setup POP or IMAP with Exchange? If it's POP or IMAP, why are you using an https url?

  5. #5
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    BTW, OWA and Outlook/Entourage don't use either POP or IMAP when talking to Exchange. But zdesktop is limited to IMAP when setup with Exchange.

  6. #6
    bmw
    bmw is offline Special Member
    Join Date
    Dec 2008
    Location
    San Rafael, CA
    Posts
    113
    Rep Power
    6

    Exclamation ZD to Exchange 2003 configuration (was Exchange IMAP Error - extended server path not

    I am using SSL for the Exchange OWA hence the "https://"

    Okay, I seem to have all the ports working correctly but still getting timeouts on the SSL connection. 993 for IMAP4 and 465 for SMTP.

    Any help would be greatly appreciated.

    I can connect successfully through command line using:

    Code:
    openssl s_client -connect mail.domainname.com:993 -crlf
    and
    Code:
    openssl s_client -starttls smtp -crlf -connect mail.domainname.com:465
    But I still get a SSL Connection Failure error message.

    Now, when I set the login name to DOMAIN/USER, the response changes and says it is the wrong login name. So, getting closer.

    Here is the zdesktop.log report using the DOMAIN/USER convention:

    Code:
    2009-01-06 06:00:38,331 INFO  [btpool0-7] [] datasource - Testing: DataSource: { id=73a01d74-9948-48e3-84e6-faf4a8361702, type=imap, isEnabled=true, name=MI - Work, host=mail.marininstitute.org, port=993, connectionType=ssl, username=MARININSTITUTE/brucew, folderId=1 }
    2009-01-06 06:00:38,800 DEBUG [btpool0-7] [] imap - S: * OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 (sanrafael2.marininstitute.org) ready.
    2009-01-06 06:00:38,800 DEBUG [btpool0-7] [] imap - C: C01 CAPABILITY
    2009-01-06 06:00:38,833 DEBUG [btpool0-7] [] imap - S: * CAPABILITY IMAP4 IMAP4rev1 IDLE LOGIN-REFERRALS MAILBOX-REFERRALS NAMESPACE LITERAL+ UIDPLUS CHILDREN AUTH=NTLM
    2009-01-06 06:00:38,834 DEBUG [btpool0-7] [] imap - S: C01 OK CAPABILITY completed.
    2009-01-06 06:00:38,836 DEBUG [btpool0-7] [] imap - C: C02 LOGIN MARININSTITUTE/brucew <password>
    2009-01-06 06:00:38,868 DEBUG [Thread-67] [] imap - S: C02 OK LOGIN completed.
    2009-01-06 06:00:38,869 DEBUG [btpool0-7] [] imap - C: C03 LIST "" ""
    2009-01-06 06:00:38,899 DEBUG [Thread-67] [] imap - S: * LIST (\Noselect) "/" ""
    2009-01-06 06:00:38,899 DEBUG [Thread-67] [] imap - S: C03 OK LIST completed.
    2009-01-06 06:00:38,900 INFO  [btpool0-7] [] datasource - Test succeeded: DataSource: { id=73a01d74-9948-48e3-84e6-faf4a8361702, type=imap, isEnabled=true, name=MI - Work, host=mail.marininstitute.org, port=993, connectionType=ssl, username=MARININSTITUTE/brucew, folderId=1 }
    2009-01-06 06:00:38,901 INFO  [btpool0-7] [] offline - SMTP Testing: DataSource: { id=73a01d74-9948-48e3-84e6-faf4a8361702, type=imap, isEnabled=true, name=MI - Work, host=mail.marininstitute.org, port=993, connectionType=ssl, username=MARININSTITUTE/brucew, folderId=1 }
    Here is the last entry with just the login name:
    Code:
    2009-01-06 06:03:00,111 INFO  [btpool0-7] [] datasource - Testing: DataSource: { id=5f1db6c7-7be8-43fe-bcad-8dc83a70142e, type=imap, isEnabled=true, name=MI - Work, host=mail.marininstitute.org, port=993, connectionType=ssl, username=brucew, folderId=1 }
    2009-01-06 06:03:00,668 DEBUG [btpool0-7] [] imap - S: * OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 (sanrafael2.marininstitute.org) ready.
    2009-01-06 06:03:00,668 DEBUG [btpool0-7] [] imap - C: C01 CAPABILITY
    2009-01-06 06:03:00,703 DEBUG [btpool0-7] [] imap - S: * CAPABILITY IMAP4 IMAP4rev1 IDLE LOGIN-REFERRALS MAILBOX-REFERRALS NAMESPACE LITERAL+ UIDPLUS CHILDREN AUTH=NTLM
    2009-01-06 06:03:00,703 DEBUG [btpool0-7] [] imap - S: C01 OK CAPABILITY completed.
    2009-01-06 06:03:00,703 DEBUG [btpool0-7] [] imap - C: C02 LOGIN brucew <password>
    2009-01-06 06:03:00,736 DEBUG [Thread-70] [] imap - S: C02 OK LOGIN completed.
    2009-01-06 06:03:00,736 DEBUG [btpool0-7] [] imap - C: C03 LIST "" ""
    2009-01-06 06:03:00,766 DEBUG [Thread-70] [] imap - S: * LIST (\Noselect) "/" ""
    2009-01-06 06:03:00,766 DEBUG [Thread-70] [] imap - S: C03 OK LIST completed.
    2009-01-06 06:03:00,775 INFO  [btpool0-7] [] datasource - Test succeeded: DataSource: { id=5f1db6c7-7be8-43fe-bcad-8dc83a70142e, type=imap, isEnabled=true, name=MI - Work, host=mail.marininstitute.org, port=993, connectionType=ssl, username=brucew, folderId=1 }
    2009-01-06 06:03:00,775 INFO  [btpool0-7] [] offline - SMTP Testing: DataSource: { id=5f1db6c7-7be8-43fe-bcad-8dc83a70142e, type=imap, isEnabled=true, name=MI - Work, host=mail.marininstitute.org, port=993, connectionType=ssl, username=brucew, folderId=1 }

  7. #7
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    what is the connection failure message? do you see a stack trace in the log?

  8. #8
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    BTW, I was puzzled by your original post when you said "When I try to create an account in Zimbra Desktop it won't allow the extended path, ../exchange". Where did you put the "../exchange"?

  9. #9
    bmw
    bmw is offline Special Member
    Join Date
    Dec 2008
    Location
    San Rafael, CA
    Posts
    113
    Rep Power
    6

    Default

    The Exchange OWA path is https://mail.domainname.com/exchange that is what I meant.

    It is all working now due to SSL not working on the outgoing server under port 465. If I leave SSL unchecked in ZD configuration but maintain port 465 it works fine. ZD grabs TLS instead. On the incoming, SSL under port 993 works fine.

    So, now I have connectivity to the Exchange Server but when it retrieves the account I lose many of the messages in the first level subfolders. The children under each subfolder populates fine including the main Inbox. It's just those messages in the first level subfolders. If I use any other client including OWA, it all populates perfectly.

    Thoughts, Jin?

    Thanx
    Bruce

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmmailboxdctl is not running !!!!!!
    By olibite in forum Administrators
    Replies: 14
    Last Post: 04-28-2011, 05:50 AM
  2. IMAP server refusing messages with old dates
    By bbarnett in forum Installation
    Replies: 7
    Last Post: 11-11-2010, 01:40 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. [SOLVED] Why my MTA Cross???
    By fsloke in forum Installation
    Replies: 6
    Last Post: 07-30-2008, 08:55 PM
  5. Please help
    By scott_summers in forum Administrators
    Replies: 0
    Last Post: 09-26-2007, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •