Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: corrupted characters

  1. #1
    ambition is offline Member
    Join Date
    Jul 2008
    Posts
    11
    Rep Power
    7

    Default corrupted characters

    We are delighted to know Zimbra -- one of the excellent softwares. As one user in HongKong, China, our company is going to change our email server to Zimmbra.
    However, we found some translation problems during this testing process. After installing Zimbra, the users can send emails within Zimbra and all the languges can be displayed (P.S: We are using traditional chinese).
    But when we send emails to Zimbra by using other companies' email addresses , eg: Gmail or other emails (in traditional chinese(example:中國
    ), the emails will change into corrupted characters(中���f�q).
    As we are using the FC7 version, please kindly advise how to solve this problem. thanks for your help!

  2. #2
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default

    Can you attach the "Show Original" of a sample message that doesn't display properly?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    famao is offline Junior Member
    Join Date
    Jun 2007
    Location
    Japan
    Posts
    8
    Rep Power
    8

    Default

    can you try to add '-Dmail.mime.decodetext.strict=false -Dmail.mime.decodeparameters=true -Dmail.mime.decodefilename=true' options to mailboxd_java_options?

    it seems ok for me.(In Japanese).

  4. #4
    ambition is offline Member
    Join Date
    Jul 2008
    Posts
    11
    Rep Power
    7

    Default

    Quote Originally Posted by dkarp View Post
    Can you attach the "Show Original" of a sample message that doesn't display properly?
    how I can do?
    Attached Images Attached Images
    Last edited by ambition; 07-27-2008 at 09:41 PM.

  5. #5
    ambition is offline Member
    Join Date
    Jul 2008
    Posts
    11
    Rep Power
    7

    Default

    Quote Originally Posted by famao View Post
    can you try to add '-Dmail.mime.decodetext.strict=false -Dmail.mime.decodeparameters=true -Dmail.mime.decodefilename=true' options to mailboxd_java_options?

    it seems ok for me.(In Japanese).
    thanks,but where I can find the 'mailboxd_java_options'?

  6. #6
    famao is offline Junior Member
    Join Date
    Jun 2007
    Location
    Japan
    Posts
    8
    Rep Power
    8

    Default

    Quote Originally Posted by ambition View Post
    thanks,but where I can find the 'mailboxd_java_options'?
    do the following commands

    # su - zimbra
    $ zmlocalconfig | grep mailboxd_java_options

    then, check it and adding above options

    $ zmlocalconfig -e 'mailboxd_java_options=..... mail.mime.decodetext.strict=false -Dmail.mime.decodeparameters=true -Dmail.mime.decodefilename=true"

  7. #7
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default

    Don't attach an image, just attach the text of one of those messages.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #8
    ambition is offline Member
    Join Date
    Jul 2008
    Posts
    11
    Rep Power
    7

    Default

    Quote Originally Posted by famao View Post
    do the following commands

    # su - zimbra
    $ zmlocalconfig | grep mailboxd_java_options

    then, check it and adding above options

    $ zmlocalconfig -e 'mailboxd_java_options=..... mail.mime.decodetext.strict=false -Dmail.mime.decodeparameters=true -Dmail.mime.decodefilename=true"
    The last sentence like this?
    zmlocalconfig -e 'mailboxd_java_options= -Dmail.mime.decodetext.strict=false -Dmail.mime.decodeparameters=true -Dmail.mime.decodefilename=true'

    I add ,but use
    $ zmlocalconfig | grep mailboxd_java_options
    it no change

  9. #9
    ambition is offline Member
    Join Date
    Jul 2008
    Posts
    11
    Rep Power
    7

    Default

    Quote Originally Posted by dkarp View Post
    Don't attach an image, just attach the text of one of those messages.
    like this?
    gmail:發回去ZIMBRA那裏讓它接收羅。。。
    zimbra:�l回去ZIMBRA那�Y��它接收�_。。。

  10. #10
    famao is offline Junior Member
    Join Date
    Jun 2007
    Location
    Japan
    Posts
    8
    Rep Power
    8

    Default

    so try to use it

    zmlocalconfig -e "mailboxd_java_options=-client -XX:NewRatio=2 -Djava.awt.headless=true -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -Dmail.mime.decodetext.strict=false -Dmail.mime.decodefilename=true -Dmail.mime.foldtext=false -Dmail.mime.decodeparameters=true"
    Last edited by famao; 07-27-2008 at 10:26 PM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. create User with zmprov with german characters like in names, etc
    By andre in forum I18N/L10N - Translations
    Replies: 4
    Last Post: Yesterday, 05:37 AM
  2. Documents and national characters
    By milosz in forum Developers
    Replies: 1
    Last Post: 03-07-2008, 01:25 PM
  3. Sharing "Notebooks" with Chinese characters
    By wcbenyip in forum Administrators
    Replies: 1
    Last Post: 08-16-2007, 10:54 AM
  4. User password with special characters reset themselves?
    By easytouch in forum Administrators
    Replies: 0
    Last Post: 08-16-2007, 06:09 AM
  5. Problems with national characters
    By mla in forum Users
    Replies: 5
    Last Post: 10-06-2005, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •