Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: UK date format

  1. #1
    jamesregional is offline New Member
    Join Date
    Feb 2006
    Posts
    3
    Rep Power
    9

    Default UK date format

    I have read through the instructions regarding the Ajax.properties files for changing from mm/dd/yyyy to dd/mm/yyyy.

    However I have created an Ajax_en_gb.properties, with the correct settings and restarted using zmcontrol stop then start.

    This now uses the 24hr time that I required, however the month/day are still the wrong way round when I am creating an appointment in the calendar.

    So I then used the Ajax.properties file and made the changes there (I made a backup) restarted using zmcontrol.
    However this also doesn't seem to have had any effect.
    Can anyone point me in the correct direction to solve this problem.

    Many Thanks

  2. #2
    jamesregional is offline New Member
    Join Date
    Feb 2006
    Posts
    3
    Rep Power
    9

    Default forgot:

    I forgot to mention:

    M4_62 version, on Fedora Core 4

    James

  3. #3
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Hi James, This is bug 5245.

    http://bugzilla.zimbra.com/show_bug.cgi?id=5245

    It's fixed in the next release.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  4. #4
    MarkSBurgunder is offline New Member
    Join Date
    Feb 2006
    Location
    Brisbane, Australia
    Posts
    3
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    http://bugzilla.zimbra.com/show_bug.cgi?id=5245

    It's fixed in the next release.
    I am running 3.0.0_GA_156.FC4 and think I am experiencing this bug. Can you confirm if the fix should be in 3.0.0_GA_156.FC4 or not?

    Cheers
    Mark

  5. #5
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default yes

    Quote Originally Posted by MarkSBurgunder
    I am running 3.0.0_GA_156.FC4 and think I am experiencing this bug. Can you confirm if the fix should be in 3.0.0_GA_156.FC4 or not?

    Cheers
    Mark
    bugzilla claims that it's fixed in your release - did you clear the cache on your browser completely, and still hit the bug? What browser are you running?

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,501
    Rep Power
    57

    Default

    I can confirm that this happens on FF 1.5.0.1 with English (UK) as the only installed language and it's running on SuSE 10 & CentOS4 i.e. the dates show as 2/13/2006. Using IE on WIN2K3 the problem doesn't show i.e. the dates show as 13/2/2006 this is with the GA release of Zimbra. For these tests the cache was cleared, FF & IE shutdown/restarted and the cache cleared again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    They were a few additional i18n date bugs that were found after the GA.

    http://bugzilla.zimbra.com/show_bug.cgi?id=5912
    http://bugzilla.zimbra.com/show_bug.cgi?id=5962

    These are now fixed and will be in the next release(eta week or two).
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    MarkSBurgunder is offline New Member
    Join Date
    Feb 2006
    Location
    Brisbane, Australia
    Posts
    3
    Rep Power
    9

    Default More info

    I am using Firefox 1.5.0.1 with the the general.useragent.locale set to en-AU.

    I have just quickly checked in IE 6 and am still getting Month/Day/Year view in the calendar instead of Day/Month/Year as is standard in Australia.

    All of the above is on Windows XP Pro with Regional properties set to English (Australia).

    Hope that helps.

    Cheers
    Mark

  9. #9
    jerryboi is offline Special Member
    Join Date
    Apr 2006
    Posts
    111
    Rep Power
    9

    Default First day of the week

    Can you also set first day of the week, e.g. in ajax.properties so that the week view in calendar would show "mon ... sun" instead of "sun ... sat" ?

  10. #10
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by jerryboi
    Can you also set first day of the week, e.g. in ajax.properties so that the week view in calendar would show "mon ... sun" instead of "sun ... sat" ?
    Even easier. This can be set from the user options panel.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Irish/UK date format
    By rniland in forum I18N/L10N - Translations
    Replies: 10
    Last Post: 02-11-2008, 12:24 AM
  3. Web Client Date Format & Firefox
    By bhickey in forum Administrators
    Replies: 1
    Last Post: 03-21-2007, 07:42 AM
  4. Replies: 4
    Last Post: 12-19-2006, 06:53 AM
  5. Replies: 1
    Last Post: 08-11-2006, 07:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •