Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Change Language.

  1. #1
    mauroreggio's Avatar
    mauroreggio is offline Active Member
    Join Date
    Dec 2007
    Posts
    27
    Rep Power
    7

    Default [SOLVED] Change Language.

    Hi all,
    i try change language of my Zimbra 4.5 installation.
    I follow the WiKi page, i download the 8 files and i copy in the folder.
    I understand that Zimbra change language following the national setting of the browser. Is this thru?
    My zimbra always appears in english, and i not find nothing about force manually the language of the interface.
    Can anyone help me?
    Thanks.
    Mauro.

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    yes, the language is determined from the browser. What browser are you using? Do you have adblock installed? Disable that if you do.

  3. #3
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    What about the file permissions on these 8 files?
    hugo ribeiro

  4. #4
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    You need to restart tomcat on the Zimbra server once you've put the language files on it.

    And you might have to force-reload on the browser, in order to clean its cache and correctly ask for the files to the server.

  5. #5
    mauroreggio's Avatar
    mauroreggio is offline Active Member
    Join Date
    Dec 2007
    Posts
    27
    Rep Power
    7

    Default

    Hi all and thanks for the answare.
    I recheck all and in fact i find the permission not good for the 8 file copied in the 3 folder specified in the wiki. But still not work good. A little change was occurred: in the "InBox" folder view (the default page that appears after the logon), the english default message "No result Found" is changed, and is in italian now "Non Trovato Alcun Risultato". So, i think that the file related at the system messages is now in italian. But all the interface is still in English. The logon page is in English too. The folder titles are in english. I force the reload of the browser (Mozilla Firefox 2.0.0.11 or IE7, the result is the same) but nothing happened. Any other suggest?
    Thank you all,
    Mauro.

  6. #6
    nxzwt is offline Project Contributor
    Join Date
    Nov 2006
    Posts
    50
    Rep Power
    8

    Default

    i suggest you change httpd.conf file,using italian as the first language.

  7. #7
    mauroreggio's Avatar
    mauroreggio is offline Active Member
    Join Date
    Dec 2007
    Posts
    27
    Rep Power
    7

    Default

    Thanks nxzwt,
    i make the setting you suggest me, but ... no others results, i've the same problem.
    Here my /etc/httpd/conf/httpd.conf settings about Language:

    #####################################

    # Default Language
    DefaultLanguage it

    # In AddLanguage i put "it" the first
    AddLanguage it .it
    AddLanguage ca .ca
    AddLanguage cs .cz .cs
    AddLanguage da .dk
    AddLanguage de .de
    AddLanguage el .el
    AddLanguage en .en
    AddLanguage eo .eo
    AddLanguage es .es
    AddLanguage et .et
    AddLanguage fr .fr
    AddLanguage he .he
    AddLanguage hr .hr
    AddLanguage ja .ja
    AddLanguage ko .ko
    AddLanguage ltz .ltz
    AddLanguage nl .nl
    AddLanguage nn .nn
    AddLanguage no .no
    AddLanguage pl .po
    AddLanguage pt .pt
    AddLanguage pt-BR .pt-br
    AddLanguage ru .ru
    AddLanguage sv .sv
    AddLanguage zh-CN .zh-cn
    AddLanguage zh-TW .zh-tw

    # In LanguagePriority i also put "it" the first
    LanguagePriority it en ca cs da de el eo es et fr he hr ja ko ltz nl nn no pl pt pt-BR ru sv zh-CN zh-TW

    ForceLanguagePriority Prefer Fallback
    AddDefaultCharset UTF-8

    ####################################

    Other suggest for me?
    Thanks.
    Mauro.

  8. #8
    mauroreggio's Avatar
    mauroreggio is offline Active Member
    Join Date
    Dec 2007
    Posts
    27
    Rep Power
    7

    Default

    ... but, one question, this problem is only mine?
    Only for know if italian translate works for all the others, and only i've problem.
    Thanks all,
    Mauro.

  9. #9
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    You know you could upgrade to 5.0GA, Italian is included: More About Translations in ZCS 5.0
    (see pic)
    Last edited by mmorse; 04-14-2008 at 09:01 PM.

  10. #10
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Link was supposed to be More About Translations in ZCS 5.0 I edited real quick, but reposting just incase you got the email already.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 06-03-2008, 11:57 PM
  2. How to change language?
    By mcmick in forum Administrators
    Replies: 11
    Last Post: 04-04-2008, 07:47 AM
  3. change language in xaraya???
    By 0p3n50ur53 in forum Developers
    Replies: 3
    Last Post: 07-21-2007, 12:10 AM
  4. Change language
    By jigi in forum I18N/L10N - Translations
    Replies: 1
    Last Post: 12-09-2005, 01:20 PM
  5. ZCS 3.0 Milestone 2 Language Files
    By KevinH in forum I18N/L10N - Translations
    Replies: 0
    Last Post: 11-14-2005, 11:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •