... using IMAP.

Just installed, but it took me ages to get this to work. Ticking "Save a copy to Sent folder" didn't work - this is plainly a bug.

What eventually did work, was to find the "datasource.xml" file under (if using Win7) Users\YOURWINDOWSUSERNAME\AppData\Local\Zimbra\Zim bra Desktop\conf

Open this file for editing (preferably in a proper xml editor) and change the following line:

<service name="gmail.com" saveToSent="false"

to this:

<service name="gmail.com" saveToSent="true"

Don't do this unless you are comfortable editing config files etc - I won't be responsible if you manage to break your installation.

Before anyone asks - I know you can set up a GMail account as a GMail account instead of IMAP, but if you do that then Personas don't work properly (the GMail SMTP servers add your main account email address as the From address to all outgoing email, no matter what you have set up in the Personas settings).