Results 1 to 7 of 7

Thread: Desktop 7.1.4 Can't add Facebook account - Seems to be a common problem

  1. #1
    andynz is offline Active Member
    Join Date
    Feb 2010
    Location
    Auckland, NZ
    Posts
    47
    Rep Power
    5

    Default Desktop 7.1.4 Can't add Facebook account - Seems to be a common problem - Workaround

    Has anyone been able to get Facebook accounts working in Desktop 7.1.4 b11299? I can add Twitter fine but when adding Facebook this happens:

    Add Account
    Add facebook Account
    My browser opens at "https://zimbraoauth2support.cloudfoundry.com/facebook......" and the page shows "Please close this window".
    So close the window
    Zimbra shows"Accounts have been updated successfully"
    However the facebook account does not show in the account list so hase not been enabled in Zimbra desktop.

    I tired a downgrade to 7.1.2 and was able to enter a Facebook account. It was not here on Zimbra restart but I could use it by setting up each time I ran 7.1.2 even though it was showing as not enabled.

    I reinstalled 7.1.4 and tried installling "Social Zimlet" from the gallery but still can't register a Facebook account. I installed the "Social Zimlet" on our 6.0.5 Zimbra OS server and I can register the accounts ok on the main server/web interface just not in Desktop 7.1.4.

    Cheers
    Andy
    Last edited by andynz; 08-14-2012 at 04:17 PM. Reason: Wrong version in title & Update

  2. #2
    andynz is offline Active Member
    Join Date
    Feb 2010
    Location
    Auckland, NZ
    Posts
    47
    Rep Power
    5

    Default

    Ok found a work around from previous post. Open Zimbra Desktop 7.1.4, click on "setup", click on "open in web browser" . When open in your browser setup the facebook account which worked for me. Then when you open Zimbra desktop again faceboook should be there.

    A definite bug in ZD 7.1.4 though.
    Last edited by andynz; 08-14-2012 at 03:58 PM. Reason: spelling

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by andynz View Post
    A definite bug in ZD 7.1.4 though.
    Have you filed a bug report in bugzilla or checked if there's already one there?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    andynz is offline Active Member
    Join Date
    Feb 2010
    Location
    Auckland, NZ
    Posts
    47
    Rep Power
    5

    Default

    Hi Bill

    Yes just checked and there is a bugzilla 70411. I have added my 2 cents worth to the bug.

    Cheers
    Andy

  5. #5
    cko
    cko is offline Starter Member
    Join Date
    Oct 2012
    Posts
    1
    Rep Power
    2

    Default

    Thanks for posting this. I just had the same problem in 7.2.1 on Mac OS 10.6.8. This is my first try out of the tool and the only thing that was a little confusing. Syncing with google mail and calendar was a breeze.

    Quote Originally Posted by andynz View Post
    Hi Bill

    Yes just checked and there is a bugzilla 70411. I have added my 2 cents worth to the bug.

    Cheers
    Andy

  6. #6
    Eljo is offline Junior Member
    Join Date
    Mar 2013
    Location
    Nederland
    Posts
    9
    Rep Power
    2

    Default

    Sorry I'm new here but I have the same problem. Your steps are not quite clear for me.

    Could you make it more simpel.

    I open Zimbra
    Where is setup?

    type Exception report

    message

    description The server encountered an internal error () that prevented it from fulfilling this request.

    exception

    org.apache.jasper.JasperException: An exception occurred processing JSP page /facebook/oauth2.jsp at line 7

    4: <%!private String readUrl(String urlString) throws IOException {
    5: URL url = new URL(urlString);
    6: BufferedReader in = new BufferedReader(new InputStreamReader(
    7: url.openStream()));
    8:
    9: String response = "";
    10: String inputLine;


    Stacktrace:
    org.apache.jasper.servlet.JspServletWrapper.handle JspException(JspServletWrapper.java:519)
    org.apache.jasper.servlet.JspServletWrapper.servic e(JspServletWrapper.java:416)
    org.apache.jasper.servlet.JspServlet.serviceJspFil e(JspServlet.java:313)
    org.apache.jasper.servlet.JspServlet.service(JspSe rvlet.java:260)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:717)
    root cause

    java.io.IOException: Server returned HTTP response code: 400 for URL: https://graph.facebook.com/oauth/acc...ook/oauth2.jsp
    sun.net.http://www.protocol.http.HttpURLConn...ion.java:1436)
    sun.net.http://www.protocol.https.HttpsURLCo...Impl.java:234)
    java.net.URL.openStream(URL.java:1010)
    org.apache.jsp.facebook.oauth2_jsp.readUrl(oauth2_ jsp.java:17)
    org.apache.jsp.facebook.oauth2_jsp._jspService(oau th2_jsp.java:166)
    org.apache.jasper.runtime.HttpJspBase.service(Http JspBase.java:70)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:717)
    org.apache.jasper.servlet.JspServletWrapper.servic e(JspServletWrapper.java:386)
    org.apache.jasper.servlet.JspServlet.serviceJspFil e(JspServlet.java:313)
    org.apache.jasper.servlet.JspServlet.service(JspSe rvlet.java:260)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:717)
    note The full stack trace of the root cause is available in the Apache Tomcat/6.0.32 logs.

    Apache Tomcat/6.0.32

  7. #7
    dgorrd is offline Starter Member
    Join Date
    Mar 2014
    Posts
    1
    Rep Power
    1

    Default Error even in browser

    I still get the Facebook error even from a browswer. (Zimbra 7.2.2)

    As far as the Google calendar and contects sync, Google site says your calendar needed to be publicly open for searching and reading to be able to sync. Is that what you did? I don't want my calendar public.




    Quote Originally Posted by cko View Post
    Thanks for posting this. I just had the same problem in 7.2.1 on Mac OS 10.6.8. This is my first try out of the tool and the only thing that was a little confusing. Syncing with google mail and calendar was a breeze.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Desktop won't set up Facebook??
    By penmaker in forum General Questions
    Replies: 6
    Last Post: 03-10-2013, 12:48 AM
  2. Desktop won't set up Facebook??
    By penmaker in forum Installation Help
    Replies: 0
    Last Post: 07-20-2012, 08:39 AM
  3. Error connecting to a Facebook account
    By raragon in forum Zimlets
    Replies: 5
    Last Post: 11-06-2009, 12:52 AM
  4. Common mailbox (or mail account) for some users
    By santiago78 in forum Administrators
    Replies: 6
    Last Post: 10-27-2008, 03:32 PM
  5. SSL Problem - No common encryption algorithm
    By Daryl Jones in forum Installation
    Replies: 15
    Last Post: 02-13-2006, 02:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •