Results 1 to 4 of 4

Thread: Ubuntu 11.10 64bit problems

  1. #1
    gbr
    gbr is offline Special Member
    Join Date
    May 2007
    Location
    Winnipeg, Manitoba, Canada
    Posts
    127
    Rep Power
    7

    Default Ubuntu 11.10 64bit problems

    Hi,

    I've ben running 64 bit Ubuntu for quite some time. Ubuntu 11.10 is the first time I've had issues running zdesktop.

    I'm not sure if the install works, since a log directory isn't created.

    This is what I get when I run zdesktop:

    Code:
    gbr@thinkpad:~/downloads/zdesktop_7_1_2_ga_b10978_linux_i686$ "/opt/zimbra/zdesktop/linux/prism/zdclient" -webapp "/home/gbr/.zdesktop/zdesktop.webapp" -override "/home/gbr/.zdesktop/zdesktop.webapp/override.ini" -profile "/home/gbr/.zdesktop/profile"
    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
    
    (zdclient:6745): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
    
    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
    
    (zdclient:6745): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
    
    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
    
    (zdclient:6745): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
    
    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
    
    (zdclient:6745): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
    
    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
    
    (zdclient:6745): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
    
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-cone-plugin.so [/usr/lib/mozilla/plugins/libtotem-cone-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so [/usr/lib/mozilla/plugins/libtotem-gmp-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-mully-plugin.so [/usr/lib/mozilla/plugins/libtotem-mully-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so [/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so [/usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so: wrong ELF class: ELFCLASS64]
    LoadPlugin: failed to initialize shared library /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so [/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so: wrong ELF class: ELFCLASS64]
    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64
    
    (zdclient:6745): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
    
    
    (zdclient:6745): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/i386-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory
    JETTY_HOME     =  /opt/zimbra/zdesktop/jetty
    JETTY_RUN      =  /home/gbr/.zdesktop/log
    JETTY_PID      =  /home/gbr/.zdesktop/log/zdesktop.pid
    JETTY_CONSOLE  =  /home/gbr/.zdesktop/log/zdesktop.out
    JETTY_ARGS     =  
    CONFIGS        =  /home/gbr/.zdesktop/jetty/etc/jetty.xml
    JAVA_OPTIONS   =  -client -d32 -Djava.awt.headless=true -Xms32m -Xmx150m -Xss150k -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -XX:NewRatio=4 -XX:TargetSurvivorRatio=70 -XX:+UseConcMarkSweepGC -DSTART='/opt/zimbra/zdesktop/jetty/etc/start.config' -Dzimbra.home='/home/gbr/.zdesktop' -Dzimbra.config='/home/gbr/.zdesktop/conf/localconfig.xml' -Djava.library.path='/opt/zimbra/zdesktop/jetty/../lib' -Djava.awt.headless=true -Djava.io.tmpdir='/home/gbr/.zdesktop/data/tmp/java' -Djava.net.useSystemProxies=true -Dsun.net.inetaddr.ttl=10 -Djetty.home='/opt/zimbra/zdesktop/jetty'
    JAVA           =  /opt/zimbra/zdesktop/linux/jre/bin/java
    Starting Jetty: 
    Stale pid file removed: /home/gbr/.zdesktop/log/zdesktop.pid
    nohup: Jetty running pid=6779
    redirecting stderr to stdout
    I then get an empty window, with the 'busy/wait' graphic.

    I created the log directory and got yhis in the logfile:

    Code:
    STARTED Jetty Mon Nov 21 16:53:20 CST 2011
    0    INFO  [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    318  WARN  [main] log - Config error at <Set name="resources">
                <Array type="String"><Item><SystemProperty name="jetty.home" default="."/>/webapps/zimlet</Item><Item>/home/gbr/.zdesktop/zimlets-deployed</Item></Array>
              </Set>
    318  WARN  [main] log - Config error at <Set name="baseResource">
            <New class="org.mortbay.resource.ResourceCollection"><Set name="resources">
                <Array type="String"><Item><SystemProperty name="jetty.home" default="."/>/webapps/zimlet</Item><Item>/home/gbr/.zdesktop/zimlets-deployed</Item></Array>
              </Set></New>
          </Set>
    318  WARN  [main] log - Config error at <New id="zimlet" class="org.mortbay.jetty.webapp.WebAppContext"><Arg><Ref id="Contexts"/></Arg><Arg><SystemProperty name="jetty.home" default="."/>/webapps/zimlet</Arg><Arg>/zimlet</Arg><Set name="co
    nfigurationClasses"><Ref id="plusConfig"/></Set><Set name="defaultsDescriptor"><SystemProperty name="jetty.home" default="."/>/etc/webdefault.xml</Set><Set name="tempDirectory">/home/gbr/.zdesktop/data/tmp/jetty/zimlet</Set><Set name="base
    Resource">
            <New class="org.mortbay.resource.ResourceCollection"><Set name="resources">
                <Array type="String"><Item><SystemProperty name="jetty.home" default="."/>/webapps/zimlet</Item><Item>/home/gbr/.zdesktop/zimlets-deployed</Item></Array>
              </Set></New>
          </Set></New>
    319  WARN  [main] log - EXCEPTION 
    java.lang.reflect.InvocationTargetException
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.xml.XmlConfiguration.set(XmlConfiguration.java:305)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:248)
    	at org.mortbay.xml.XmlConfiguration.newObj(XmlConfiguration.java:626)
    	at org.mortbay.xml.XmlConfiguration.itemValue(XmlConfiguration.java:915)
    	at org.mortbay.xml.XmlConfiguration.value(XmlConfiguration.java:837)
    	at org.mortbay.xml.XmlConfiguration.set(XmlConfiguration.java:286)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:248)
    	at org.mortbay.xml.XmlConfiguration.newObj(XmlConfiguration.java:626)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:256)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:214)
    	at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:974)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.start.Main.invokeMain(Main.java:194)
    	at org.mortbay.start.Main.start(Main.java:534)
    	at org.mortbay.start.Main.start(Main.java:441)
    	at org.mortbay.start.Main.main(Main.java:119)
    Caused by: java.lang.RuntimeException: java.lang.IllegalArgumentException: file:/home/gbr/.zdesktop/zimlets-deployed is not an existing directory.
    	at org.mortbay.resource.ResourceCollection.setResources(ResourceCollection.java:120)
    	... 23 more
    Caused by: java.lang.IllegalArgumentException: file:/home/gbr/.zdesktop/zimlets-deployed is not an existing directory.
    	at org.mortbay.resource.ResourceCollection.setResources(ResourceCollection.java:115)
    	... 23 more
    320  ERROR [main] log - Nested in java.lang.reflect.InvocationTargetException:
    java.lang.RuntimeException: java.lang.IllegalArgumentException: file:/home/gbr/.zdesktop/zimlets-deployed is not an existing directory.
    	at org.mortbay.resource.ResourceCollection.setResources(ResourceCollection.java:120)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.xml.XmlConfiguration.set(XmlConfiguration.java:305)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.xml.XmlConfiguration.set(XmlConfiguration.java:305)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:248)
    	at org.mortbay.xml.XmlConfiguration.newObj(XmlConfiguration.java:626)
    	at org.mortbay.xml.XmlConfiguration.itemValue(XmlConfiguration.java:915)
    	at org.mortbay.xml.XmlConfiguration.value(XmlConfiguration.java:837)
    	at org.mortbay.xml.XmlConfiguration.set(XmlConfiguration.java:286)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:248)
    	at org.mortbay.xml.XmlConfiguration.newObj(XmlConfiguration.java:626)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:256)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:214)
    	at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:974)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.start.Main.invokeMain(Main.java:194)
    	at org.mortbay.start.Main.start(Main.java:534)
    	at org.mortbay.start.Main.start(Main.java:441)
    	at org.mortbay.start.Main.main(Main.java:119)
    Caused by: java.lang.RuntimeException: java.lang.IllegalArgumentException: file:/home/gbr/.zdesktop/zimlets-deployed is not an existing directory.
    	at org.mortbay.resource.ResourceCollection.setResources(ResourceCollection.java:120)
    	... 23 more
    Caused by: java.lang.IllegalArgumentException: file:/home/gbr/.zdesktop/zimlets-deployed is not an existing directory.
    	at org.mortbay.resource.ResourceCollection.setResources(ResourceCollection.java:115)
    	... 23 more
    320  ERROR [main] log - Nested in java.lang.reflect.InvocationTargetException:
    java.lang.RuntimeException: java.lang.IllegalArgumentException: file:/home/gbr/.zdesktop/zimlets-deployed is not an existing directory.
    	at org.mortbay.resource.ResourceCollection.setResources(ResourceCollection.java:120)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.xml.XmlConfiguration.set(XmlConfiguration.java:305)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:248)
    	at org.mortbay.xml.XmlConfiguration.newObj(XmlConfiguration.java:626)
    	at org.mortbay.xml.XmlConfiguration.itemValue(XmlConfiguration.java:915)
    	at org.mortbay.xml.XmlConfiguration.value(XmlConfiguration.java:837)
    	at org.mortbay.xml.XmlConfiguration.set(XmlConfiguration.java:286)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:248)
    	at org.mortbay.xml.XmlConfiguration.newObj(XmlConfiguration.java:626)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:256)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:214)
    	at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:974)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.start.Main.invokeMain(Main.java:194)
    	at org.mortbay.start.Main.start(Main.java:534)
    	at org.mortbay.start.Main.start(Main.java:441)
    	at org.mortbay.start.Main.main(Main.java:119)
    Caused by: java.lang.IllegalArgumentException: file:/home/gbr/.zdesktop/zimlets-deployed is not an existing directory.
    	at org.mortbay.resource.ResourceCollection.setResources(ResourceCollection.java:115)
    	... 23 more
    So it looks like jetty is failing.

    Any ideas?

    Gerald

  2. #2
    broomie is offline Starter Member
    Join Date
    Nov 2011
    Posts
    1
    Rep Power
    3

    Default I get this too Ubuntu11.10 64 bit

    Nothing more to add but I am stuck now - wanted to try Zimbra.


    paul

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by broomie View Post
    Nothing more to add but I am stuck now - wanted to try Zimbra.
    Have you actually tried installing the package that provides the missing libraries show in your error messages? I'm afraid I don't use Ubuntu so I can't specifically help you with this but you could have a look at some of these links (or ask on a Ubuntu forum): +"ubuntu" +"libappmenu.so" - Yahoo! Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    gbr
    gbr is offline Special Member
    Join Date
    May 2007
    Location
    Winnipeg, Manitoba, Canada
    Posts
    127
    Rep Power
    7

    Default

    Hi,

    It seems the 7.1.2 installer is missing stuff. I went back to 7.0.0 beta and installed it. It ran fine. I then upgraded through each GA release, and ended up with a running install.

    Gerald

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 04-07-2011, 02:54 AM
  2. Replies: 0
    Last Post: 01-06-2011, 12:26 AM
  3. HOWTO: Ubuntu 64bit Install
    By dijichi2 in forum Installation
    Replies: 12
    Last Post: 07-23-2008, 03:33 PM
  4. Ubuntu 64bit install?
    By R3dn3ck in forum Installation
    Replies: 2
    Last Post: 11-28-2006, 03:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •