Results 1 to 9 of 9

Thread: zd 2.0 reply prefix doesn't work by default

  1. #1
    egts is offline Junior Member
    Join Date
    Aug 2008
    Posts
    9
    Rep Power
    6

    Default zd 2.0 reply prefix doesn't work by default

    Hello all,

    First of, great job on ZD 2.0! I really enjoyed the 1.x series and the 2.0 series is even better! Please keep up the fantastic work!

    I'm seeing some small issues though on ZD 2.0 for Linux.

    1. If I set my replies to "Use prefix" to put a > at the beginning of each line in a reply, >s don't appear when I restart ZD and reply to a message. The setting is still set in the preferences, but the behavior isn't applied upon reply. To get around it, I need to go into the Preferences every time I start ZD, de-select "Use prefix", save preferences, re-select it, and save preferences.

    2. Replies can "Use headers" (which is very verbose) or not ("----- Original Message -----"). ZD 1.x used to do what most traditional email systems do ("On Wed, Sep 01, 2010 at 02:26:19PM -0400, Bob Smith wrote:"). Is there any way to get this behavior back?

    3. How can I get replys to always be plain text? This doesn't happen for me. I don't have "Reply/Forward using format of the original message" checked and I do have "Compose: As Text" checked.

    Thanks!

    Dave

  2. #2
    LadyBug is offline Intermediate Member
    Join Date
    May 2009
    Posts
    23
    Rep Power
    6

    Default

    Quote Originally Posted by egts View Post
    1. If I set my replies to "Use prefix" to put a > at the beginning of each line in a reply, >s don't appear when I restart ZD and reply to a message. The setting is still set in the preferences, but the behavior isn't applied upon reply. To get around it, I need to go into the Preferences every time I start ZD, de-select "Use prefix", save preferences, re-select it, and save preferences.
    I've filed a bug in April about this issue Bug 46319 – ZD does not use reply preferences at first but it seems Zimbra has trouble reproducing it. Please go and comment on your situation so we can get it fixed.

    In my case I just need to go to the preferences -> composing tab to get the > behaviour back. No deselect & save & reselect & save cycle necessary. Just viewing the preferences gets the prefix back -- for a while.

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by LadyBug View Post
    I've filed a bug in April about this issue Bug 46319 – ZD does not use reply preferences at first but it seems Zimbra has trouble reproducing it. Please go and comment on your situation so we can get it fixed.

    In my case I just need to go to the preferences -> composing tab to get the > behaviour back. No deselect & save & reselect & save cycle necessary. Just viewing the preferences gets the prefix back -- for a while.
    A couple of things you haven't mentioned in that bug report: does it happen if you compose in a new window only; does it happen if you are replying to an HTML message; is this a 32 bit or 64 bit version of Windows 7; is your Windows fully patched and up to date? If any of the behaviour is different in those circumstances then perhaps you'd like to update the bug report.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    egts is offline Junior Member
    Join Date
    Aug 2008
    Posts
    9
    Rep Power
    6

    Default

    Quote Originally Posted by LadyBug View Post
    I've filed a bug in April about this issue Bug 46319 – ZD does not use reply preferences at first but it seems Zimbra has trouble reproducing it. Please go and comment on your situation so we can get it fixed.

    In my case I just need to go to the preferences -> composing tab to get the > behaviour back. No deselect & save & reselect & save cycle necessary. Just viewing the preferences gets the prefix back -- for a while.
    Thanks for the pointers! I'll chime in on the BZ, thanks for sending me that!

    I'm also seeing what you are seeing and I'll do you one better. You are correct that you don't have to uncheck and recheck as I noted. In fact, I don't even have to go to the Compose section. Just load the Preferences tab and then go back and then it will work as you noted.

    Thanks again for chiming in!

  5. #5
    egts is offline Junior Member
    Join Date
    Aug 2008
    Posts
    9
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    A couple of things you haven't mentioned in that bug report: does it happen if you compose in a new window only; does it happen if you are replying to an HTML message; is this a 32 bit or 64 bit version of Windows 7; is your Windows fully patched and up to date? If any of the behaviour is different in those circumstances then perhaps you'd like to update the bug report.
    In my case, I'm running RHEL 5.5 x86_64 fully updated.

    I'm also composing in a new window. For fun, I turned off compose in a new window and restarted. When I reply, the quotes do work as desired. So it seems like the problem is that the preferences don't get applied when composing in a new window until after you click on the Preferences tab and go back.

    Incremental progress! Thank you!

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by egts View Post
    I'm also composing in a new window. For fun, I turned off compose in a new window and restarted. When I reply, the quotes do work as desired. So it seems like the problem is that the preferences don't get applied when composing in a new window until after you click on the Preferences tab and go back.
    OK, thanks for trying that and it should go on the bug report.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    egts is offline Junior Member
    Join Date
    Aug 2008
    Posts
    9
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    OK, thanks for trying that and it should go on the bug report.
    Done. Comment #15!

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by egts View Post
    Done. Comment #15!
    You're too quick for me.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    LadyBug is offline Intermediate Member
    Join Date
    May 2009
    Posts
    23
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    A couple of things you haven't mentioned in that bug report: does it happen if you compose in a new window only; does it happen if you are replying to an HTML message; is this a 32 bit or 64 bit version of Windows 7; is your Windows fully patched and up to date? If any of the behaviour is different in those circumstances then perhaps you'd like to update the bug report.
    Well, I did augment my bug report in September (comment #11) when the supposed fix did not work. There I did mention that this was seen on Win 7 32 bit.

    But honestly, I reported what I thought was directly relevant to the bug at hand (reply preferences settings). Reporting HTML compose options or composing in new window did not even enter my mind, because I did not think they were relevant in this case since they were working correctly.

    I would have added that stuff to my report if someone from Zimbra would have asked me to give more details on X, Y and Z instead of just saying "Can't reproduce".

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. E-mail reply prefix
    By rickard in forum Users
    Replies: 3
    Last Post: 07-17-2009, 04:13 AM
  2. Force Reply all to be the default
    By Meowmixjinx in forum Administrators
    Replies: 1
    Last Post: 01-28-2008, 10:10 AM
  3. Replies: 45
    Last Post: 11-28-2007, 06:39 PM
  4. Perdition not restart !!!!
    By olibite in forum Administrators
    Replies: 2
    Last Post: 05-22-2007, 03:50 AM
  5. Email reply prefix
    By rmccullough in forum Installation
    Replies: 1
    Last Post: 12-14-2005, 12:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •