Results 1 to 4 of 4

Thread: [SOLVED] Zdesktop 2 and no english spell checker

  1. #1
    fafa31 is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    20
    Rep Power
    5

    Default [SOLVED] Zdesktop 2 and no english spell checker

    Hello,

    I would like to know how can I configure zdesktop 2 beta 3 to use an other spellcheck than english ?

    In zdesktop 1, we have to configure <install>/profile/user.js, but it doesn't work under zdesktop 2

    Thanks for your help.

    Fabrice.
    Fabrice

    --------------------------------------------------
    Centos 5.3 X64
    Zimbra Release 6.0.4_GA_2038.RHEL5_64_20091214174341 CentOS5_64 NETWORK edition
    Samba 3.0.33

  2. #2
    fafa31 is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    20
    Rep Power
    5

    Default

    Really no idea ???

    Fabrice

    --------------------------------------------------
    Centos 5.3 X64
    Zimbra Release 6.0.4_GA_2038.RHEL5_64_20091214174341 CentOS5_64 NETWORK edition
    Samba 3.0.33

  3. #3
    peter@leleu.be is offline Starter Member
    Join Date
    Jul 2010
    Posts
    1
    Rep Power
    4

    Default

    Quote Originally Posted by fafa31 View Post
    Hello,

    I would like to know how can I configure zdesktop 2 beta 3 to use an other spellcheck than english ?

    In zdesktop 1, we have to configure <install>/profile/user.js, but it doesn't work under zdesktop 2

    Thanks for your help.

    Fabrice.
    Hello Fabrice,

    Same problem for me. I do see a difference between ZDv1 and ZDv2 beta's. In ZDv1 there was in <install>win32\prism\xulrunner\dictionaries the possibility to add additional dictionaries. The <install> directory was named zdesktop The new ZDv2 app installs in Zimbra Desktop But this install path is missing the win32 directory.
    I have been search this entire site but found no reference to installing additional languages into this new directory structure.

    I hope someone can help us with this additional information.

    Peter

  4. #4
    fafa31 is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    20
    Rep Power
    5

    Default

    Here is the solution given on zimbra bugzilla :

    Apparently the solution in Beta3 is a little different.

    1)Copy the language files found in the zip file (forgot where I found them, if
    someone knows the url please let me know) to the program path of zimbra in the
    directory
    C:\Program Files\Zimbra\Zimbra Desktop\win32\prism\xulrunner\dictionaries
    In my case I copied nl.dic and nl.aff
    2)Go on windows XP to the following directory:
    C:\Documents and Settings\<username>\Local Settings\Application
    Data\Zimbra\Zimbra Desktop\profile
    and edit user.js. Change the line "user_pref("spellchecker.dictionary", "nl")"
    into the correct language you need.
    3)Stop ZD and make sure that zdesktop.exe is also stopped from the task
    manager.
    4)Restart ZD. Spell checking should be working now. It is even independent from
    your choosen UI language setting. Tested it with nl locale in user.js and
    English UI.

    For me it work
    Fabrice

    --------------------------------------------------
    Centos 5.3 X64
    Zimbra Release 6.0.4_GA_2038.RHEL5_64_20091214174341 CentOS5_64 NETWORK edition
    Samba 3.0.33

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •