Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ZD v2 b2 - Problem with emails having attachments

  1. #1
    berkeb is offline Member
    Join Date
    Mar 2010
    Posts
    10
    Rep Power
    5

    Default ZD v2 b2 - Problem with emails having attachments

    when I click an email with an attachment, I get the following error. Is this a known issue and are there any solutions? It was working just fine with ZD v2 b1.

    ---------------------------------------------------
    method: GetMsgRequest
    msg: system failure: MessagingException while creating MimeMessage for item 8014
    code: service.FAILURE
    detail: soap:Receiver
    trace: com.zimbra.common.service.ServiceException: system failure: MessagingException while creating MimeMessage for item 8014 ExceptionId:btpool0-20:1271365875260:70153b1630f76d1b Code:service.FAILURE at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:248) at com.zimbra.cs.mailbox.MessageCache.getMimeMessage( MessageCache.java:198) at com.zimbra.cs.mailbox.Message.getMimeMessage(Messa ge.java:334) at com.zimbra.cs.mailbox.Message.getMimeMessage(Messa ge.java:315) at com.zimbra.cs.service.mail.ToXML.encodeMessageAsMP (ToXML.java:785) at com.zimbra.cs.service.mail.GetMsg.handle(GetMsg.ja va:102) at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:419) at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:273) at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:157) at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291) at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212) at javax.servlet.http.HttpServlet.service(HttpServlet .java:727) at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:182) at javax.servlet.http.HttpServlet.service(HttpServlet .java:820) at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:511) at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:390) at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216) at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:182) at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765) at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:418) at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230) at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114) at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152) at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230) at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152) at org.mortbay.jetty.Server.handle(Server.java:326) at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:543) at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:939) at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:755) at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:218) at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:405) at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:409) at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451) Caused by: javax.mail.MessagingException: Error in input stream; nested exception is: java.io.IOException: renaming destination file C:\Users\it\AppData\Local\Zimbra\Zimbra Desktop\data\tmp\uncompressed\BHq69SqJA1bPcYzTGwgz vBTo0tY= already exists at javax.mail.internet.InternetHeaders.load(InternetH eaders.java:361) at javax.mail.internet.InternetHeaders.(InternetHeade rs.java:310) at javax.mail.internet.MimeMessage.createInternetHead ers(MimeMessage.java:2107) at javax.mail.internet.MimeMessage.parse(MimeMessage. java:328) at javax.mail.internet.MimeMessage.(MimeMessage.java: 205) at com.zimbra.cs.mime.Mime$FixedMimeMessage.(Mime.jav a:89) at com.zimbra.cs.mailbox.MessageCache.getMimeMessage( MessageCache.java:161) ... 31 more Caused by: java.io.IOException: renaming destination file C:\Users\it\AppData\Local\Zimbra\Zimbra Desktop\data\tmp\uncompressed\BHq69SqJA1bPcYzTGwgz vBTo0tY= already exists at com.zimbra.common.util.FileUtil.rename(FileUtil.ja va:541) at com.zimbra.cs.store.UncompressedFileCache.get(Unco mpressedFileCache.java:175) at com.zimbra.cs.store.FileDescriptorCache.getSharedF ile(FileDescriptorCache.java:126) at com.zimbra.cs.store.FileDescriptorCache.read(FileD escriptorCache.java:86) at com.zimbra.cs.store.BlobInputStream.read(BlobInput Stream.java:205) at com.sun.mail.util.LineInputStream.readLine(LineInp utStream.java:84) at javax.mail.internet.InternetHeaders.load(InternetH eaders.java:338) ... 37 more
    request:

    Body: {
    GetMsgRequest: {
    _jsns: "urn:zimbraMail",
    m: {
    html: 1,
    id: "724de8ea-9084-4fb7-aed7-36d93ef661cb:8014",
    max: 100000,
    read: 1
    }
    }
    },
    Header: {
    context: {
    _jsns: "urn:zimbra",
    account: {
    _content: "xxxxx@xxxxxxxx.com",
    by: "name"
    },
    authToken: "(removed)",
    notify: {
    seq: 103
    },
    session: {
    _content: 17,
    id: 17
    },
    userAgent: {
    name: "ZimbraWebClient - PRISM (Win)",
    version: "0.0"
    }
    }
    }
    -------------------------------------
    thanks

  2. #2
    LadyBug is offline Intermediate Member
    Join Date
    May 2009
    Posts
    23
    Rep Power
    6

    Default Works fine here

    I'm running ZD 2.0 b2 on Windows 7 and attachments are working fine.

  3. #3
    berkeb is offline Member
    Join Date
    Mar 2010
    Posts
    10
    Rep Power
    5

    Default

    I'm using Vista. But I have read that this problem also happens in XP.

    I could temporarily solve the problem by deleting the files from C:\Users\it\AppData\Local\Zimbra\Zimbra Desktop\data\tmp\uncompressed folder. However after some time the problem comes back. May it be about revisiting emails with attachments after some time?

  4. #4
    CTJP is offline Member
    Join Date
    Dec 2009
    Posts
    13
    Rep Power
    5

    Default Similar Error for me too

    I get a similar error as well. I'm running ZD2 Beta 2 on Win 7 home premium using both the 64-bit Windows on one machine and the 32bit on another; error happens on both.

    So far it is confined to my ISP yahoo hosted accounts and with only some attachments. I have not been able to figure out what makes some attachments work and others generate the error.

    Last night for instance - I received 3 e-mails from the same person - all with attachments; 2 worked just fine - the third failed. I've been using the 'send error' button when it happens but only for an attachment type (file type) that hasn't generated the error on me before.

    The directory referenced by the previous poster on my machines is always empty.

  5. #5
    markpr is offline Active Member
    Join Date
    Apr 2006
    Posts
    29
    Rep Power
    9

    Default

    The problem is intermittent for me, but happens on both Win7 32bit and Win7 64bit systems against accounts using Zimbra 6.04NE edition with ZD2 beta 2

    It can happen in a new message in the Inbox as well as for messages in other folders such as Sent. It seems to be a problem with individual messages. When the problem has occurred I have selected to send the error reports into Zimbra. The same attachments can be opened fine in the Web Client.

    Does this need a bug report or is sending error reports sufficient to get this recognized?

  6. #6
    Join Date
    Apr 2008
    Posts
    11
    Rep Power
    7

    Default

    Same issue on Win 7 Home. Intermittent failure of messages with attachments. While it seems intermittent it has occurred on 2 emails from the same friend.
    Could this be the result of a conflict with emails (with attachments) from certain email clients?

  7. #7
    andynz is offline Active Member
    Join Date
    Feb 2010
    Location
    Auckland, NZ
    Posts
    47
    Rep Power
    5

    Default

    Same problem here. W7 ZD2 beta2_b10414_win32. Cleared the temp file as per 'berkeb' suggestion and it works for the moment.
    Last edited by andynz; 05-20-2010 at 01:14 PM. Reason: Spelling

  8. #8
    nyjetshead is offline Loyal Member
    Join Date
    Dec 2008
    Posts
    92
    Rep Power
    6

    Default

    Works fine on Linux ZD 2.0 Beta 2
    I also have it on Win7 will check.

  9. #9
    sagelike is offline Active Member
    Join Date
    Jan 2010
    Location
    Cochrane, Alberta
    Posts
    40
    Rep Power
    5

    Default Same problem here

    I'm having same problem on Windows XP and client is having this problem on his mac as well. I experienced the problem with ZD2 and ZD 2 beta release 2.

    It's a real pain and I wrote a note about this a couple of months ago but got not response.

    Please Fix this! It's a serious problem.

  10. #10
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    Quote Originally Posted by sagelike View Post
    Please Fix this! It's a serious problem.
    Problems only get fixed if a) they exist and b) you filed a bug report. Posting in the forums does not get to the attention of the developers like it does in bugzilla.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with .doc files as attachments
    By gmsmith in forum Users
    Replies: 4
    Last Post: 06-18-2009, 02:55 AM
  2. Multiple Yahoo Emails with ONE user id problem
    By tomparris in forum General Questions
    Replies: 0
    Last Post: 06-10-2009, 02:45 PM
  3. Emails with attachments being deferred
    By chapman_164 in forum Administrators
    Replies: 4
    Last Post: 02-19-2008, 07:08 AM
  4. Replies: 0
    Last Post: 10-06-2006, 11:21 PM
  5. Reading attachments problem
    By lenjacobs in forum Users
    Replies: 2
    Last Post: 12-27-2005, 11:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •