Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: How do I change the max signature length limit in ZD?

  1. #11
    Juliand is offline Starter Member
    Join Date
    May 2011
    Posts
    2
    Rep Power
    4

    Default SOLVED for Zimbra Desktop on Mac OSX without trashing account

    All
    I am using ZD with a google apps account using IMAP. I was as frustrated as you guys but have managed to solve this for my setup without destroying my account. I edited the zimbra-attrs.xml and initially only changed the default value from 10240 to 20480 then tried my longer html signature and got the same error even after quitting and re-starting ZD. Then I theorised that in fact there was no 'value=' argument in the attr line even though there was one in the previous attribute so I added value="0" saved the file then re-started ZD and tried again but still got the same error. However, I then changed the format of my signature from HTML back to plain text then changed it back to html again, re-added my image reference and saved the longer html signature without problem!

    Not sure whether it was the adding of the value argument or making the client re-check the attrs file by changing from html to text to html but it worked for me.

    Hope this helps some of you.

  2. #12
    ken2johnson is offline Active Member
    Join Date
    Jun 2011
    Posts
    28
    Rep Power
    4

    Default Try this for Windows users

    I found that none of the previously offered solutions worked for me in Windows Vista. So, I dug into the Zimbra source files to find out why.

    Zimbra uses a variable named zimbraMailSignatureMaxLength to limit the length of the HTML signature you can use. There seems to be no logical reasoning behind this limit and increasing it doesn't seem to have any negative side effects. This variable needs to be changed in multiple files in order for the maximum limit warning message to go away. Just increase the number I've highlighted in bold below for the line I specify in each file to increase the limit. For my needs, I changed it to 10240 and that was good enough for my signature to not exceed the limit. Here are the file locations and the lines in those files that you will need to modify. This is for the 7.01 version, but should work for some previous versions as well.

    C:\Users\YOURUSERNAME\AppData\Local\Zimbra\Zimbra Desktop\conf\attrs\zimbra-attrs.xml
    (NOTE: In XP it would be "C:\Documents and Settings\YOUUSERNAME\Local Settings\Application Data\Zimbra\Zimbra Desktop\conf\attrs\zimbra-attrs.xml".)
    <attr id="454" name="zimbraMailSignatureMaxLength" type="long" min="0" cardinality="single" optionalIn="account,cos" flags="accountInfo,accountInherited">
    <defaultCOSValue>1024</defaultCOSValue>
    <desc>maximum length of mail signature, 0 means unlimited. If not set, default is 1024</desc>
    </attr>

    C:\Program Files\Zimbra\Zimbra Desktop\jetty\webapps\zimbra\js\NewWindow_2_all.js
    name:"zimbraMailSignatureMaxLength",type:ZmSetting .T_COS,dataType:ZmSetting.D_INT,defaultValue:1024}

    C:\Program Files\Zimbra\Zimbra Desktop\jetty\webapps\zimbra\js\Startup1_2_all.js
    name:"zimbraMailSignatureMaxLength",type:ZmSetting .T_COS,dataType:ZmSetting.D_INT,defaultValue:1024}

    C:\Program Files\Zimbra\Zimbra Desktop\jetty\webapps\zimbra\js\zimbraMail\prefs\Z mPreferencesApp.js settings.registerSetting("SIGNATURE_MAX_LENGTH", {name:"zimbraMailSignatureMaxLength", type:ZmSetting.T_COS, dataType:ZmSetting.D_INT, defaultValue:1024});

    Restart Zimbra Desktop after making these changes. You should now have a much larger HTML Signature limit of 10KB instead of the default of 1KB. It's also worth noting that when you install an update for Zimbra it is very likely that it will overwrite these changes. So, you will need to go back and edit them again. Hope this helps anyone else fighting with this issue.

  3. #13
    Juliand is offline Starter Member
    Join Date
    May 2011
    Posts
    2
    Rep Power
    4

    Default Really Solved !

    Ken
    Thanks for your solution !

    I have tried it and it works well also on the Mac as well. My previous solution seems to be hit and miss the more thorough solution from Ken works well.

    All the files on the mac are located in the Zimbra Desktop directory on the mac (not in the application support directory where other apps store this sort of file). Use Ken's directory structure from there and you should find everything. You will need to give yourself permission to change the files in the directories using the get info command even if you are the administrator as the default permissions only allow the system to change these files.

  4. #14
    ken2johnson is offline Active Member
    Join Date
    Jun 2011
    Posts
    28
    Rep Power
    4

    Default Still not working right

    This is still not fixed even in the 7.1.3 Beta.

    Here is where you can find the files you need to modify in Linux. You edit the same lines in the Linux files as in the Windows ones. Incidentally, on a fresh install the first file was set to 10240, which is more than big enough. So, it looks like they tried to resolve this. However, as we have discovered, this is only one of the places they need to change this value to really fix the problem.

    The first file that you probably don't need to modify is here ~/zdesktop/conf/attrs/zimbra-attrs.xml

    Here are the other files you will need to modify as I specified in my previous post:
    /opt/zimbra/zdesktop/jetty/webapps/zimbra/js/NewWindow_2_all.js
    /opt/zimbra/zdesktop/jetty/webapps/zimbra/js/Startup1_2_all.js
    /opt/zimbra/zdesktop/jetty/webapps/zimbra/js/zimbraMail/prefs/Z mPreferencesApp.js


    I hope this helps.

  5. #15
    MDovali is offline Starter Member
    Join Date
    Sep 2012
    Posts
    1
    Rep Power
    2

    Default

    Hi, I had tried many suggestions explained in many threads and I havenīt any success. Finally I tried something that works, I donīt understand why but it works.

    1. I reset the MailSignatureMaxLength value to min="0" (the default value).

    2. I define the signature with a name and with the text lines in Plain Text format, and (this is the tricky step) saved it. No error occurs.

    3. I reedit the signature, cahging the format to HTML and modifyng the font size and color of the text lines and adding the URL of the logoīs image, and saved it. NO ERROR OCCURS!!!. I tried first copy&paste the HTML signature from the Zimbra Web Application, but it doesnīt work.

    I hope this will work for you, good luck.

  6. #16
    stevewb is offline New Member
    Join Date
    Sep 2013
    Posts
    3
    Rep Power
    1

    Default

    It worked for me! I very happy chap I am now

  7. #17
    esparanz is offline Starter Member
    Join Date
    Oct 2013
    Posts
    1
    Rep Power
    1

    Default

    Hi,
    I am setting up a html signature for a pop account. I am getting the same error as mentioned in the threads. Tried all the methods but still the error persists.

    Any workaround to this one?

    Thanks in advance.

    Rahul

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Signature limit set to 1024
    By Supernova in forum Users
    Replies: 3
    Last Post: 03-18-2011, 04:41 AM
  2. [SOLVED] Zimbra Desktop Email Signature Max Length
    By ferdtang in forum General Questions
    Replies: 5
    Last Post: 12-01-2009, 09:43 PM
  3. Change signature, lose whitespace
    By EdMartin in forum Administrators
    Replies: 4
    Last Post: 10-05-2009, 01:47 AM
  4. [SOLVED] Change max attachement size
    By osiris in forum Administrators
    Replies: 1
    Last Post: 03-04-2008, 05:56 AM
  5. Max length of ZimbraMtaRestriction value reached...
    By staufj22 in forum Administrators
    Replies: 0
    Last Post: 10-18-2007, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •