Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [SOLVED] Oops! Browser is blocking Popups

  1. #1
    KineticEd is offline Junior Member
    Join Date
    Oct 2009
    Location
    Caldwell, OH
    Posts
    8
    Rep Power
    5

    Default [SOLVED] Oops! Browser is blocking Popups

    Zimbra Desktop 1.0.3 is installed. Logging into Zimbra Mail with IE or Firefox works just fine. When double-clicking an email to view it, replying or creating a new message brings up the, "Oops! Browser is blocking Popups," message. ZD is configured to open a new window when composing a message. We noticed that Yahoo! Toolbar was installed so we removed it, restarted the PC and the message went away. There are no other pop-up blockers installed on the system. ZD was running for about five hours and then the message started to come back again. Closing out of ZD and reopening it fixes the problem temporarily.

    Anything else that I can check?

    Thanks!

  2. #2
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    5

    Default

    My guess is this only happens when running in Firefox, and not in IE. For some reason Firefox keeps track of the number of popups that's been allowed so far. By default the maximum is 20 per session (yes, also when pop-up blocking is turned off completely).

    - Type "about:config" in the address bar
    - Ignore the warning
    - Filter for "dom.popup_maximum"
    - Change the value from 20 to 1000

    - If this helped, please let others know by post to this thread and marking it "Solved"

  3. #3
    Tech Tiger1 is offline Starter Member
    Join Date
    Feb 2009
    Posts
    1
    Rep Power
    6

    Default

    hey Hivos

    Thanks for that piece of information

  4. #4
    KineticEd is offline Junior Member
    Join Date
    Oct 2009
    Location
    Caldwell, OH
    Posts
    8
    Rep Power
    5

    Default

    I just want to note that this problem is happening within Zimbra Desktop, not with a browser session.

  5. #5
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    5

    Default

    My bad... I hadn't noticed this was a ZD and not a ZCS thread

    I'm no ZD guru by any means, but since ZD is based on prism (and therefore firefox), you may be able to get the address bar to show up by changing ZD's webapp.ini file and then be able to perform the steps above. In webapp.ini change "location=false" to "location=true".

  6. #6
    KineticEd is offline Junior Member
    Join Date
    Oct 2009
    Location
    Caldwell, OH
    Posts
    8
    Rep Power
    5

    Default

    User didn't have Firefox installed. I went ahead and installed it, completed the same steps above, rebooted and still the same. As soon as I get to the 20th new email, I get the, "Oops!," message. I reverified that the dom.popup_maximum is set to 1000. Any other ideas?

  7. #7
    KineticEd is offline Junior Member
    Join Date
    Oct 2009
    Location
    Caldwell, OH
    Posts
    8
    Rep Power
    5

    Default

    Also added the 127.0.0.1 address string into the list of Firefox's exceptions and even turned off Pop-Ups and we still cannot create more than 20 new messages.

  8. #8
    KineticEd is offline Junior Member
    Join Date
    Oct 2009
    Location
    Caldwell, OH
    Posts
    8
    Rep Power
    5

    Default

    We installed ZD on a new machine that didn't have Firefox or anything Yahoo! related installed and were not able to create more than 20 new messages.

  9. #9
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    5

    Default

    You appear to not fully understand ZD. Let me explain Mozilla Prism, upon which ZD is based first: it's a lightweight browser, based on XULRunner, the same render engine that e.g. Firefox and Thunderbird use. See it as a stripped Firefox, a ZD dedicated browser without a GUI (addressbar, buttons etc.). This dedicated browser is used to render ZD, which is based on the same scripts as ZCS.

    Therefore, at the moment you installed ZD on that machine, you installed Mozilla Prism (the 'stripped firefox'), which apparently has this nasty bug built-in.

    I think you can resolve this bug by changing the config of Prism. In order to do so, you need to get the address bar to display in ZD / Prism first. As suggested in my previous post, change "location=false" to "location=true" in the webapp.ini file. Then, in the address bar which should be showing now, change dom.popup_maximum to 1000 via about:config. It's my best guess...

    Let us know if it works

  10. #10
    KineticEd is offline Junior Member
    Join Date
    Oct 2009
    Location
    Caldwell, OH
    Posts
    8
    Rep Power
    5

    Default

    As I noted in my earlier posts, I have changed the dom.popup_maximum to 1000 in the about:config from within Firefox. However, when I try to do the exact same thing in the ZD address bar, I cannot modify what is currently in it. Cannot delete the address string. Nothing. I've tried to do this on more than one machine.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 11-26-2013, 09:50 PM
  2. Oops! Browser is blocking Popups
    By peer in forum General Questions
    Replies: 15
    Last Post: 03-12-2011, 06:54 PM
  3. [SOLVED] Attachment blocking within .zip files?
    By bsneddon in forum Administrators
    Replies: 6
    Last Post: 02-15-2010, 10:58 PM
  4. Replies: 1
    Last Post: 12-17-2009, 09:42 AM
  5. Browser in AJAX mode freezes, please help
    By Raiky in forum Installation
    Replies: 3
    Last Post: 03-16-2008, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •