Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Can I use my choice of Browser?

  1. #11
    geekneck is offline Intermediate Member
    Join Date
    Jul 2007
    Posts
    15
    Rep Power
    8

    Default

    Quote Originally Posted by jmhe View Post
    another thing you can try is to set default browser as something else; then set it back to firefox; restart zd afterward.
    No luck on either front. I checked Firefox's Preferences and Check Now says that Firefox is the default.

    I then went to the System Preferences and changed the default browser to Konqueror. I restarted ZD, then click on a link in an email message. I still got the Zimbra browser. I then set system preferences back to Firefox, killed ZD and tried again. Still the Zimbra browser... :-(

  2. #12
    geekneck is offline Intermediate Member
    Join Date
    Jul 2007
    Posts
    15
    Rep Power
    8

    Default Error info

    I just found the ZD error console. When I click a link, hoping to get Firefox to start, I see a bunch of errors in the Error Console. This one looks interesting:

    Code:
    Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalProtocolService.loadURI]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://webrunner/content/webrunner.js :: anonymous :: line 516"  data: no]
    Source File: chrome://webrunner/content/webrunner.js
    Line: 516
    Does this give any clues as to the source of my problem? Thanks!

  3. #13
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Do you have Thunderbird or other mail app installed on this machine? Can you click a link inside Thunderbird to see if it can be opened in FF?


    Quote Originally Posted by geekneck View Post
    I just found the ZD error console. When I click a link, hoping to get Firefox to start, I see a bunch of errors in the Error Console. This one looks interesting:

    Code:
    Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalProtocolService.loadURI]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://webrunner/content/webrunner.js :: anonymous :: line 516"  data: no]
    Source File: chrome://webrunner/content/webrunner.js
    Line: 516
    Does this give any clues as to the source of my problem? Thanks!

  4. #14
    geekneck is offline Intermediate Member
    Join Date
    Jul 2007
    Posts
    15
    Rep Power
    8

    Default

    Quote Originally Posted by jmhe View Post
    Do you have Thunderbird or other mail app installed on this machine? Can you click a link inside Thunderbird to see if it can be opened in FF?
    Clicking a link in Thunderbird opens Firefox straight-away.

  5. #15
    docwhat is offline Starter Member
    Join Date
    Apr 2010
    Location
    Pittsburgh, PA
    Posts
    1
    Rep Power
    5

    Default I filed a bug for this...

    I have the same problem as well.

    I filled a bug for this:
    https://bugzilla.zimbra.com/show_bug.cgi?id=46196

    Ciao!

  6. #16
    n.bochev is offline Active Member
    Join Date
    Aug 2009
    Location
    Bulgaria
    Posts
    25
    Rep Power
    6

    Default

    I have the same issue with ZD v2 b2 on Ubuntu Lucid. Strange thing is it works fine at my home pc, but at work it always opens links in it's own window.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 02-08-2013, 01:13 PM
  2. Can I change the default browser launched ?
    By linuxworks in forum General Questions
    Replies: 6
    Last Post: 05-17-2012, 04:08 PM
  3. Replies: 1
    Last Post: 12-17-2009, 09:42 AM
  4. Browser in AJAX mode freezes, please help
    By Raiky in forum Installation
    Replies: 3
    Last Post: 03-16-2008, 06:22 PM
  5. Handling browser caches
    By Coilcore in forum Administrators
    Replies: 6
    Last Post: 09-27-2006, 07:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •