Results 1 to 7 of 7

Thread: [SOLVED] Zimbra Desktop - how to disable upgrade?

  1. #1
    Ludek is offline Project Contributor
    Join Date
    Aug 2007
    Location
    Czech Republic
    Posts
    13
    Rep Power
    8

    Unhappy [SOLVED] Zimbra Desktop - how to disable upgrade?

    Hello,
    how can I disable upgrade of Zimbra Desktop?
    I am using a modified version of Zimbra Desktop, because I need the Czech language and Czech spelling.

    Once the upgrade is available, users upgrade Zimbra Desktop and lose all my changes.

    I must to do everything again and again after each upgrade on all computers :'-(.

    Thank You so much for your reply!

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Linux:
    <install>/linux/prism/extensions/prism-runtime\@developer.mozilla.org/defaults/preferences/preferences.js

    Windows:
    <install>/win32/prism/extensions/prism-runtime@developer.mozilla.org/defaults/preferences/preferences.js

    Mac:
    <install>/macos/prism/Prism.app/Contents/Resources/extensions/prism-runtime\@developer.mozilla.org/defaults/preferences/preferences.js

    Where <install> is typically:

    Linux - /home/user/zimbra/zdesktop

    Win - drive:\zimbra\zdesktop\ if you started out on an earlier version, or the %USERPROFILE% enviromental variable on later versions.
    Vista drive:\Users\username\AppData(hidden folder)\Local\Zimbra\zdesktop
    XP drive:\Documents and Settings\username\Application Data\Zimbra\zdesktop

    Mac - /users/user/zimbra/zdesktop

    pref("app.update.enabled", true); //enables or disables the background update checker; default=true
    pref("app.update.auto", false); //enables background download of updates according to the policy described by app.update.mode; default=true
    pref("app.update.mode", 2); //defines the policy by which background downloads are done; 0=download all; 1=download compatible; 2=download minor and prompt for major; default=1
    pref("app.update.silent", false); //disables all notification UI for updates; default=false
    You want it all off so adjust the app.update.enabled to false.

    (For others: We actually have background downloading off at the moment - only the prompt is on - see Bug 34944 - tweak background downloading of minor updates)

  3. #3
    Ludek is offline Project Contributor
    Join Date
    Aug 2007
    Location
    Czech Republic
    Posts
    13
    Rep Power
    8

    Default

    Thank you very much for your help and great explanation!
    (I have Linux and users are using Linux (and Windows :-))
    Thank You!
    Last edited by Ludek; 03-06-2009 at 01:52 AM.

  4. #4
    mutface is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    23
    Rep Power
    6

    Default

    Thank you for the info.

    I'm using Opensuse 11.X and cannot find any of the files you have mentioned. Several Things to note:

    (1) I was typing an email and then the update prompt came up and I accidentally pressed entered because it was pop-up and the keyboard focus shifted to the pop-up whilst I was typing. Who designed it? Was it designed to annoy the user everytime they open Zimbra??

    (2) 99&#37; of softwares out there that is used by people have a "disable auto-update" within the preferences section..... Why make it so difficult to turn off updates??

    I don't generally like updates.

    WHY??

    It just makes me want to go back to using Microsoft Outlook.

    Problem is not solved as I still can't find a way to turn off the annoying pop-up window that comes on each time I run Zimbra Desktop.

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Quote Originally Posted by mutface View Post
    Problem is not solved as I still can't find a way to turn off the annoying pop-up window that comes on each time I run Zimbra Desktop.
    Well, I run ZD on an openSUSE 11.1 system and file location given above is correct for the preferences.js (the update option is in there) file so I guess this thread will stay marked as solved. Try doing a 'find' on your PC for that file.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Quote Originally Posted by mutface View Post
    It just makes me want to go back to using Microsoft Outlook
    When did they make a version of Outlook for openSUSE?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Quote Originally Posted by mutface View Post
    "disable auto-update" within the preferences section.....
    fyi: there will be one in zd 1.1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •