Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Proxy Settings for Zimbra Desktop in Linux

  1. #1
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default Proxy Settings for Zimbra Desktop in Linux

    Can anyone tell me where to change the proxy server settings for the Zimbra Desktop under Linux? Every day a short time after I launch the Zimbra Desktop I am prompted for a user name and password for my proxy server. This makes sense because the proxy server that it is using requires authentication. However, I'd like to change the proxy settings to another server that does not require authentication and I can't seem to find where this setting lives. I thought it might be tied to another program's settings, but I've checked my .bashrc, Firefox, Konqueror, and Opera but none of them are using this particular proxy server. I've disabled auto updates in the preferences.js file, but I still get prompted at least once a day for the user name and password.

    Thanks,
    John

  2. #2
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Desktop currently doesn't support proxy. It's a roadmap item.

  3. #3
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Quote Originally Posted by jjzhuang View Post
    Desktop currently doesn't support proxy. It's a roadmap item.
    Why then am I prompted to enter my proxy authentication everyday after starting up the desktop? This appears to be related to the software doing a version check or something like that, rather than the desktop going through a proxy to connect to the Zimbra server.

  4. #4
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    can you attach a screenshot of the prompt?

  5. #5
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Quote Originally Posted by jmhe View Post
    can you attach a screenshot of the prompt?
    Screenshot attached (I blurred out a few sections for privacy reasons). This actually came up when I received an email that apparently needed to retrieve some info from the Internet.
    Attached Images Attached Images

  6. #6
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    You must have some proxy service running on the network that is prompting that dialog to you.

    Judging by the screenshot, I think your ZD was loading an HTML message and it's trying to fetch images on that HTML page from another web server - that's what triggered the prompt.

    What if you click on a text message or a message that has no image in it, do you still get the same prompt?

    Anyway, I don't think that dialog is from ZD.

  7. #7
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Quote Originally Posted by jmhe View Post
    Anyway, I don't think that dialog is from ZD.
    Sorry to disagree, but this dialog is absolutely from ZD. Note the Zimbra icon in the top left of the authentication box that appears. Also note the bottom left of the ZD screen where it says "Waiting for gw.vtrenz.net". This will stay until I answer the prompt. I never see this window if I don't have ZD running. The box does not come up with normal text messages. I can make this box appear on demand. If I launch ZD and then click on this message or some other one that wants to download images from the the 'Net I get the prompt. After I put it in once I never get the prompt again, unless I close and restart ZD.

  8. #8
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Quote Originally Posted by soxfan View Post
    Sorry to disagree, but this dialog is absolutely from ZD. ...
    Yeah, I take that back. This dialog is from ZD (actually from the XULRunner framework, which is also what Firefox is built on). I guess you have an HTTP proxy setup on your network and it's returning 407 Proxy Authentication Required error - which triggered that dialog. ZD caches your login info, until ZD is restarted.

    Let me see if I can find a workaround for you - like caching your login info persistently.

  9. #9
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    You should be able to use a different proxy server with these lines in your profile/user.js. You need to restart ZD after the change.

    user_pref(”network.proxy.http”, “<your proxy server host/ip>″);
    user_pref(”network.proxy.http_port”, <your proxy server port>);
    user_pref(”network.proxy.type”, 1);
    user_pref("network.proxy.no_proxies_on", "localhost, 127.0.0.1");

    For more information on network proxy preferences, please check out the links here: (network.proxy.xxxxxx)

    Category:Preferences - MozillaZine Knowledge Base
    Last edited by jmhe; 03-04-2009 at 03:58 PM.

  10. #10
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    You should be able to use a different proxy server with these lines in your profile/user.js. You need to restart ZD after the change
    Thanks for your continued help with this, but unfortunately adding these lines did not solve the problem. I tried adding them to the uesr.js file as you suggested and I also tried adding them to the prefs.js file, which is where I found them in my Firefox profile. I shutdown and restarted ZD from the command line after making the changes, and also tried totally rebooting my PC after the simple command line restart did not work. There were no references to proxy settings in either the user.js and prefs.js prior to me adding these lines, so I still go back to my question of where is ZD getting these settings in the first place? We have a few different proxy servers running. We do not have any network services that would allow an application to automatically pick up the proxy settings. If I use any web app under any operating system, whether it be Linux, Windows, or Mac I am required to manually enter the proxy settings.

    I did some additional testing on the same workstation by setting up the Zimbra Desktop under a different Unix account and using a different Zimbra account. I then forwarded along the particular message that I know prompts me for the proxy settings. Under this different account I was never prompted for the proxy settings and the html loaded up fine when I click on the "Display Images" button.

    I'm stumped.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Desktop proxy support
    By Satoru in forum General Questions
    Replies: 15
    Last Post: 08-05-2010, 12:04 PM
  2. Problem running Zimbra desktop in a custom Linux environment
    By respirit in forum Installation Help
    Replies: 1
    Last Post: 01-05-2009, 12:39 PM
  3. Proxy Server Used for Auto-Update Under Linux
    By soxfan in forum General Questions
    Replies: 0
    Last Post: 10-17-2008, 06:27 AM
  4. Desktop on Linux
    By Mo_Hong in forum General Questions
    Replies: 2
    Last Post: 03-28-2007, 10:18 AM
  5. Antivirus suddenly stop
    By kowell in forum Administrators
    Replies: 17
    Last Post: 03-27-2007, 04:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •