Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Can I make links open in my default browser?

  1. #1
    PeterSteele is offline Active Member
    Join Date
    Feb 2009
    Posts
    27
    Rep Power
    6

    Default Can I make links open in my default browser?

    If I receive emails with links in them, clicking on that link opens the target URL in a zdesktop window. I'd prefer to have links open in my default browser (Firefox right now). Can this be configured?

  2. #2
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    7

    Default

    It should always use your default browser, unless

    1) You don't have default browser set (I've seen such case on Linux)
    2) Your browser (e.g. FF) is in the middle of upgrading
    3) You are running into this bug, which should be fixed in RC2 (Bug 33815 – Zimbra Desktop Client does not use default browser for one part hostnames)

  3. #3
    PeterSteele is offline Active Member
    Join Date
    Feb 2009
    Posts
    27
    Rep Power
    6

    Default

    Well, I definitely have a default browser set, and I'm not in the middle of an upgrade. In doing some more tests it seems some links do open in my default browser whereas others do not, and the behavior appears to match that described in the bug. So I'll just wait for RC2...

  4. #4
    partypooper is offline Intermediate Member
    Join Date
    Oct 2005
    Posts
    16
    Rep Power
    9

    Default Hi

    Same thing here.
    Using Ubuntu 8.10 and latest Zimbra destkop.
    Any clues?

  5. #5
    webman's Avatar
    webman is offline Special Member
    Join Date
    Oct 2007
    Location
    North East England
    Posts
    167
    Rep Power
    7

    Default

    We use Prism from the Zimbra Desktop package to access our internal Zimbra open source server, and I made this small modification to get anything other than our email subdomain (mail.example.com) to open in the default browser:

    ./Prism/extensions/prism-runtime@developer.mozilla.org/chrome/webrunner/content/webrunner.js

    Line 487, change return to true so it's like this full block of code:

    Code:
        var linkDomain = this._getBaseDomain(aURI);
        // Can't use browser.currentURI since it causes reentrancy into the docshell.
        if (!linkDomain || (linkDomain == this._currentDomain))
          return true;		// default: false CR 2009-01-05 CHANGE TO TRUE TO ALLOW other subdomains to load in new window
        else
          return true;		// default: true
      },
    URLs in mail.example.com (like documents) still open in Prism windows, and everything else in the default browser.

    I've never understood all the seemingly-duplicated Mozilla directories and files; and it may well have changed in later versions.
    Craig Rodway » Flickr | Last.fm | Del.icio.us | Twitter

  6. #6
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    7

    Default

    Try these steps:

    1) Open FF, Advanced|General|System Defaults, check the box of "Always check to see if FF is the default browser on startup"

    2) System|Preferences|Preferred Applications|Web Browser, choose Custom, the Command should be something like: /opt/firefox/firefox "%s", depending on where you installed FF.

    3) restart ZD, test on an url inside an email.



    Quote Originally Posted by partypooper View Post
    Same thing here.
    Using Ubuntu 8.10 and latest Zimbra destkop.
    Any clues?

  7. #7
    Netlurker is offline New Member
    Join Date
    Jun 2009
    Location
    Cincinnati, OH
    Posts
    3
    Rep Power
    5

    Default Not working right for me either

    I am having this same issue with Ubuntu 8.10 (64 bit) and the latest ZD. I did not notice this issue prior to the last ZD update. (However I also recently changed to the 64 bit version of Ubuntu so I can't be 100% sure which is the cause.) I have a default browser set (Firefox) but also tried the custom command and the javascript change to no avail.

  8. #8
    bradb21's Avatar
    bradb21 is offline Advanced Member
    Join Date
    Aug 2007
    Location
    Chicago Area, USA
    Posts
    189
    Rep Power
    7

    Default

    Ubuntu 9.04 with Firefox as my default browser and all my links still open in Prism and not Firefox.
    Release 6.0.2_GA_1912.UBUNTU8_64 UBUNTU8_64 NETWORK edition + Mobile Option
    Activesync with Moto Q9C, HTC Touch Pro, Palm Pro, & Palm Pre

  9. #9
    Netlurker is offline New Member
    Join Date
    Jun 2009
    Location
    Cincinnati, OH
    Posts
    3
    Rep Power
    5

    Default Update

    I have now moved to Ubuntu 9.04 but went back to 32-bit (too much hassle getting everything to work in 64-bit.) I no longer have the issue. So, it appears to be related to 64-bit Ubuntu.

  10. #10
    bradb21's Avatar
    bradb21 is offline Advanced Member
    Join Date
    Aug 2007
    Location
    Chicago Area, USA
    Posts
    189
    Rep Power
    7

    Default

    That would hold true for me because I'm running 64bit Ubuntu 9.04 on my laptop and I have issue.
    Release 6.0.2_GA_1912.UBUNTU8_64 UBUNTU8_64 NETWORK edition + Mobile Option
    Activesync with Moto Q9C, HTC Touch Pro, Palm Pro, & Palm Pre

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 42
    Last Post: 08-11-2006, 09:50 AM
  2. open port 7071
    By pgrayove in forum Users
    Replies: 5
    Last Post: 03-30-2006, 09:08 AM
  3. The mailbox and mta dies in FC4 GA version
    By meikka in forum Installation
    Replies: 72
    Last Post: 03-16-2006, 05:30 PM
  4. Move server to different OS
    By EriSan500 in forum Administrators
    Replies: 7
    Last Post: 03-05-2006, 01:00 PM
  5. Zimbra Security
    By mikea in forum Administrators
    Replies: 4
    Last Post: 10-22-2005, 08:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •