Results 1 to 9 of 9

Thread: mailto is not a registered protocol

  1. #1
    jfurfey is offline Starter Member
    Join Date
    Jan 2009
    Posts
    1
    Rep Power
    6

    Default mailto is not a registered protocol

    Running latest Zimbra Desktop version on OS X Leopard. mailto links bring up the Zimbra Desktop client, but I get this message.

    Alert!
    mailto is not a registered protocol

    Any way to fix this? I have already told Zimbra Desktop to act as my default mail client.

  2. #2
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    it's fixed in this bug Bug 34342 – Use Zimbra Desktop as default mail application does not work please try again in the coming release

  3. #3
    amb1545 is offline Member
    Join Date
    Dec 2007
    Posts
    12
    Rep Power
    7

    Default

    Quote Originally Posted by jmhe View Post
    it's fixed in this bug Bug 34342 – Use Zimbra Desktop as default mail application does not work please try again in the coming release
    Do you know what release this is supposed to be fixed in? I am experiencing it in build 1513 (which ZCD says is the latest).

  4. #4
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    Is it on Mac? Please try to register Mail.app as the default mail app first; then go to Options and register ZD as default again.

    Quote Originally Posted by amb1545 View Post
    Do you know what release this is supposed to be fixed in? I am experiencing it in build 1513 (which ZCD says is the latest).

  5. #5
    amb1545 is offline Member
    Join Date
    Dec 2007
    Posts
    12
    Rep Power
    7

    Default

    Yes this is on 10.5.6. I have tried the above several times and I am still receiving the error message in ZCD.

  6. #6
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    What do you see under Mail.app->Preferences->Default email reader:?

    Please also try this:

    1) While running YZD, press Shift-F6 to bring out status bar
    2) Click on the Gear icon on status bar->Tools->Error Console
    3) Click an mailto link in Firefox

    Do you see any errors in Error Console (pls ignore all warnings)? If so please paste the errors here. Thanks.


    Quote Originally Posted by amb1545 View Post
    Yes this is on 10.5.6. I have tried the above several times and I am still receiving the error message in ZCD.

  7. #7
    brandonhowe is offline Starter Member
    Join Date
    May 2009
    Posts
    2
    Rep Power
    6

    Default

    I am seeing this error in ZD build 1537 on OS X 10.5.7.
    ZD is the default mail handler.
    No error codes in ZD.

  8. #8
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    please try the following:

    1) run Mail.app (e.g. Spotlight->Mail)
    2) Mail->Preferences->General->Default email reader, set it to be Mail.app
    3) Quit Mail.app
    4) go to ZD, check the box for Options->Global->Other->Use Zimbra Desktop as default mail application
    5) Open Firefox or Safari, go to MailTo Syntax, click on any of the mailto links.

    Let me know whether you still see the error.

    Quote Originally Posted by brandonhowe View Post
    I am seeing this error in ZD build 1537 on OS X 10.5.7.
    ZD is the default mail handler.
    No error codes in ZD.

  9. #9
    brandonhowe is offline Starter Member
    Join Date
    May 2009
    Posts
    2
    Rep Power
    6

    Default

    That cleared it up. I think I was just mis-reading the part about making Mail.app the default in Mail. I kept changing it back to Zimbra.

    Works fine now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. support for Firefox 3 mailto protocol handler?
    By ScottChapman in forum Developers
    Replies: 19
    Last Post: 05-21-2012, 07:13 PM
  2. correct mailto handler without toaster
    By bdial in forum Administrators
    Replies: 3
    Last Post: 12-17-2008, 08:16 AM
  3. Mailto Link Handling
    By pnkrkrgeo in forum General Questions
    Replies: 7
    Last Post: 08-01-2008, 01:32 AM
  4. new message window is completely blank after clicking mailto links.
    By rich@specialai.com in forum General Questions
    Replies: 1
    Last Post: 06-10-2008, 03:51 PM
  5. Handling mailto tags?
    By The Craw in forum Administrators
    Replies: 2
    Last Post: 11-27-2007, 11:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •