Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Logger and Mailbox stop after reboot

  1. #1
    arvinderpb is offline Member
    Join Date
    Oct 2008
    Location
    India/Punjab
    Posts
    10
    Rep Power
    6

    Exclamation [SOLVED] Logger and Mailbox stop after reboot

    Hello All, i have very serious problem with zimbra server. My server was working fine from lost one month. today i reboot the server for some hardware issue. after reboot my zimbra server is not running. i check the status with

    it show

    mbra@mail:/root> zmcontrol status
    Host mail.XXXX
    antispam Running
    antivirus Running
    ldap Running
    logger Stopped
    logmysql.server is not running
    mailbox Stopped
    mysql.server is not running
    mta Running
    snmp Running
    spell Running
    stats Stopped

    zimbra@mail:/root> mysql.server status
    mysql is not running


    what to do??? urgent required solution. Its my production server and my all mails are stoped.

    thanks for advance

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Which Zimbra version and release? Update your forum profile with the output of:

    Code:
    zmcontol -v
    What errors do you see in the log files? If you search the forums you'll find some threads and answers on his problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    arvinderpb is offline Member
    Join Date
    Oct 2008
    Location
    India/Punjab
    Posts
    10
    Rep Power
    6

    Default

    Thanks phoenix for reply,

    zimbra@mail:/root> zmcontrol -v


    Release 5.0.10_GA_2638.SuSEES10_20081003055958 SuSEES10 FOSS edition

    My server was working fine yesterday. After reboot the server zimbra server stop working. when i checked it show SQL server is not running. Thats why it show logger and mailbox stopped.

    Please advice me what to do? also tell me which log file show me proper error for this.

    waiting reply.

  4. #4
    arvinderpb is offline Member
    Join Date
    Oct 2008
    Location
    India/Punjab
    Posts
    10
    Rep Power
    6

    Default

    Checked log files /opt/zimbra/log/mysql.error.log and it shows

    081227 10:58:49 mysqld started
    081227 10:58:49 [ERROR] Can't start server: cannot resolve hostname!: No such file or directory
    081227 10:58:49 mysqld ended

    but my DNS server resolve my zimbra mail server properly.

    mail:~ # nslookup mail.deepakfasteners.com
    Server: 192.168.0.95
    Address: 192.168.0.95#53

    Name: mail.deepakfasteners.com
    Address: 192.168.0.96

    mail:~ # ping mail.deepakfasteners.com
    PING mail.deepakfasteners.com (192.168.0.96) 56(84) bytes of data.
    64 bytes from mail.deepakfasteners.com (192.168.0.96): icmp_seq=1 ttl=64 time=0.027 ms
    64 bytes from mail.deepakfasteners.com (192.168.0.96): icmp_seq=2 ttl=64 time=0.009 ms

    --- mail.deepakfasteners.com ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 1002ms
    rtt min/avg/max/mdev = 0.009/0.018/0.027/0.009 ms

    zimbra@mail:~/mysql/bin> ./resolveip mail.deepakfasteners.com
    IP address of mail.deepakfasteners.com is 192.168.0.96

    zimbra@mail:~/mysql/bin> ./resolveip 192.168.0.96
    Host name of 192.168.0.96 is mail.deepakfasteners.com



    there is no log file name /opt/zimbra/log/mysqld.log

    what would be the problem?

    Thanks in advance
    Last edited by arvinderpb; 12-27-2008 at 07:04 AM.

  5. #5
    arvinderpb is offline Member
    Join Date
    Oct 2008
    Location
    India/Punjab
    Posts
    10
    Rep Power
    6

    Default

    waiting reply

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Quote Originally Posted by arvinderpb View Post
    waiting reply
    What are you mad about? If you'd searched the forums you will find many posts covering your problem and what to do to diagnose it.

    It would appear you have a DNS problem. Is the firewall and apparmor disabled on your Zimbra server? Post the output of the following commands (run on the zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com any
    dig yourdomain.com mx
    host `hostname`  <-- use backticks not single quotes
    Please format the output of each command with 'code', highlight your text and hit the code (the # symbol) above the edit box.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    arvinderpb is offline Member
    Join Date
    Oct 2008
    Location
    India/Punjab
    Posts
    10
    Rep Power
    6

    Default

    Thanks Bill for reply. I was searchng from last two days but nothing to find for my problem.

    here is asked commands ouputs




    Code:
    mail:~ # cat /etc/hosts
    #
    # hosts         This file describes a number of hostname-to-address
    #               mappings for the TCP/IP subsystem.  It is mostly
    #               used at boot time, when no name servers are running.
    #               On small systems, this file can be used instead of a
    #               "named" name server.
    # Syntax:
    #
    # IP-Address  Full-Qualified-Hostname  Short-Hostname
    #
    
    127.0.0.1       localhost
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    192.168.0.96    mail mail

    Code:
    mail:~ # cat /etc/resolv.conf
    nameserver 192.168.0.95
    domain deepakfasteners.com
    Code:
    mail:~ # dig deepakfasteners.com any
    
    ; <<>> DiG 9.3.2 <<>> deepakfasteners.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29430
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 4
    
    ;; QUESTION SECTION:
    ;deepakfasteners.com.           IN      ANY
    
    ;; ANSWER SECTION:
    deepakfasteners.com.    600     IN      A       192.168.2.95
    deepakfasteners.com.    600     IN      A       192.168.200.95
    deepakfasteners.com.    600     IN      A       192.168.0.95
    deepakfasteners.com.    3600    IN      NS      server.deepakfasteners.com.
    deepakfasteners.com.    3600    IN      SOA     server.deepakfasteners.com. hostmaster. 6438 900 600 86400 3600
    deepakfasteners.com.    3600    IN      MX      10 mail.deepakfasteners.com.
    
    ;; ADDITIONAL SECTION:
    server.deepakfasteners.com. 3600 IN     A       192.168.0.95
    server.deepakfasteners.com. 3600 IN     A       192.168.200.95
    server.deepakfasteners.com. 3600 IN     A       192.168.2.95
    mail.deepakfasteners.com. 3600  IN      A       192.168.0.96
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.95#53(192.168.0.95)
    ;; WHEN: Sun Dec 28 15:48:57 2008
    ;; MSG SIZE  rcvd: 237


    Code:
    mail:~ # dig deepakfasteners.com mx
    
    ; <<>> DiG 9.3.2 <<>> deepakfasteners.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33166
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;deepakfasteners.com.           IN      MX
    
    ;; ANSWER SECTION:
    deepakfasteners.com.    3600    IN      MX      10 mail.deepakfasteners.com.
    
    ;; ADDITIONAL SECTION:
    mail.deepakfasteners.com. 3600  IN      A       192.168.0.96
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.95#53(192.168.0.95)
    ;; WHEN: Sun Dec 28 15:50:17 2008
    ;; MSG SIZE  rcvd: 74


    Code:
    mail:~ # host 'mail'
    mail.deepakfasteners.com has address 192.168.0.96
    mail:~ #
    Last edited by phoenix; 12-28-2008 at 06:39 AM.

  8. #8
    arvinderpb is offline Member
    Join Date
    Oct 2008
    Location
    India/Punjab
    Posts
    10
    Rep Power
    6

    Default

    i don't have enable firewall and AppArmor on my zimbra mail server.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Read the requirements for the hosts file in the Quick Start Installation Guide and modify yours accordingly.


    The output from this is incorrect:
    Code:
    mail:~ # host 'mail'
    mail.deepakfasteners.com has address 192.168.0.96
    mail:~ #
    that is not the format of the command I asked you to run, use the command I gave you earlier in the exact format I've shown you.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    arvinderpb is offline Member
    Join Date
    Oct 2008
    Location
    India/Punjab
    Posts
    10
    Rep Power
    6

    Default

    My server was working fine from last 2 months with these confrigurations anyway

    i have change the /etc/hosts file as follow

    Code:
    mail:~ # cat /etc/hosts
    #
    # hosts         This file describes a number of hostname-to-address
    #               mappings for the TCP/IP subsystem.  It is mostly
    #               used at boot time, when no name servers are running.
    #               On small systems, this file can be used instead of a
    #               "named" name server.
    # Syntax:
    #
    # IP-Address  Full-Qualified-Hostname  Short-Hostname
    #
    
    127.0.0.1       localhost
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    192.168.0.96    mail.deepakfasteners.com mail
    and the output of host mail.deepakfasteners.com server <- server is my DNS server on windows serverf 2003

    Code:
    zimbra@mail:/root> host mail.deepakfasteners.com server
    Using domain server:
    Name: server
    Address: 192.168.0.95#53
    Aliases:
    
    mail.deepakfasteners.com has address 192.168.0.96
    Using domain server:
    Name: server
    Address: 192.168.0.95#53
    Aliases:
    
    Using domain server:
    Name: server
    Address: 192.168.0.95#53
    Aliases:

    After reboot the problem is same. what eles to check?
    Last edited by arvinderpb; 12-28-2008 at 10:12 AM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [need help] logger and mailbox stopped
    By scotch in forum Installation
    Replies: 0
    Last Post: 12-05-2008, 09:43 AM
  2. Mailbox and logger not starting - SLES9 M3 Beta436
    By DanielP in forum Installation
    Replies: 49
    Last Post: 08-25-2008, 03:23 AM
  3. After reboot mailbox and tomcat don't start
    By gon in forum Administrators
    Replies: 1
    Last Post: 11-02-2007, 11:50 AM
  4. problem with logger and mailbox
    By pepe27 in forum Installation
    Replies: 1
    Last Post: 04-05-2006, 07:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •