Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Zimbra Desktop proxy support

  1. #1
    Satoru is offline Active Member
    Join Date
    Sep 2007
    Posts
    28
    Rep Power
    7

    Smile Zimbra Desktop proxy support

    Hello guys,
    I just dowloaded beta3 on my laptop/Windows xp SP2. My Zimbra server is on the Internet, so direct connect from the Internet works fine
    However in my office, direct connect to the internet of http/https trafic isn't allowed, so have to connect via proxy
    Are there any way to use Zimbra desktop via proxy?
    Any suggestions will be appreciated,

    Satoru

  2. #2
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    there's no proxy support in 1.0. the only workaround i can think of is to run your own reverse proxy. for zimbra sync everything is http, so it should work.

  3. #3
    Satoru is offline Active Member
    Join Date
    Sep 2007
    Posts
    28
    Rep Power
    7

    Default

    Thanks your reply.
    Could you tell me software name that run reverse proxy on the same PC runs Zimbra desktop (Windows xp SP2)?

  4. #4
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    I don't actually use one myself so can't really recommend any. Maybe other forum members can help here.

  5. #5
    Kallisti is offline Loyal Member
    Join Date
    Jan 2008
    Posts
    79
    Rep Power
    7

    Default

    Hi guys!

    I have tried two programs, ProxyCap and Proxifier, and I can't get either of them to work with ZD. Other programs are fine but not ZD. I don't really see the benefit of of Zs choice of making the server part a service but I guess it makes things like this and going offline a bit more complicated. At least Proxifier (I think it was) claims to work with services. However no traffic from zd shows up at all and is definitively not proxied.

    How complex can it be to implement proxy support in zd, anyway?

    /K

    PS. for reference the bug is 30313. Be sure to read the whole bug!

  6. #6
    darkmemory is offline Junior Member
    Join Date
    May 2007
    Posts
    6
    Rep Power
    7

    Default

    You have to run the service under a windows account and not the default "Local System" account. Once you have it running under your windows account chances are that your reverse proxy will work (depending on how the RP works). I was able to get ZD working on my windows box behind an ISA proxy by setting the service account to use my logon credentials and running the "Microsoft Firewall Client for ISA server".

    ~V~

  7. #7
    Kallisti is offline Loyal Member
    Join Date
    Jan 2008
    Posts
    79
    Rep Power
    7

    Default

    Thanks for trying to help. Unfortunately I have tried with using a local system account with the permission to interact, a domain account in the local administrator group, a local account in the users group and a local account in the admin group.

    What I have discovered though is that, according to the logs, my zd-process is not doing anything, not even trying to reach my zcs when I use a named account. So having it run as a system account bypasses the proxy and with a named account it won't even try! :/

    /K

  8. #8
    Kallisti is offline Loyal Member
    Join Date
    Jan 2008
    Posts
    79
    Rep Power
    7

    Default

    Hi again!

    New ZD version but no fix. Still can't use the proxifier workaround. Are there anyone looking into this or does anyone have a working workaround?

    /K

  9. #9
    Kallisti is offline Loyal Member
    Join Date
    Jan 2008
    Posts
    79
    Rep Power
    7

    Default

    I have submitted a new bug to follow the progress of this situation.
    /K

  10. #10
    Kallisti is offline Loyal Member
    Join Date
    Jan 2008
    Posts
    79
    Rep Power
    7

    Default

    I'm answering a question from the bug here to keep bugzilla uncluttered:

    I have ZD installed and Proxifier 2.8. My company uses a http proxy so I have set it up in Proxifier. Firefox, Miranda IM, MediaMonkey etc. uses Proxifier to reach internet. In all these programs I have configured them to access internet directly, no proxy settings. Proxifier works by intercepting and redirecting the traffic through the http proxy.

    As Proxifier has a connections view I can monitor each application/process that is intercepted by Proxifier. One such process i zdclient.exe, accessing the upgrade information. zdesktop.exe never shows up. According to the Proxifier manual the program supports proxifying services as well as normal applications. Following Proxifier instructions I have checked that the service is allowed to interact with the desktop. I have also tried having zdesktop log on with my domain account and with a local account, restarting the service between all the changes. Proxifier never shows a zdesktop.exe process.

    /K

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  4. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  5. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •