Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: I got this error message.

  1. #1
    Derf is offline Junior Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    7

    Default I got this error message.

    I installed zdesktop on Fedora core7 and that went fine. But starting zimbra gave me this error...








    [root@softwareworkstation1 init.d]# ./zdesktop start
    Starting zdesktop
    [root@softwareworkstation1 init.d]# nohup: appending output to `nohup.out'

    ************************************************** **********************************************


    1 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog
    597 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7633
    600 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7634
    600 [main] INFO org.mortbay.log - jetty-6.1.2rc1
    1581 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.
    log4j:WARN No appenders could be found for logger (zimbra.misc).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server process is running as root, changing to user=zimbra uid=-1 gid=-1
    Zimbra server process, after change, is running with uid=-1 euid=-1 gid=-1 egid=-1
    ZoneInfo: /root/zimbra/zdesktop/jre/lib/zi/ZoneInfoMappings (Permission denied)
    1 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog
    328 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7633
    331 [main] INFO org.mortbay.log - Started SelectChannelConnector @ localhost:7634
    332 [main] INFO org.mortbay.log - jetty-6.1.2rc1
    582 [main] INFO org.mortbay.log - No Transaction manager found - if your webapp requires one, please configure one.
    log4j:WARN No appenders could be found for logger (zimbra.misc).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server process is running as root, changing to user=zimbra uid=-1 gid=-1
    Zimbra server process, after change, is running with uid=-1 euid=-1 gid=-1 egid=-1
    ZoneInfo: /root/zimbra/zdesktop/jre/lib/zi/ZoneInfoMappings (Permission denied)

    ************************************************** **************************************************

    What im i doing wrong

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I just realized my other post may be have been wrong. Why is the UID -1?

    That may be a problem on our end.

    Also, the zimbra user may not have access to /root

  3. #3
    Derf is offline Junior Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    7

    Default

    Yea could be my bad for installing under root. Ill reinstall and give an update on that.
    Thanks for the tip.

  4. #4
    Derf is offline Junior Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    7

    Default

    Hey,
    No luck, I reinstalled zdesktop (under a different directory) and its still not starting up.
    Same error message

    Any ideas?

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I think it might be related to this:
    Code:
    Zimbra server process is running as root, changing to user=zimbra uid=-1 gid=-1
    Zimbra server process, after change, is running with uid=-1 euid=-1 gid=-1 egid=-1
    File a bug on that.

  6. #6
    Derf is offline Junior Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    7

    Default

    Will do
    thanks for the help

  7. #7
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Are you running as root? It can't be run as root. We'll make it more friendly but running as root is always bad. Thanks!

  8. #8
    Derf is offline Junior Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    7

    Default

    I cant start the zdesktop server without being root because i don't have sufficient rights as a regular user. So I have to run it as root. Is there a way i can start the zdesktop server without changing my user settings?

  9. #9
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    We have a check to make sure the server is not running as root. This is a security measure. It's definitely a good idea to run any application not as root, especially with something complex like zdesktop. Thanks!

  10. #10
    Derf is offline Junior Member
    Join Date
    Jun 2007
    Posts
    9
    Rep Power
    7

    Default

    Zimbra server process is running as uid=0 euid=0 gid=0 egid=0
    Fatal error: terminating: can not start server with uid of 0


    How can I change the uid?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •