Hi,

Installed Zimbra OSE a week or so ago and am quite impressed. Good work Zimbra team.

Decided to sign up to the wiki (have a few discoveries and solutions to share) and the forum. So why didn't my confirmation email come through?

Code:
May 26 20:50:32 mail postfix/smtpd[15926]: connect from mta02.zimbra.com[205.140.197.62]
May 26 20:50:32 mail postfix/smtpd[15926]: NOQUEUE: reject: RCPT from mta02.zimbra.com[205.140.197.62]: 450 4.1.8 <apache@www-prod-3.zimbra.com>: Sender address rejected: Domain not found; from=<apache@www-prod-3.zimbra.com> to=<xxx@xxx.xxx> proto=ESMTP helo=<mta02.zimbra.com>
May 26 20:50:33 mail postfix/smtpd[15926]: disconnect from mta02.zimbra.com[205.140.197.62]
I would really like to keep the postfix option 'reject_unknown_sender_domain' enabled - it is very effective in the fight against spam, yet Zimbra's own mail domain, at least 'www-prod-3.zimbra.com' has neither an A or MX record! Seems strange for a company where this is their business.

Code:
; <<>> DiG 9.6.0-APPLE-P2 <<>> any www-prod-3.zimbra.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 61626
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;www-prod-3.zimbra.com.		IN	ANY

;; AUTHORITY SECTION:
zimbra.com.		600	IN	SOA	sc9-ext-dns-1.vmware.com. hostmaster.vmware.com. 2010051301 3600 900 604800 600

;; Query time: 41 msec
;; SERVER: 10.1.1.1#53(10.1.1.1)
;; WHEN: Wed May 26 21:15:30 2010
;; MSG SIZE  rcvd: 107
So, in short, don't tick the 'Sender's domain (reject_unknown_sender_domain)' box under 'DNS Checks' in 'Global Settings -> MTA', otherwise you won't get any email from Zimbra!

n.