I am using Zimbra Desktop on the latest Mac OS X (including the latest Java release that came out from Apple in the past day or two). I have been running beta 10515 for a month or two and it worked fine... now when I upgrade to the released version 2.0 (version 10580) it stops working with the following set of errors. I have tried to get it working many times but have to keep rolling back to the beta. Can someone please help me?

We use Zimbra on the back end as well.

Exception:

java.lang.AssertionError
at com.zimbra.cs.index.LuceneIndex.doneWriting(Lucene Index.java:754)
at com.zimbra.cs.index.LuceneIndex.endWriteOperation( LuceneIndex.java:793)
at com.zimbra.cs.index.MailboxIndex.endWriteOperation (MailboxIndex.java:272)
at com.zimbra.cs.mailbox.IndexHelper.indexingPartOfEn dTransaction(IndexHelper.java:1037)
at com.zimbra.cs.mailbox.Mailbox.endTransaction(Mailb ox.java:7011)
at com.zimbra.cs.mailbox.Mailbox.saveDraft(Mailbox.ja va:4817)
at com.zimbra.cs.mailbox.Mailbox.saveDraft(Mailbox.ja va:4744)
at com.zimbra.cs.mailbox.InitialSync.saveMessage(Init ialSync.java:1252)
at com.zimbra.cs.mailbox.InitialSync.syncMessagesAsTg z(InitialSync.java:1027)
at com.zimbra.cs.mailbox.InitialSync.syncMessages(Ini tialSync.java:960)
at com.zimbra.cs.mailbox.InitialSync.syncMessagelikeI tems(InitialSync.java:441)
at com.zimbra.cs.mailbox.DeltaSync.deltaSync(DeltaSyn c.java:247)
at com.zimbra.cs.mailbox.DeltaSync.sync(DeltaSync.jav a:89)
at com.zimbra.cs.mailbox.DeltaSync.sync(DeltaSync.jav a:73)
at com.zimbra.cs.mailbox.MailboxSync.sync(MailboxSync .java:180)
at com.zimbra.cs.mailbox.ZcsMailbox.sync(ZcsMailbox.j ava:119)
at com.zimbra.cs.mailbox.ZcsMailbox.syncOnTimer(ZcsMa ilbox.java:100)
at com.zimbra.cs.mailbox.SyncMailbox$1.run(SyncMailbo x.java:262)
at java.util.TimerThread.mainLoop(Timer.java:512)
at java.util.TimerThread.run(Timer.java:462)

If issue persists please post description and debug information here.