Results 1 to 8 of 8

Thread: Roundup of issues in Zimbra Desktop 2 beta 1

  1. #1
    storm's Avatar
    storm is offline Advanced Member
    Join Date
    May 2006
    Location
    London, UK
    Posts
    176
    Rep Power
    8

    Default Roundup of issues in Zimbra Desktop 2 beta 1

    Here is a round-up summarising a number of issues with the first beta.

    (I'll link or create any associated bugs where appropriate, or point them out to me if you know), note some of these issues are known/stated issues:

    No proxy or web access for zimlets
    Bug 30313; support for proxying from Zimbra desktop
    This has been discussed here, I believe: ZD2 and Proxy - so i seems it will be resolved around the next beta release.

    Zimlets do not display in mail module
    See bug: Bug 42575; Zimlets pane missing in accordion view in Mail application tab
    Installed zimlets only display from other modules (such as addressbook, tasks etc...) preventing their usage for mail-orientated tasks.

    Zimlets only work in relation to local folders
    I have created a bug for this here: Bug 44577; Zimlets work only in relation to 'Local folders' (Zimbra Desktop 2)
    The actions of Zimlets only apply to local folders, i.e. Birthday Calender reminder only creates a calender in local calenders, and only uses birthdays from local addressbook. This is particularly unhelpful. The user should be able to choose, or at least set the default account themselves, or else have an accordion-style display of zimlets at the bottom of each account tree. Vote if you want this changed quickly!

    Zimlets are not deployed
    In spite of following instructions in this thread: Deploying Zimlets in ZD2 Beta1 , zimlets were not deployed, I only managed to deploy them by creating a '_dev' folder in '~/.zdesktop/zimlets-deployed' and copying the unzipped folders into it. Of course, this is only intended for development purposes, and not for general usage.
    It is hoped that by release of Zimbra Desktop 2 final (GA) this bug will be implemented and allow users to deploy zimlets via the UI (vote to encourage it!): Bug 31419; Deploy Zimlets in Desktop (UI)

    Spell correction in html emails not functioning
    When composing an html email, right-clicking a work marked as misspelled does not offer the spell-check menu, it offers only the formatting menu. (If opening a plain text email this works ok).

    Spellcheck not functioning
    There seems to be no way of doing a mandatory spellcheck.

    Mandatory Spellcheck blocks sending of emails
    If a user sets spellcheck to be mandatory (in preferences, mail composition) then they cannot send emails as the spellcheck will not compete.
    I have created a new bug here: Bug 45085 When mandatory spell check is enabled outgoing mail cannot be sent.

    Read receipts not functioning
    I have created a new bug here: Bug 44574; Read receipt requests are not notified and cannot be accepted or declined
    Messages with read receipt requests appear to be shaded differently, but they are not explicit, and do not appear to issue any notification or ability to accept/decline.

    Default setting for responding to read-receipt requests is to refuse
    The default settings is fairly well hidden in preferences, it should be better exposed, and it should be set as default to ask the user whether to accept or refuse, not just silently refuse, or most users will never know any better. The first time a user is asked for a read-receipt they could be requested to update the setting for future.

    Cannot effectively set custom field in Contacts
    I have created a new bug here: Bug 44575; User cannot enter a field name in custom contact field as cursor constantly exits
    When setting a custom field in Contacts (under 'Other') a user can type in the field value easily enough, but when attempting to type in the field name, after entering each character the cursor jumps to the field value box!

    The current release is stated not to be fully internationalised, so hopefully these internationalisation issues will be ironed-out by the final release:

    Language reverts to US English
    I've created a bug here: Bug 44579; Chosen language is not honoured and reverts to US English
    Regardless of the language selected, the language reverts to US English (seemingly randomly, and especially, but not necessarily after a restart).

    Lack of access to internationalised dictionaries or instructions
    This would be addressed by this enhancement bug: Bug 35874: provide same way of installing/switching dictionaries as FF does - vote if you want it!
    In the meantime, I have managed to install an internationalised dictionary (in my case for the en-GB), however I had to resort to using instructions and dictionaries which were linked from a Zimbra wiki page which is no longer available (I used the Google cache of the page). There needs to be a widget in preferences where the user can automatically download and install the necessary dictionary and update settings, from within preferences. There should be documentation at least in the wiki also.

    Performance is greatly enhanced in ZD2, however the following suggestion might benefit some power users:

    Lazy loading user-customisation

    Vote if you want it! - I have created an enhancement bug here: Bug 44576; Lazy loading - user customisation
    The user should have ability to turn-off lazy loading for those modules considered necessary - i.e. Contacts (Address book) if they are in constant usage. This facility would be in preferences with a warning about potential impact on overall performance.
    Last edited by storm; 03-06-2010 at 06:25 AM. Reason: Added bug references

  2. #2
    pleo84103 is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    15
    Rep Power
    5

    Default

    May want to check out this post:
    http://www.zimbra.com/forums/error-r...up-screen.html
    This is a recent issue (late 2009) with zimbra desktop 1, that seem sto also be an issue with zimbra desktop 2. It seems to be some kind of interaction with prism, and possibly an itunes update, but it is unclear that if this is the case with zimbra desktop 2 - The above post has references to other posts which seem to me to describe similar issues in zimbra desktop 1 and some workarounds

  3. #3
    gnyce is offline Advanced Member
    Join Date
    Aug 2007
    Location
    outside Philadelphia
    Posts
    214
    Rep Power
    7

    Default

    Add to this list - changing an email message (with content already added to the message-body) from text to HTML deletes all the content...

  4. #4
    storm's Avatar
    storm is offline Advanced Member
    Join Date
    May 2006
    Location
    London, UK
    Posts
    176
    Rep Power
    8

    Default

    @gnyce and pleo84103 - thanks I'll check these out and update this list.

  5. #5
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Storm, thanks a lot for taking the effort to provide all the feedback. This is exactly what we need. It's users like you who greatly help drive the product forward. Appreciate it!

  6. #6
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Quote Originally Posted by gnyce View Post
    Add to this list - changing an email message (with content already added to the message-body) from text to HTML deletes all the content...
    I thinks you are hitting this: https://bugzilla.zimbra.com/show_bug.cgi?id=44395

  7. #7
    jjzhuang is offline Zimbra Employee
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Quote Originally Posted by jjzhuang View Post
    BTW the content is not really deleted. If you try a second time it often shows up.

  8. #8
    storm's Avatar
    storm is offline Advanced Member
    Join Date
    May 2006
    Location
    London, UK
    Posts
    176
    Rep Power
    8

    Default Mandatory Spellcheck not functioning

    I've created a new bug report: Bug 45085 When mandatory spell check is enabled outgoing mail cannot be sent.

    Until spellcheck is working, users should not enable mandatory spellcheck
    (preferences>mail>composing>'mandatory spellcheck before sending a message'

    When this is enabled, users cannot send messages. If this occurs, close the message (by clicking the top right corner of the compose tab, as you will not be able to click 'cancel'). Zdesktop will offer to save the message as a draft. Go to preferences and disable the feature, until this bug is fixed. You should be able to send mail again. Resend any unsent messages from drafts.

    Cheers,
    Störm

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •