Results 1 to 9 of 9

Thread: SSL connection failure. Please check host and port settings.

  1. #1
    cpha is offline Junior Member
    Join Date
    Nov 2009
    Posts
    5
    Rep Power
    5

    Default SSL connection failure. Please check host and port settings.

    Trying to connect to Exchange Server 2003 using IMAP.

    "receiving mail" settings work over SSL on port 993,

    However sending email under SMTP using port 465, I get the error message . "SSL connection failure. Please check host and port settings." I have also tried enabling disable TLS / Required SSL on the mail server under SMTP virtual directory and still get this error message. When I uncheck SSL, it defaults to port 25 and works.

    I have tried different ports and still get the same error.

    Would appreciate any help in this regards and thanks in advance

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Quote Originally Posted by cpha View Post
    However sending email under SMTP using port 465, I get the error message . "SSL connection failure. Please check host and port settings." I have also tried enabling disable TLS / Required SSL on the mail server under SMTP virtual directory and still get this error message. When I uncheck SSL, it defaults to port 25 and works.
    Does the server support sending mail via Port 465? You may have to ask the Exchange administrator if that's supported.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    cpha is offline Junior Member
    Join Date
    Nov 2009
    Posts
    5
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    Does the server support sending mail via Port 465? You may have to ask the Exchange administrator if that's supported.
    Yes it does. If i telnet to the mail server on port 465, i was able to send the email.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Are you sure that it requires SSL on port 465? Have you tried unchecking that and changing the port to see if it works?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    cpha is offline Junior Member
    Join Date
    Nov 2009
    Posts
    5
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    Are you sure that it requires SSL on port 465? Have you tried unchecking that and changing the port to see if it works?
    Yes. Also i tried changing the port and still have the problem.

    From what i understand the incoming IMAP is secured as it uses SSL, all i am trying to do is make sure that when i am sending an email, it is secured using SSL.

    I also tried using Mac Mail with IMAP settings and it works.

  6. #6
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Unless you are somehow able to negotiate an SSL connection by hand, SSL was not enabled on port 465 so I would look into how exactly you are enabling SSL, and how that port is being forwarded to your Exchange server. If you were able to "telnet to the mail server on port 465" and then send mail, my guess would be that port 465 is being forwarded to port 25.

  7. #7
    cpha is offline Junior Member
    Join Date
    Nov 2009
    Posts
    5
    Rep Power
    5

    Default

    Quote Originally Posted by ArcaneMagus View Post
    Unless you are somehow able to negotiate an SSL connection by hand, SSL was not enabled on port 465 so I would look into how exactly you are enabling SSL, and how that port is being forwarded to your Exchange server. If you were able to "telnet to the mail server on port 465" and then send mail, my guess would be that port 465 is being forwarded to port 25.
    Not sure what you mean by negotiate by hand ? I have a SSL cert installed on the exchange server. Created a new SMTP Virtual diretory in Exchange server System Management console. Associated the SSL cert on the SSL is how i have configured SSL.

    Port 465 is mapped to 25 under the SMTP protocol options.

    What do i have to do to select the check box " Use SSL encryption when sending email"?

  8. #8
    cpha is offline Junior Member
    Join Date
    Nov 2009
    Posts
    5
    Rep Power
    5

    Default

    Quote Originally Posted by ArcaneMagus View Post
    Unless you are somehow able to negotiate an SSL connection by hand, SSL was not enabled on port 465 so I would look into how exactly you are enabling SSL, and how that port is being forwarded to your Exchange server. If you were able to "telnet to the mail server on port 465" and then send mail, my guess would be that port 465 is being forwarded to port 25.
    Forgot to mention, i did telnet to port 465 and was successful in sending an email to myself.

  9. #9
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Quote Originally Posted by cpha View Post
    Port 465 is mapped to 25 under the SMTP protocol options.
    Quote Originally Posted by cpha
    i did telnet to port 465 and was successful in sending an email to myself.
    What I meant is that if you were able to telnet to port 465 without the connection (almost) instantly being closed then SSL was not enabled on that port as SSL is binary mode only. Being able to telnet to that port and send an email to yourself meant that you were simply forwarding port 465 to port 25, which will never do SSL.

    You need to remove that mapping of port 465 to port 25 as it is absolutely wrong. I am not sure exactly how you are supposed to setup SSL on an Exchange server, but XFOR: Enabling SSL For Exchange Server is probably a good place to start, other then Google of course.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SSL connection failure. Please check host and port settings.
    By anbongdem in forum General Questions
    Replies: 10
    Last Post: 03-31-2010, 08:17 AM
  2. Fail to set up pop account: SSL connection failure.
    By krabina in forum Error Reports
    Replies: 14
    Last Post: 10-25-2009, 04:16 PM
  3. Erorr..initializing ldap failed(5362)
    By Logan_filter in forum Installation
    Replies: 10
    Last Post: 12-19-2008, 01:10 PM
  4. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 09:10 AM
  5. [SOLVED] Build Zimbra..a little problem...
    By Abdelmonam Kouka in forum Developers
    Replies: 33
    Last Post: 05-22-2008, 05:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •