Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Build 1593 Broke My Linux Install

  1. #21
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Can you rename webapp.js, which can be found in the same directory as webapp.ini, to something like webapp.backjs, and try to run zd again?
    After doing this I get an alert box that says:
    Code:
    The connection was refused when attempting to contact 127.0.0.1:7633.
    Then when I click OK the application just hangs.

  2. #22
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    OK, this is really bizarre. After the failed attempt with the webapp.js file renamed I moved it back to its original name. Then just for the heck of it I tried launching ZD and wouldn't you know it now seems to be working fine. I have no idea how it would have corrected itself, but at least for right now I am OK. I will post back if I run into further issues.

  3. #23
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Think I've got it figured out. We access the Internet here through a proxy server. Previously I had discovered that the ZD proxy settings are controlled by using 'gnome-network-preferences' (even though I use KDE). The list of hosts to bypass the proxy server includes 127.0.0.0/8, which I think should mean that 127.0.0.1 should bypass the proxy server, but apparently it wasn't. I added the specific 127.0.0.1 address to the list and I believe that is what caused the ZD to work again. Note, that I haven't touched the proxy bypass list recently at all, so something in the behavior of ZD from the previous version to 1593 changed in this regard.

  4. #24
    jmhe is offline Zimbra Employee
    Join Date
    Aug 2008
    Posts
    830
    Rep Power
    8

    Default

    ah, that makes sense. thanks for letting us know.

    in previous builds, zd used localhost; since we found out many people didn't even have localhost correctly configured on their pc-s, we decided to start using 127.0.0.1 in 1593.

    Quote Originally Posted by soxfan View Post
    Think I've got it figured out. We access the Internet here through a proxy server. Previously I had discovered that the ZD proxy settings are controlled by using 'gnome-network-preferences' (even though I use KDE). The list of hosts to bypass the proxy server includes 127.0.0.0/8, which I think should mean that 127.0.0.1 should bypass the proxy server, but apparently it wasn't. I added the specific 127.0.0.1 address to the list and I believe that is what caused the ZD to work again. Note, that I haven't touched the proxy bypass list recently at all, so something in the behavior of ZD from the previous version to 1593 changed in this regard.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Linux Install
    By Gazoo2 in forum Installation
    Replies: 10
    Last Post: 05-29-2009, 12:27 AM
  2. PPC Linux install ?
    By gvl in forum Developers
    Replies: 0
    Last Post: 01-19-2009, 10:19 AM
  3. Replies: 1
    Last Post: 01-13-2009, 08:10 AM
  4. Replies: 21
    Last Post: 09-27-2007, 11:49 AM
  5. Antivirus suddenly stop
    By kowell in forum Administrators
    Replies: 17
    Last Post: 03-27-2007, 04:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •