Results 1 to 3 of 3

Thread: Connection Error....

  1. #1
    seamuslawless is offline Starter Member
    Join Date
    Oct 2008
    Posts
    2
    Rep Power
    6

    Default Connection Error....

    Hi,

    Zimbra cannot connect to my Yahoo! Mail account and is giving the following error. "Service error. Please check your server settings; verify your email address, password or client access permissions (if required)." I've enabled debug trace and when I view the logs I get the following....

    2008-10-22 11:20:22,395 INFO [sync-timer-seamuslawless@yahoo.com] [] datasource - Importing data for data source 'My Yahoo! Mail'
    2008-10-22 11:20:22,396 DEBUG [sync-timer-seamuslawless@yahoo.com] [] datasource - Generating new yauth token for user 'seamuslawless'
    2008-10-22 11:20:26,330 INFO [sync-timer-seamuslawless@yahoo.com] [] datasource - Import completed for data source 'My Yahoo! Mail'
    2008-10-22 11:20:26,331 INFO [sync-timer-seamuslawless@yahoo.com] [] offline - sync connection down: My Yahoo! Mail
    2008-10-22 11:20:26,331 DEBUG [sync-timer-seamuslawless@yahoo.com] [] offline - sync conneciton down: My Yahoo! Mail
    com.zimbra.common.service.ServiceException: system failure: Authentication failed
    ExceptionId:sync-timer-seamuslawless@yahoo.com:1224670826330:c6b1885306d3 568d
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:253)
    at com.zimbra.cs.offline.util.OfflineYAuth.authentica te(OfflineYAuth.java:51)
    at com.zimbra.cs.offline.YMailImport.<init>(YMailImpo rt.java:22)
    at com.zimbra.cs.account.offline.OfflineDataSource.ge tDataImport(OfflineDataSource.java:293)
    at com.zimbra.cs.datasource.DataSourceManager.newData Import(DataSourceManager.java:78)
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(DataSourceManager.java:158)
    at com.zimbra.cs.mailbox.LocalMailbox.importData(Loca lMailbox.java:354)
    at com.zimbra.cs.mailbox.LocalMailbox.syncAllLocalDat aSources(LocalMailbox.java:327)
    at com.zimbra.cs.mailbox.LocalMailbox.sync(LocalMailb ox.java:383)
    at com.zimbra.cs.mailbox.LocalMailbox.syncOnTimer(Loc alMailbox.java:307)
    at com.zimbra.cs.mailbox.DesktopMailbox$1.run(Desktop Mailbox.java:259)
    at java.util.TimerThread.mainLoop(Unknown Source)
    at java.util.TimerThread.run(Unknown Source)
    Caused by: java.net.ConnectException: Connection refused: connect
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(Unknown Source)
    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect (Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.<init>( Unknown Source)
    at com.sun.net.ssl.internal.ssl.SSLSocketFactoryImpl. createSocket(Unknown Source)
    at com.zimbra.common.util.EasySSLProtocolSocketFactor y.createSocket(EasySSLProtocolSocketFactory.java:1 24)
    at com.zimbra.common.util.EasySSLProtocolSocketFactor y.createSocket(EasySSLProtocolSocketFactory.java:1 65)
    at org.apache.commons.httpclient.HttpConnection.open( HttpConnection.java:706)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteWithRetry(HttpMethodDirector.java:386)
    at org.apache.commons.httpclient.HttpMethodDirector.e xecuteMethod(HttpMethodDirector.java:170)
    at org.apache.commons.httpclient.HttpClient.executeMe thod(HttpClient.java:396)
    at org.apache.commons.httpclient.HttpClient.executeMe thod(HttpClient.java:324)
    at com.zimbra.cs.util.yauth.RawAuth.doGet(RawAuth.jav a:137)
    at com.zimbra.cs.util.yauth.RawAuth.getToken(RawAuth. java:79)
    at com.zimbra.cs.util.yauth.TokenStore.newToken(Token Store.java:27)
    at com.zimbra.cs.util.yauth.MetadataTokenStore.newTok en(MetadataTokenStore.java:51)
    at com.zimbra.cs.util.yauth.RawAuthManager.authentica te(RawAuthManager.java:43)
    at com.zimbra.cs.util.yauth.RawAuthManager$1.authenti cate(RawAuthManager.java:76)
    at com.zimbra.cs.offline.util.OfflineYAuth.authentica te(OfflineYAuth.java:49)
    ... 11 more


    I thought it may have been a problem with my companies proxy so I edited /zdesktop/win32/prism/xulrunner/greprefs/all.js as follows

    pref("network.proxy.type", 2);
    //@line 798 "e:\xr19rel\WINNT_5.2_Depend\mozilla\modules\libpr ef\src\init\all.js"

    pref("network.proxy.ftp", "");
    pref("network.proxy.ftp_port", 0);
    pref("network.proxy.gopher", "");
    pref("network.proxy.gopher_port", 0);
    pref("network.proxy.http", "www-myproxy.mysite.ie");
    pref("network.proxy.http_port", 8080);
    pref("network.proxy.ssl", "www-myproxy.mysite.ie");
    pref("network.proxy.ssl_port", 8080);
    pref("network.proxy.socks", "socks-myproxy.mysite.ie");
    pref("network.proxy.socks_port", 1080);
    pref("network.proxy.socks_version", 5);
    pref("network.proxy.socks_remote_dns", false);
    pref("network.proxy.no_proxies_on", "localhost, 127.0.0.1");
    pref("network.proxy.failover_timeout", 1800); // 30 minutes
    pref("network.online", true); //online/offline
    pref("network.cookie.cookieBehavior", 0); // 0-Accept, 1-dontAcceptForeign, 2-dontUse
    pref("network.cookie.disableCookieForMailNews", true); // disable all cookies for mail
    pref("network.cookie.lifetimePolicy", 0); // accept normally, 1-askBeforeAccepting, 2-acceptForSession,3-acceptForNDays
    pref("network.cookie.alwaysAcceptSessionCookies", false);
    pref("network.cookie.prefsMigrated", false);
    pref("network.cookie.lifetime.days", 90);

    // The PAC file to load. Ignored unless network.proxy.type is 2.
    pref("network.proxy.autoconfig_url", "www.mysite.ie/proxy.pac");


    trying both proxy type 1 and 2..... still no joy. Anyone got any ideas?! Thanks a mill!

    Shay

  2. #2
    Gary is offline Starter Member
    Join Date
    Oct 2008
    Posts
    1
    Rep Power
    6

    Default

    I get the same, and I've read a number of other posts about the same issue. Seems this one must have them stumped.

  3. #3
    seamuslawless is offline Starter Member
    Join Date
    Oct 2008
    Posts
    2
    Rep Power
    6

    Default

    Having looked at the problem some more, I think it may be an issue with how Jetty handles proxies.... not the prism desktop client. I'm no closer to a solution though unfortunately

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  4. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •