Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: can't authenticate on soap

  1. #1
    mouden.asmae is offline Intermediate Member
    Join Date
    Feb 2013
    Posts
    23
    Rep Power
    2

    Default can't authenticate on soap

    hello,
    i want create account with class java, when i try to authenticate with admin,it doesn't work with no exception and no error, this is my code:
    Code:
    try{
    	   
    		attrs.put(Provisioning.A_cn, "zimbra.aridmn.com");
    		
    	    SoapProvisioning sp = new SoapProvisioning();
    	  
    		sp.soapSetURI("https://192.168.10.203:7071/service/soap");
    		
    		sp.soapAdminAuthenticate("admin", "rootroot");
    		
    		sp.createAccount(login + "@zimbra.aridmn.com", pass, attrs);
    		
    		res.sendRedirect("https://192.168.10.203/");
    		System.out.println(response);}
    catch (Exception e)
    {
    	  redirect = "errorMsg: Error adding account: " + e.getMessage();
    }
    when i try to connect to https://192.168.10.203:7071/service/soap i get:
    Code:
    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
    <soap:Body>
    <soap:Fault>
    <soap:Code>
    <soap:Value>soap:Receiver</soap:Value>
    </soap:Code>
    <soap:Reason>
    <soap:Text>system failure: Request not allowed on port 7071</soap:Text>
    </soap:Reason>
    <soap:Detail>
    <Error xmlns="urn:zimbra">
    <Code>service.FAILURE</Code>
    <Trace>
    qtp1372666800-106:https://192.168.10.203:7071/service/soap:1371649525607:8a0ffe3252f29bbf
    </Trace>
    </Error>
    </soap:Detail>
    </soap:Fault>
    </soap:Body>
    </soap:Envelope>
    how can i resolve this problem please i need your help, thank you.

  2. #2
    mouden.asmae is offline Intermediate Member
    Join Date
    Feb 2013
    Posts
    23
    Rep Power
    2

    Default

    pleaaaase it's urgent i need your help

  3. #3
    tdesorbaix is offline Zimlet Guru & Moderator
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    365
    Rep Power
    8

    Default

    Hi,

    If you have not found the problem yet, it seems to come from the URL you are using.
    You are using the url for accessing the user part of zimbra.
    You want to access the soap for the admin part of zimbra, so the url should look like this :
    https://192.168.10.203:7071/service/admin/soap

  4. #4
    mouden.asmae is offline Intermediate Member
    Join Date
    Feb 2013
    Posts
    23
    Rep Power
    2

    Default

    Quote Originally Posted by tdesorbaix View Post
    Hi,

    If you have not found the problem yet, it seems to come from the URL you are using.
    You are using the url for accessing the user part of zimbra.
    You want to access the soap for the admin part of zimbra, so the url should look like this :
    https://192.168.10.203:7071/service/admin/soap
    thank you for your reply, i tried this url first but i get this error:
    HTML Code:
    HTTP ERROR 405
    
    Problem accessing /service/admin/soap. Reason:
    
        HTTP method GET is not supported by this URL
    Powered by Jetty://
    .

  5. #5
    tdesorbaix is offline Zimlet Guru & Moderator
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    365
    Rep Power
    8

    Default

    Yes, it is normal.
    You must use POST, not GET.

  6. #6
    mouden.asmae is offline Intermediate Member
    Join Date
    Feb 2013
    Posts
    23
    Rep Power
    2

    Default

    Quote Originally Posted by tdesorbaix View Post
    Yes, it is normal.
    You must use POST, not GET.
    thank you for your reply, but still having the same problem with Post method, i thing it's something wrong on server, i think that soap are not enabled on server but i'm newbie i don't know how to enable or how to detect the problem with soap on server . can you help me on that.

  7. #7
    mouden.asmae is offline Intermediate Member
    Join Date
    Feb 2013
    Posts
    23
    Rep Power
    2

    Default

    i want add something this code was working with zimbra 7, i changed the server we installed zimbra 8 then i have this problem

  8. #8
    tdesorbaix is offline Zimlet Guru & Moderator
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    365
    Rep Power
    8

    Default

    SOAP is always enabled. It is used everywhere in the webmail interface.
    Nothing would work if soap didn't worked.

    What error do you get when using POST instead of GET?

  9. #9
    mouden.asmae is offline Intermediate Member
    Join Date
    Feb 2013
    Posts
    23
    Rep Power
    2

    Default

    Quote Originally Posted by tdesorbaix View Post
    SOAP is always enabled. It is used everywhere in the webmail interface.
    Nothing would work if soap didn't worked.

    What error do you get when using POST instead of GET?
    I don't get any error or exception but the execution of my code stops on admin authentication line with no error and no exception

  10. #10
    tdesorbaix is offline Zimlet Guru & Moderator
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    365
    Rep Power
    8

    Default

    If you are in Dev environment you could try to activate debug mode in the jetty configuration and chek the log mailbox.log to get more informations.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOAP API authenticate using a zm_auth_token
    By taichimaro in forum Developers
    Replies: 0
    Last Post: 06-20-2011, 07:31 AM
  2. How do I authenticate using port 587
    By spectra in forum Administrators
    Replies: 2
    Last Post: 05-05-2011, 12:31 PM
  3. Error 403 Must Authenticate
    By vmartinez in forum Error Reports
    Replies: 2
    Last Post: 10-08-2008, 01:12 PM
  4. [SOLVED] 403 Must Authenticate
    By vmartinez in forum Administrators
    Replies: 0
    Last Post: 10-08-2008, 09:57 AM
  5. authenticate to OS X server
    By superman in forum Administrators
    Replies: 1
    Last Post: 04-18-2006, 10:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •