Dear Sirs
I am new to Zimbra and I try to make basic admin tasks through the web service. I am using Soap::Lite in perl to get the XML for the request. My problem is the although that I manage to login I did not manage to do anything else because I do not have the session id returned in AuthResponse. see XML below

<?xml version="1.0" encoding="UTF-8"?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><AuthRequest xmlns="urn:zimbraAdmin"><name xsi:type="xsd:string">username</name><password xsi:type="xsd:string">password</password></AuthRequest></soap:Body></soap:Envelope>



<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><context xmlns="urn:zimbra"><change token="1437"/></context></soap:Header><soap:Body><AuthResponse xmlns="urn:zimbraAdmin"><authToken>0_5a80541e00883 a18288a147d02903c3634918da3_69643d33363a3463316330 3137622d313338382d343039622d386661632d623138326637 3966653766633b6578703d31333a3133373136303033333034 32363b61646d696e3d313a313b747970653d363a7a696d6272 613b</authToken><lifetime>43199999</lifetime></AuthResponse></soap:Body></soap:Envelope>


I even try to make a second call to Auth with authToken time but again I did not get the session id.

<?xml version="1.0" encoding="UTF-8"?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><context><session xsi:type="xsd:string" /></context></soap:Header><soap:Body><AuthRequest xmlns="urn:zimbraAccount"><authToken xsi:type="xsd:string">0_5a80541e00883a18288a147d02 903c3634918da3_69643d33363a34633163303137622d31333 8382d343039622d386661632d6231383266373966653766633 b6578703d31333a313337313630303333303432363b61646d6 96e3d313a313b747970653d363a7a696d6272613b</authToken><id xsi:type="xsd:string">username</id></AuthRequest></soap:Body></soap:Envelope>



<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><context xmlns="urn:zimbra"><change token="1437"/></context></soap:Header><soap:Body><AuthResponse xmlns="urn:zimbraAccount"><authToken>0_5a80541e008 83a18288a147d02903c3634918da3_69643d33363a34633163 303137622d313338382d343039622d386661632d6231383266 373966653766633b6578703d31333a31333731363030333330 3432363b61646d696e3d313a313b747970653d363a7a696d62 72613b</authToken><lifetime>43199919</lifetime><skin>serenity</skin></AuthResponse></soap:Body></soap:Envelope>

I try to make a call without session id and with token
<?xml version="1.0" encoding="UTF-8"?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><context><authToken xsi:type="xsd:string">0_5a80541e00883a18288a147d02 903c3634918da3_69643d33363a34633163303137622d31333 8382d343039622d386661632d6231383266373966653766633 b6578703d31333a313337313630303333303432363b61646d6 96e3d313a313b747970653d363a7a696d6272613b</authToken></context></soap:Header><soap:Body><SetPasswordRequest xmlns="urn:zimbraAdmin"><id xsi:type="xsd:string">emailaddress</id><newPassword xsi:type="xsd:string">password</newPassword></SetPasswordRequest></soap:Body></soap:Envelope>

and I get

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><context xmlns="urn:zimbra"/></soap:Header><soap:Body><soap:Fault><faultcode>soap :Client</faultcode><faultstring>no valid authtoken present</faultstring><detail><Error xmlns="urn:zimbra"><Code>service.AUTH_REQUIRED</Code><Trace>qtp1324910826-10412:https://172.21.54.99:7071/service/admin/soap:1371557130585:197825f51c0d2828:SoapEngine385</Trace></Error></detail></soap:Fault></soap:Body></soap:Envelope>

Authentication Required.
Is their any way to get the session id or using zimbraAdmin without if
Thank you in Advance
Regards
Marios Koudounias