Results 1 to 3 of 3

Thread: Can't get source code

  1. #1
    bysdan is offline New Member
    Join Date
    Jul 2011
    Posts
    3
    Rep Power
    3

    Default Can't get source code

    I've downloaded p4v (for windows 64), in the open connection window, in the Server section I write : codes.zimbra.com:2666,
    in the user : public, and leave the workspace blank, then i press OK, and after a while i get the following error :

    Connect to server failed; check $P4PORT.
    TCP connect to codes.zimbra.com:2666 failed.
    connect: codes.zimbra.com:2666: WSAETIMEDOUT


    note : i've also tried with the p4 command line, as written in the Building Zimbra using Perforce wiki section, but I get the same error ???

    Thanks for your replies,
    Dan

  2. #2
    AlternativeMind is offline Junior Member
    Join Date
    Sep 2011
    Posts
    5
    Rep Power
    3

    Default

    Similar issue on linux side. I cannot get the source code:
    Code:
    # export P4PORT=codes.zimbra.com:2666
    # ./p4 -u public -P public1234 -c public-view sync -f //depot/zcs/BRANCH/...
    //depot/zcs/BRANCH/... - no such file(s).
    Ok, maybe the depot is now codes... let's try again:
    Code:
    # ./p4 -u public -P public1234 -c public-view sync -f //codes/zcs/BRANCH/...
    //codes/zcs/BRANCH/... - must refer to client 'public-view'.
    How can we get a copy of the source?

  3. #3
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    You are supposed to replace BRANCH with the actual branch you are checking out, such as main or HELIX or HELIX-712, etc, as noted in the wiki.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zimbra source code
    By DinuAsa in forum Developers
    Replies: 11
    Last Post: 11-22-2010, 04:06 AM
  2. Sits at loading screen?
    By moshen in forum General Questions
    Replies: 8
    Last Post: 02-19-2008, 02:15 PM
  3. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •