Results 1 to 6 of 6

Thread: Problem with building 8.0.0

  1. #1
    ocx
    ocx is offline New Member
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    3

    Default Problem with building 8.0.0

    Hi,

    Im trying to build latest 8.0.0_BETA1_3878

    But i'm getting several errors about missing ant-global.xml

    Code:
    BUILD FAILED
    /home/public/p4/main/ZimbraServer/build.xml:3: Cannot find /home/public/p4/main/ant-global.xml imported from /home/public/p4/main/ZimbraServer/build.xml
    Before, i was compiling some earlier builds of 8.0.0, around rev. 36xx and it was all fine. Tried commenting out includes with ant-global, but build fails with only one error then - cant find ant-contrib, even though its installed...

    Building on Debian 6.

  2. #2
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,185
    Rep Power
    9

    Default

    Does this work now? There is a lot of changes underway in the ant build structure.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    ezajko is offline Intermediate Member
    Join Date
    Nov 2005
    Posts
    24
    Rep Power
    9

    Default

    Quote Originally Posted by quanah View Post
    Does this work now? There is a lot of changes underway in the ant build structure.
    Nope, same error for zcs-8.0.0_BETA2_3923

    Code:
    Buildfile: build.xml
    
    BUILD FAILED
    /home/public/p4/main/ZimbraServer/build.xml:3: Cannot find ../ant-global.xml imported from /home/public/p4/main/ZimbraServer/build.xml

  4. #4
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,185
    Rep Power
    9

    Default

    Thanks, this should be fixed now!
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #5
    ocx
    ocx is offline New Member
    Join Date
    Jun 2011
    Posts
    3
    Rep Power
    3

    Default

    BUILD FAILED
    /home/public/p4/main/ZimbraServer/build.xml:429: Basedir /home/public/p4/main/ZimbraClient does not exist

  6. #6
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,185
    Rep Power
    9

    Default

    Fixed, thanks.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Crashes every day
    By feiticeir0 in forum Administrators
    Replies: 10
    Last Post: 10-13-2011, 06:53 AM
  2. Missing Email Problem
    By prox in forum Zimbra Connector for Outlook
    Replies: 6
    Last Post: 03-16-2008, 10:01 PM
  3. WindowsMobile - problem with regional fonts
    By wojo2000 in forum Zimbra Mobile
    Replies: 0
    Last Post: 06-22-2007, 10:37 AM
  4. Problem building Ajax
    By JoshuaPrismon in forum Developers
    Replies: 5
    Last Post: 03-02-2007, 12:43 PM
  5. problem while building perl
    By ravinder in forum Developers
    Replies: 7
    Last Post: 05-29-2006, 09:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •