If I build with java 1.6, I get a message:

/usr/dev/zcs-6.0.7_GA_2483-src/ZimbraBuild $ ./buildZCS.sh
Checking for prerequisite binaries
Checking ant
Checking java
Error: Unsupported version of java: 1.6.0
You can obtain java from:
http://java.sun.com/javase/downloads/index_jdk5.jsp
Make sure the downloaded version appears first in your path

When I try with 1.5, it wants some repackaged version of part of 1.6.

Is there no simple(?) straight forward way to build zimbra from source?