Results 1 to 8 of 8

Thread: postfix not started on FC4

  1. #1
    vpoorboy is offline Senior Member
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    9

    Default postfix not started on FC4

    I've installed Zimbra from source on Fedora Core 4, it's ok. And I could run the server, logged in it with the default account (user1/test123). But the second time I started the server, the Postfix cannot started, services in order : ldap mysql.server then tomcat, and postfix.

    It returned warnings:

    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.2.3/conf/main.cf
    postfix/postfix-script: starting the Postfix mail system


    I tried to chown file main.cf. It's ok. But when I started the Postfix again, it changed the owner back to user, and continued to returned those warnings.

    Does sb have the same problem ?

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Do you have the right entries in sudoers?

  3. #3
    vpoorboy is offline Senior Member
    Join Date
    Oct 2005
    Posts
    67
    Rep Power
    9

    Default

    yes, the sudoers file contains these lines:

    user ALL=NOPASSWD:/opt/zimbra/openldap/libexec/slapd
    user ALL=NOPASSWD:/opt/zimbra/postfix/sbin/postfix
    user ALL=NOPASSWD:/opt/zimbra/postfix/sbin/postalias


    when I start postfix, it shows these warnings:

    postfix/postfix-script: warning: not owned by group postdrop: /opt/zimbra/postfix-2.2.3/sbin/postdrop
    postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /opt/zimbra/postfix-2.2.3/sbin/postdrop
    postfix/postfix-script: starting the Postfix mail system


    But it's ok, I realize that the Postfix is still running. The first two warnings can be fixed by:

    chown rootostdrop /opt/zimbra/postfix-2.2.3/sbin/postdrop
    chmod g+s /opt/zimbra/postfix-2.2.3/sbin/postdrop


    Thanks!

  4. #4
    vaneck is offline Member
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    8

    Default

    Hi I've been working on setting up zimbra the last few days at work, and the MTA apparently crapped out on us over the weekend. We've been trying to figure out what caused this, but we cannot get postfix to start up. We get the same original posted error. We checked out sudoers file and it looks correct.

    %zimbra ALL = NOPASSWD:/opt/zimbra/openldap-2.3.20/libexec/slapd
    %zimbra ALL = NOPASSWD:/opt/zimbra/postfix-2.2.9/sbin/postfix, /opt/zimbra/postfix-2.2.9/sbin/postalias, /opt/zimbra/postfix
    -2.2.9/sbin/qshape.pl, /opt/zimbra/postfix-2.2.9/sbin/postconf, /opt/zimbra/postfix-2.2.9/sbin/postsuper
    %zimbra ALL = NOPASSWD:/opt/zimbra/libexec/zmqstat
    %zimbra ALL = NOPASSWD:/opt/zimbra/libexec/zmtomcatstart



    This is Zimbra 3.1 running on CentOS 4.2. The only changes we made since we last knew it was ok was installing imapsync to transfer our mail over, and updating CPAN. We have occasionally had the mta stop running after a while, but at worst restarting the server brought everything backup.

    Edit: Sorry I think this should probably be in the admin board, but I didn't realize it was in the development when I posted.
    Last edited by vaneck; 04-24-2006 at 04:46 PM.

  5. #5
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    What is in the log when you try to start postfix?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #6
    vaneck is offline Member
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    8

    Default

    ok, maybe I need to get my eyes checked because I took another look at the processes and I saw that sendmail was running. Well I killed sendmail zimbra's postfix started up. However, postfix is still whining about main.cf not being owned by root. Should I be concerned about this at all?

    This is what is in the /var/log/zimbra.log file when I run zmmtactl start

    Apr 24 21:31:07 lima postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.2.9/conf/main.cf
    Apr 24 21:31:07 lima postfix/postfix-script: starting the Postfix mail system
    Apr 24 21:31:08 lima postfix/master[7033]: daemon started -- version 2.2.9, configuration /opt/zimbra/postfix-2.2.9/conf

  7. #7
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by vaneck
    Should I be concerned about this at all?
    Not if things are working.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    main.cf is owned by zimbra, because zimbra modifies the file via the postconf command. Not an error, just a warning.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 11-03-2007, 10:55 PM
  2. Sending Mail! Still something wrong!
    By BlueHaven in forum Installation
    Replies: 11
    Last Post: 08-02-2007, 04:19 PM
  3. Cannot send mail.
    By jeremyshoe in forum Installation
    Replies: 7
    Last Post: 10-17-2006, 09:42 PM
  4. unable to restart zimbra after reboot
    By droefs in forum Administrators
    Replies: 28
    Last Post: 04-16-2006, 02:33 PM
  5. Is this normal?
    By tbullock in forum Installation
    Replies: 7
    Last Post: 11-18-2005, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •