Results 1 to 2 of 2

Thread: [SOLVED] SOAP returning NullPointerException

  1. #1
    ploeger's Avatar
    ploeger is offline Senior Member
    Join Date
    Oct 2008
    Rep Power

    Post [SOLVED] SOAP returning NullPointerException


    I'm trying to send the following SOAP-request to zimbra:

    <soap:Envelope xmlns:soap="" xmlns:default="urn:zimbra" xmlns:default1="urn:zimbraMail">
          <default:context xmlns="urn:zimbra">
             <account by="name"></account>
          <default1:CreateAppointmentRequest xmlns="urn:zimbraMail">
             <m l="10"/>
             <inv uid="">
                <comp status="CONF" fb="B" fba="B" transp="O" class="PUB" allDay="0" name="test" loc="" isOrg="0" priority="0" url=""/>
                <s d="20100415T150000"/>
                <e d="20100415T170000"/>
                <or a="" d=""/>
    But all I get is a NullPointerException:

    2010-04-15 14:01:37,992 WARN  [btpool0-2://] [;mid=10;ip=;] SoapEngine - handler exception
        at com.zimbra.cs.service.mail.CalendarRequest.handleMsgElement(
        at com.zimbra.cs.service.mail.CreateCalendarItem.handle(
        at com.zimbra.soap.SoapEngine.dispatchRequest(
        at com.zimbra.soap.SoapEngine.dispatch(
        at com.zimbra.soap.SoapEngine.dispatch(
        at com.zimbra.soap.SoapServlet.doWork(
        at com.zimbra.soap.SoapServlet.doPost(
        at javax.servlet.http.HttpServlet.service(
        at com.zimbra.cs.servlet.ZimbraServlet.service(
        at javax.servlet.http.HttpServlet.service(
        at org.mortbay.jetty.servlet.ServletHolder.handle(
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
        at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
        at org.mortbay.servlet.UserAgentFilter.doFilter(
        at org.mortbay.servlet.GzipFilter.doFilter(
        at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
        at org.mortbay.jetty.servlet.ServletHandler.handle(
        at org.mortbay.jetty.servlet.SessionHandler.handle(
        at org.mortbay.jetty.handler.ContextHandler.handle(
        at org.mortbay.jetty.webapp.WebAppContext.handle(
        at org.mortbay.jetty.handler.ContextHandlerCollection.handle(
        at org.mortbay.jetty.handler.HandlerCollection.handle(
        at org.mortbay.jetty.handler.HandlerWrapper.handle(
        at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(
        at org.mortbay.jetty.handler.HandlerWrapper.handle(
        at org.mortbay.jetty.handler.DebugHandler.handle(
        at org.mortbay.jetty.handler.HandlerWrapper.handle(
        at org.mortbay.jetty.Server.handle(
        at org.mortbay.jetty.HttpConnection.handleRequest(
        at org.mortbay.jetty.HttpConnection$RequestHandler.content(
        at org.mortbay.jetty.HttpParser.parseNext(
        at org.mortbay.jetty.HttpParser.parseAvailable(
        at org.mortbay.jetty.HttpConnection.handle(
        at org.mortbay.thread.BoundedThreadPool$
    What am I doing wrong here? I've compared that SOAP request with an original one, Zimbra is sending when creating a new appointment, but don't see any great differences...

    Thanks in advance!

    Kind regards
    Release 8.0.6.GA.5922.UBUNTU12.64 UBUNTU12_64 NETWORK edition.

  2. #2
    ploeger's Avatar
    ploeger is offline Senior Member
    Join Date
    Oct 2008
    Rep Power


    Arghh.. gotta read the documentation right! The nesting was completely wrong (s, e, etc. have to be under comp, su under m and so forth)... Sorry.

    (Am I the only wrong, who thinks, that the SOAP docs suck?)
    Release 8.0.6.GA.5922.UBUNTU12.64 UBUNTU12_64 NETWORK edition.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zimbra "freezes" when a certain user logs in.
    By gruad23 in forum Administrators
    Replies: 5
    Last Post: 04-05-2010, 07:26 AM
  2. users logon with 2 passwords
    By vmcastro in forum Administrators
    Replies: 2
    Last Post: 01-11-2010, 10:08 AM
  3. Can recives but can't send mail outgoing
    By hoangkk in forum Installation
    Replies: 9
    Last Post: 09-21-2009, 07:35 PM
  4. Replies: 35
    Last Post: 07-17-2009, 03:52 PM
  5. zmzimletctl deploy - ERROR -
    By todd_dsm in forum Administrators
    Replies: 0
    Last Post: 04-02-2009, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts