Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: [SOLVED] Build Zimbra..a little problem...

  1. #21
    Abdelmonam Kouka's Avatar
    Abdelmonam Kouka is offline Active Member
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by jholder View Post
    I don't think this has much to do with building. This is an LDAP problem. Zimbra relies upon ldap for all other services, if it doesn't start, nothing starts.

    That's what's happening. So we need to focus there.

    What happens when you

    su - zimbra
    ldap start
    Code:
    zimbra@monaco:~/bin$ ./ldap start
    Started slapd: pid 10099
    zimbra@monaco:~/bin$ ./zmcontrol status
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.
    zimbra@monaco:~/bin$ ./ldap start
    slapd already running: pid 10099

  2. #22
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    I wouldn't continue to try and bodge together your current build. Start again. Somewhere along the way something has gone horribly wrong. You're missing (lots of) vital files.

    I find that in my install (from source) the /opt/zimbra/conf contain only one file (dspam.conf) and only one directory (spamassassin)
    As you point out, you're missing most of the conf directory. Virtually nothing (including ldap) will work without this. Copying stuff in from a binary install is *NOT* a fix.

    ./zmdumpenv: line 36: /opt/zimbra/libexec/get_plat_tag.sh: No such file or directory

    ----------------
    rpm: To install rpm packages on Debian systems, use alien. See README.Debian.
    error: cannot open Name index using db3 - No such file or directory (2)
    package zimbra-core is not installed
    get_plat_tag.sh is so fundamental to the building and running of zimbra, if you don't have this in place give up and go home. this is the reason you're getting the alien/debian message above, by default the zimbra installers drop down to rpm if it doesn't find another platform defined.

    how are you installing the end zimbra? are you doing a make inside ZimbraBuild? do you end up with ZimbraBuild/zcs-<version>? and then do a install.sh from inside there? my instructions:
    Ubuntu Hardy - Build Zimbra
    are not complete, they have never been released to the public yet. some of the instructions rely on build script patches from solaris source that I removed from the ubuntu patch I submitted for cleanliness. they are 98%, I'll try and finish them soon.

  3. #23
    Abdelmonam Kouka's Avatar
    Abdelmonam Kouka is offline Active Member
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by dijichi2 View Post
    how are you installing the end zimbra? are you doing a make inside ZimbraBuild? do you end up with ZimbraBuild/zcs-<version>? and then do a install.sh from inside there? my instructions:
    Ubuntu Hardy - Build Zimbra
    are not complete, they have never been released to the public yet. some of the instructions rely on build script patches from solaris source that I removed from the ubuntu patch I submitted for cleanliness. they are 98%, I'll try and finish them soon.
    I install zimbra using this tutorial Ubuntu Hardy - Build Instructions
    All is going as it was described within, but when I attempted the "Start building main codebase" section in this page Ubuntu Hardy - Build Zimbra I can't run gmake
    Code:
    root@monaco:/home/public/p4# gmake
    bash: gmake: command not found
    So I proceed manually by going under ZimbraBuild where I executed
    Code:
    make dev-install
    and after a lot of time and big message I have got at the end "*** Installation complete", after that I tried to start zimbra services...
    As I see, the problem is in this section, but why it doesn't work? I search for "gmake" via synaptic but no result!

  4. #24
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    right that explains things. gmake is from my Solaris build instructions, doesn't exist under Linux but neither does the build script. The Ubuntu instructions aren't complete (it does say that at top of the page!). Instead of doing make dev-install in ZimbraBuild, just do make. Then you will end up with a full installer.

  5. #25
    Abdelmonam Kouka's Avatar
    Abdelmonam Kouka is offline Active Member
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by dijichi2 View Post
    right that explains things. gmake is from my Solaris build instructions, doesn't exist under Linux but neither does the build script. The Ubuntu instructions aren't complete (it does say that at top of the page!). Instead of doing make dev-install in ZimbraBuild, just do make. Then you will end up with a full installer.
    Thanks very much for the clarification but :-/

    I do what you said to me, I find some problems when it attempts to compile ZimbraNative, some header files are missing, in fact it was jni.h which I search and download it from the web, it call jni_md.h, so I do the same thing..the same with jri_md.h and assert.h, this last one call CyWin.h witch I can't find it any where!!!

    Did you think that is normal? Am I on the good way (by downloading header files)? What can I do?

    Sorry for all these question, but really I do my best but I find always problems in this subject.
    Thanks for help and comprehension...

  6. #26
    Abdelmonam Kouka's Avatar
    Abdelmonam Kouka is offline Active Member
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by Abdelmonam Kouka View Post
    Thanks very much for the clarification but :-/

    I do what you said to me, I find some problems when it attempts to compile ZimbraNative, some header files are missing, in fact it was jni.h which I search and download it from the web, it call jni_md.h, so I do the same thing..the same with jri_md.h and assert.h, this last one call CyWin.h witch I can't find it any where!!!

    Did you think that is normal? Am I on the good way (by downloading header files)? What can I do?

    Sorry for all these question, but really I do my best but I find always problems in this subject.
    Thanks for help and comprehension...
    OK, I find the solution for this pb, it call this files from /usr/local/java/include which doesn't exist --> the solution is
    Code:
    ln -s /home/abdelmonam/jdk1.5.0_12/ /usr/local/java
    I will continu now and give feed backs

  7. #27
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by Abdelmonam Kouka View Post
    OK, I find the solution for this pb, it call this files from /usr/local/java/include which doesn't exist --> the solution is
    Code:
    ln -s /home/abdelmonam/jdk1.5.0_12/ /usr/local/java
    I will continu now and give feed backs
    Bad idea. The Zimbra user needs to be able to access jdk. Why one would stick jdk in their home directory is beyond me...but if you want zimbra to work, you have to either move it to a place where it will have access, or give zimbra access to your home directory.

  8. #28
    Abdelmonam Kouka's Avatar
    Abdelmonam Kouka is offline Active Member
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by jholder View Post
    Bad idea. The Zimbra user needs to be able to access jdk. Why one would stick jdk in their home directory is beyond me...but if you want zimbra to work, you have to either move it to a place where it will have access, or give zimbra access to your home directory.
    OK, I change the java home directory under /usr/local/java/

  9. #29
    Abdelmonam Kouka's Avatar
    Abdelmonam Kouka is offline Active Member
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by dijichi2 View Post
    right that explains things. gmake is from my Solaris build instructions, doesn't exist under Linux but neither does the build script. The Ubuntu instructions aren't complete (it does say that at top of the page!). Instead of doing make dev-install in ZimbraBuild, just do make. Then you will end up with a full installer.
    Thanks for the advice It helps me
    In fact, by executing make instead of make dev-install, I have compilled all the project and create a .deb packages, but at the end I have got this error
    Code:
    cp -f /home/public/p4/FRANKLIN/ZimbraBuild/storebuild/opt/zimbra/jetty-6.1.5/webapps/zimbra/downloads/* /home/public/p4/FRANKLIN/ZimbraBuild/i386
    cp: cannot stat `/home/public/p4/FRANKLIN/ZimbraBuild/storebuild/opt/zimbra/jetty-6.1.5/webapps/zimbra/downloads/*': No such file or directory
    make: [zcs_stage] Error 1 (ignored)
    *** BUILD COMPLETED ***
    I search where is the problem but I don't find! Since it said "ignored", I will try tomorrow to install the .deb packages that I have got and I will tell you if all is going good.

    BTW: if all is well done, am asked to re-build from scratch each time I modify a source file of Zimbra? In fact I hope develop other features for zimbra using Eclipse (or NetBeans or any other IDE) and I would like to see the changes after compiling and without re-building all! Any idea here???

  10. #30
    Abdelmonam Kouka's Avatar
    Abdelmonam Kouka is offline Active Member
    Join Date
    Apr 2008
    Location
    Tunisia
    Posts
    49
    Rep Power
    7

    Default

    Hello,

    I installed the zimbra version that I have build yesterday, the installation is going well, but I can't start services, I have pb in ldap and DNS, an IT admin said to me that the pb is not with the DNS but with my build because I am using ubuntu 7.10 witch isn't zimbra compatible, is he right?

    Here the output of the installation (there is the error messages within), thanks in advance for the help:
    The output is too long, so I removed some part that doesn't contain a pertinent information:
    Code:
    root@monaco:/home/public/p4/FRANKLIN/ZimbraBuild/zcs-5.0.6_GA_2261.UBUNTU7.20080515182551# ./install.sh --platform-override
        zimbra-core......zimbra-core_5.0.6_GA_2261.UBUNTU7_i386.deb...done
        zimbra-ldap......zimbra-ldap_5.0.6_GA_2261.UBUNTU7_i386.deb...done
        zimbra-logger......zimbra-logger_5.0.6_GA_2261.UBUNTU7_i386.deb...done
        zimbra-mta......zimbra-mta_5.0.6_GA_2261.UBUNTU7_i386.deb...done
        zimbra-snmp......zimbra-snmp_5.0.6_GA_2261.UBUNTU7_i386.deb...done
        zimbra-store......zimbra-store_5.0.6_GA_2261.UBUNTU7_i386.deb...done
        zimbra-apache......zimbra-apache_5.0.6_GA_2261.UBUNTU7_i386.deb...done
        zimbra-spell......zimbra-spell_5.0.6_GA_2261.UBUNTU7_i386.deb...done
    Operations logged to /tmp/zmsetup.01001900-0000138846976.log
    Setting defaults...
            Interface: 1**.***.*.*9
            Interface: 127.0.0.1
    
    DNS ERROR - none of the MX records for monaco.*****.net
    resolve to this host
    Change domain name? [Yes] No
    done.
    Checking for port conflicts
    Port conflict detected: 389 (zimbra-ldap)
    Port conflict detected: 389 (zimbra-ldap)
    Port conflicts detected! - Any key to continue 
    
    Main menu
    
       1) Common Configuration:                                                  
       2) zimbra-ldap:                             Enabled                       
       3) zimbra-store:                            Enabled                       
            +Create Admin User:                    yes                           
            +Admin user to create:                 admin@monaco.*****.net      
    ******* +Admin Password                        UNSET                         
            +Enable automated spam training:       yes                           
            +Spam training user:                   spam.fpaizl8c@monaco.*****.net
            +Non-spam(Ham) training user:          ham._ptstbghex@monaco.*****.net
            +Global Documents Account:             wiki@monaco.*****.net       
            +SMTP host:                            monaco.*****.net            
            +Web server HTTP port:                 80                            
            +Web server HTTPS port:                443                           
            +Web server mode:                      http                          
            +IMAP server port:                     143                           
            +IMAP server SSL port:                 993                           
            +POP server port:                      110                           
            +POP server SSL port:                  995                           
            +Use spell check server:               yes                           
            +Spell server URL:                     http://monaco.*****.net:7780/aspell.php
    
       4) zimbra-mta:                              Enabled                       
       5) zimbra-snmp:                             Enabled                       
       6) zimbra-logger:                           Enabled                       
       7) zimbra-spell:                            Enabled                       
       8) Default Class of Service Configuration:                                
       r) Start servers after configuration        yes                           
       s) Save config to file                                                    
       x) Expand menu                                                            
       q) Quit                                    
    
    Address unconfigured (**) items  (? - help) 1
    
    Common configuration
    
       1) Hostname:                                monaco.*****.net            
       2) Ldap master host:                        monaco.*****.net            
       3) Ldap port:                               389                           
       4) Ldap Admin password:                     set                           
       5) Require secure interprocess communications: yes                           
       6) TimeZone:                                (GMT-08.00) Pacific Time (US & Canada)
    
    Select, or 'r' for previous menu [r] 5
    
    Common configuration
    
       1) Hostname:                                monaco.*****.net            
       2) Ldap master host:                        monaco.*****.net            
       3) Ldap port:                               389                           
       4) Ldap Admin password:                     set                           
       5) Require secure interprocess communications: no                            
       6) TimeZone:                                (GMT-08.00) Pacific Time (US & Canada)
    
    Select, or 'r' for previous menu [r] 6
    
    Enter the number for the local timezone: [5] 33
    
    Common configuration
    
       1) Hostname:                                monaco.*****.net            
       2) Ldap master host:                        monaco.*****.net            
       3) Ldap port:                               389                           
       4) Ldap Admin password:                     set                           
       5) Require secure interprocess communications: no                            
       6) TimeZone:                                (GMT+01.00) Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
    
    Select, or 'r' for previous menu [r] 3
    
    Please enter the ldap server port [389] 
    
    Common configuration
    
       1) Hostname:                                monaco.*****.net            
       2) Ldap master host:                        monaco.*****.net            
       3) Ldap port:                               389                           
       4) Ldap Admin password:                     set                           
       5) Require secure interprocess communications: no                            
       6) TimeZone:                                (GMT+01.00) Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
    
    Select, or 'r' for previous menu [r] r
    
    Address unconfigured (**) items  (? - help) 3
    
    
    Store configuration
    
       1) Status:                                  Enabled                       
       2) Create Admin User:                       yes                           
       3) Admin user to create:                    admin@monaco.*****.net      
    ** 4) Admin Password                           UNSET                         
       5) Enable automated spam training:          yes                           
       6) Spam training user:                      spam.fpaizl8c@monaco.*****.net
       7) Non-spam(Ham) training user:             ham._ptstbghex@monaco.*****.net
       8) Global Documents Account:                wiki@monaco.*****.net       
       9) SMTP host:                               monaco.*****.net            
      10) Web server HTTP port:                    80                            
      11) Web server HTTPS port:                   443                           
      12) Web server mode:                         http                          
      13) IMAP server port:                        143                           
      14) IMAP server SSL port:                    993                           
      15) POP server port:                         110                           
      16) POP server SSL port:                     995                           
      17) Use spell check server:                  yes                           
      18) Spell server URL:                        http://monaco.*****.net:7780/aspell.php
    
    Select, or 'r' for previous menu [r] 4
    
    Password for admin@monaco.*****.net (min 6 characters): [EKHTHnlb_7] *****zimbra
    
    Store configuration
    
       1) Status:                                  Enabled                       
       2) Create Admin User:                       yes                           
       3) Admin user to create:                    admin@monaco.*****.net      
       4) Admin Password                           set                           
       5) Enable automated spam training:          yes                           
       6) Spam training user:                      spam.fpaizl8c@monaco.*****.net
       7) Non-spam(Ham) training user:             ham._ptstbghex@monaco.*****.net
       8) Global Documents Account:                wiki@monaco.*****.net       
       9) SMTP host:                               monaco.*****.net            
      10) Web server HTTP port:                    80                            
      11) Web server HTTPS port:                   443                           
      12) Web server mode:                         http                          
      13) IMAP server port:                        143                           
      14) IMAP server SSL port:                    993                           
      15) POP server port:                         110                           
      16) POP server SSL port:                     995                           
      17) Use spell check server:                  yes                           
      18) Spell server URL:                        http://monaco.*****.net:7780/aspell.php
    
    Select, or 'r' for previous menu [r] r
    
    Main menu
    
       1) Common Configuration:                                                  
       2) zimbra-ldap:                             Enabled                       
       3) zimbra-store:                            Enabled                       
       4) zimbra-mta:                              Enabled                       
       5) zimbra-snmp:                             Enabled                       
       6) zimbra-logger:                           Enabled                       
       7) zimbra-spell:                            Enabled                       
       8) Default Class of Service Configuration:                                
       r) Start servers after configuration        yes                           
       s) Save config to file                                                    
       x) Expand menu                                                            
       q) Quit                                    
    
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) 2
    
    Ldap configuration
    
       1) Status:                                  Enabled                       
       2) Create Domain:                           yes                           
       3) Domain to create:                        monaco.*****.net            
       4) Ldap Root password:                      set                           
       5) Ldap Replication password:               set                           
       6) Ldap Postfix password:                   set                           
       7) Ldap Amavis password:                    set                           
    
    Select, or 'r' for previous menu [r] 3
    
    Create Domain: [monaco.*****.net] 
    
            Interface: 1**.***.*.*9
            Interface: 127.0.0.1
    
    DNS ERROR - none of the MX records for monaco.*****.net
    resolve to this host
    It is suggested that the MX record resolve to this host
    Re-Enter domain name? [Yes] r
    A Yes/No answer is required
    Re-Enter domain name? [Yes] 
    Create Domain: [monaco.*****.net] 
    
            Interface: 1**.***.*.*9
            Interface: 127.0.0.1
    
    DNS ERROR - none of the MX records for monaco.*****.net
    resolve to this host
    It is suggested that the MX record resolve to this host
    Re-Enter domain name? [Yes] No
    
    Ldap configuration
    
       1) Status:                                  Enabled                       
       2) Create Domain:                           yes                           
       3) Domain to create:                        monaco.*****.net            
       4) Ldap Root password:                      set                           
       5) Ldap Replication password:               set                           
       6) Ldap Postfix password:                   set                           
       7) Ldap Amavis password:                    set                           
    
    Select, or 'r' for previous menu [r] a
    Invalid selection! - press any key to continue 
    
    Main menu
    
       1) Common Configuration:                                                  
       2) zimbra-ldap:                             Enabled                       
       3) zimbra-store:                            Enabled                       
       4) zimbra-mta:                              Enabled                       
       5) zimbra-snmp:                             Enabled                       
       6) zimbra-logger:                           Enabled                       
       7) zimbra-spell:                            Enabled                       
       8) Default Class of Service Configuration:                                
       r) Start servers after configuration        yes                           
       s) Save config to file                                                    
       x) Expand menu                                                            
       q) Quit                                    
    
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] 
    Save config in file: [/opt/zimbra/config.3275] 
    Saving config in /opt/zimbra/config.3275...done.
    The system will be modified - continue? [No] Yes
    Operations logged to /tmp/zmsetup.01001900-0000138846976.log
    Setting local config values...done.
    Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Creating SSL certificate...done.
    Installing mailboxd SSL certificates...done.
    Initializing ldap...done.
    Setting replication password...done.
    Setting Postfix password...done.
    Setting amavis password...done.
    Saving CA in ldap ...done.
    Creating server entry for monaco.*****.net...done.
    Saving SSL Certificate in ldap ...done.
    Setting spell check URL...done.
    Setting service ports on monaco.*****.net...done.
    Adding monaco.*****.net to zimbraMailHostPool in default COS...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    done.
    Installing skins... 
            sand
            lemongrass
            bones
            waves
            sky
            lavender
            beach
            hotrod
            yahoo
            bare
            steel
    done.
    Setting zimbraFeatureIMEnabled=FALSE...done.
    Setting zimbraFeatureTasksEnabled=TRUE...done.
    Setting zimbraFeatureBriefcasesEnabled=TRUE...done.
    Setting zimbraFeatureNotebookEnabled=TRUE...done.
    Setting MTA auth host...done.
    Setting TimeZone Preference...done.
    Creating domain monaco.*****.net...done.
    Creating user admin@monaco.*****.net...done.
    Creating postmaster alias...done.
    Creating user wiki@monaco.*****.net...done.
    Creating user spam.fpaizl8c@monaco.*****.net...done.
    Creating user ham._ptstbghex@monaco.*****.net...done.
    Setting spam training accounts...done.
    Initializing store sql database...done.
    Setting zimbraSmtpHostname for monaco.*****.net...done.
    Initializing logger sql database...done.
    Initializing mta config...done.
    Configuring SNMP...done.
    Setting services on monaco.*****.net...done.
    Setting up zimbra crontab...done.
    Setting up syslog.conf...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    done.
    
    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Suite.
    The only information that will be transmitted is:
            The VERSION of zcs installed (5.0.6_GA_2261_UBUNTU7)
            The ADMIN EMAIL ADDRESS created (admin@monaco.*****.net)
    
    Notify Zimbra of your installation? [Yes] 
    Notifying Zimbra of installation via http://www.zimbra.com/cgi-bin/notify.cgi?VER=5.0.6_GA_2261_UBUNTU7&MAIL=admin@monaco.*****.net
    
    Notification complete
    
    Starting servers...Unable to determine enabled services from ldap.
    done.
    Checking for deprecated zimlets...failed.
    Installing zimlets... 
            com_zimbra_date
            com_zimbra_email
            com_zimbra_cert_manager
            com_zimbra_phone
            com_zimbra_url
            com_zimbra_local
    done.
    Initializing Documents...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    failed to initialize documents...see logfile for details.
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.AuthenticationException [LDAP: error code 49 - Invalid Credentials])
    Restarting mailboxd...done.
    
    Moving /tmp/zmsetup.01001900-0000138846976.log to /opt/zimbra/log
    
    Configuration complete - press return to exit
    and then
    Code:
    zimbra@monaco:~/bin$ ./zmcontrol status
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.
    zimbra@monaco:~/bin$ ./zmcontrol start 
    Host monaco.*****.net
            Starting ldap...Done.
    FAILED
    Failed to start slapd.  Attempting debug start to determine error.
    daemon: bind(7) failed errno=98 (Address already in use)
    daemon: bind(7) failed errno=98 (Address already in use)
    slap_open_listener: failed on ldap://monaco.*****.net:389

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  4. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •