Hi,

I've read a few posts regarding problems deleting events in various clients but nothing at the CalDAV protocol level. I'm trying to simply delete an event via CalDAV and Zimbra returns a 204 as expected, but then a subsequent GET on the deleted event is still successful.

Here's the log:

Code:
2011/11/03 10:37:53:588 GMT [DEBUG] header - >> "PUT /dav/zm1102fjwde@demo2.zimbra.com/Test/20111103T103753Z-xxx.ics HTTP/1.1[\r][\n]"
2011/11/03 10:37:53:611 GMT [DEBUG] header - >> "User-Agent: Jakarta Commons-HttpClient/3.1[\r][\n]"
2011/11/03 10:37:53:614 GMT [DEBUG] header - >> "Host: demo2.zimbra.com[\r][\n]"
2011/11/03 10:37:53:614 GMT [DEBUG] header - >> "Content-Length: 336[\r][\n]"
2011/11/03 10:37:53:615 GMT [DEBUG] header - >> "Content-Type: text/calendar; charset=UTF-8[\r][\n]"
2011/11/03 10:37:53:615 GMT [DEBUG] header - >> "[\r][\n]"
2011/11/03 10:37:53:984 GMT [DEBUG] header - << "HTTP/1.1 201 Created[\r][\n]"
2011/11/03 10:37:53:984 GMT [DEBUG] header - << "HTTP/1.1 201 Created[\r][\n]"
2011/11/03 10:37:53:985 GMT [DEBUG] header - << "Date: Thu, 03 Nov 2011 10:37:00 GMT[\r][\n]"
2011/11/03 10:37:53:985 GMT [DEBUG] header - << "ETag: "46307-46307"[\r][\n]"
2011/11/03 10:37:53:985 GMT [DEBUG] header - << "Content-Length: 0[\r][\n]"
2011/11/03 10:37:53:985 GMT [DEBUG] header - << "[\r][\n]"

2011/11/03 10:37:54:104 GMT [DEBUG] header - >> "DELETE /dav/zm1102fjwde@demo2.zimbra.com/Test/20111103T103753Z-xxx.ics HTTP/1.1[\r][\n]"
2011/11/03 10:37:54:106 GMT [DEBUG] header - >> "User-Agent: Jakarta Commons-HttpClient/3.1[\r][\n]"
2011/11/03 10:37:54:106 GMT [DEBUG] header - >> "Host: demo2.zimbra.com[\r][\n]"
2011/11/03 10:37:54:106 GMT [DEBUG] header - >> "Content-Length: 0[\r][\n]"
2011/11/03 10:37:54:106 GMT [DEBUG] header - >> "[\r][\n]"
2011/11/03 10:37:54:322 GMT [DEBUG] header - << "HTTP/1.1 204 No Content[\r][\n]"
2011/11/03 10:37:54:322 GMT [DEBUG] header - << "HTTP/1.1 204 No Content[\r][\n]"
2011/11/03 10:37:54:322 GMT [DEBUG] header - << "Date: Thu, 03 Nov 2011 10:37:00 GMT[\r][\n]"
2011/11/03 10:37:54:322 GMT [DEBUG] header - << "[\r][\n]"

2011/11/03 10:37:54:337 GMT [DEBUG] header - >> "GET /dav/zm1102fjwde@demo2.zimbra.com/Test/20111103T103753Z-xxx.ics HTTP/1.1[\r][\n]"
2011/11/03 10:37:54:337 GMT [DEBUG] header - >> "User-Agent: Jakarta Commons-HttpClient/3.1[\r][\n]"
2011/11/03 10:37:54:337 GMT [DEBUG] header - >> "Host: demo2.zimbra.com[\r][\n]"
2011/11/03 10:37:54:338 GMT [DEBUG] header - >> "[\r][\n]"
2011/11/03 10:37:54:520 GMT [DEBUG] header - << "HTTP/1.1 200 OK[\r][\n]"
2011/11/03 10:37:54:520 GMT [DEBUG] header - << "HTTP/1.1 200 OK[\r][\n]"
2011/11/03 10:37:54:520 GMT [DEBUG] header - << "Date: Thu, 03 Nov 2011 10:37:01 GMT[\r][\n]"
2011/11/03 10:37:54:520 GMT [DEBUG] header - << "ETag: "46308-46307"[\r][\n]"
2011/11/03 10:37:54:520 GMT [DEBUG] header - << "Content-Type: text/calendar; charset=utf-8[\r][\n]"
2011/11/03 10:37:54:521 GMT [DEBUG] header - << "Content-Length: 405[\r][\n]"
2011/11/03 10:37:54:521 GMT [DEBUG] header - << "[\r][\n]"
I'm using the hosted instance of Zimbra at demo2.zimbra.com.

Any insight into why this event is not actually being deleted would be appreciated.

Cheers,

Mark