Results 1 to 9 of 9

Thread: iSync connector errors on calendars, won't sync...

  1. #1
    travisbell is offline Active Member
    Join Date
    Aug 2006
    Posts
    33
    Rep Power
    9

    Default iSync connector errors on calendars, won't sync...

    Hey guys,

    I have 3/4 Macs running the iSync connector perfectly. Problem is, on one of them it reports saying the user isn't allowed to change the shared calendar even though he is a manager for it...

    What can I do to troubleshoot this?

    Thanks!

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    #1 - Make sure you've got the latest released iSync (0.9.12)

    #2 - Check the logs for any errors or exceptions
    ~/Library/Application Support/Zimbra/com.zimbra.<long string>/*.log.*
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    travisbell is offline Active Member
    Join Date
    Aug 2006
    Posts
    33
    Rep Power
    9

    Default

    Hey Kevin,

    I see this:

    [assert] error: (null)
    [assert] where: "ZimbraHelper_main.mm", "IsCalendarSelected", line: 2388

    [assert] error: (null)
    [assert] where: "ZimbraClient.mm", "-[ZimbraClient session:delCalendar:map:]", line: 1734

    [assert] error: (null)
    [assert] where: "ZimbraClient.mm", "-[ZimbraClient session:addExceptionEvent:changeRecords:map:]", line: 1915

    [assert] error: ok
    [assert] where: "ZimbraHelper_main.mm", "SyncCalendars", line: 1245

    Although I have no idea what it means...

  4. #4
    travisbell is offline Active Member
    Join Date
    Aug 2006
    Posts
    33
    Rep Power
    9

    Default

    I also see this,

    [ZimbraHelper] Caught exception while trying to sync calendars: name = NSInvalidArgumentException, reason = *** -[ZimbraClient UTF8String]: selector not recognized [self = 0x4859c0] (465)
    [ZimbraHelper] cancelling sync (465)
    [assert] error: !err
    [assert] where: "ZimbraHelper_main.mm", "Sync", line: 2154

    Thanks!

  5. #5
    James Brinkerhoff is offline Intermediate Member
    Join Date
    May 2006
    Location
    New York, NY US
    Posts
    23
    Rep Power
    9

    Default Same issue with 3.1.4 and iSync 0.9.12, but not 4.0RC1

    Things seem to work fine with 4.0, RC1. However with 3.1.4 it seems that isync fails to authenticate when a shared calendar is accepted.

    [assert] error: (null)
    [assert] where: "ZimbraClient.mm", "-[ZimbraClient authenticate:]", line: 1272

    [assert] error: (null)
    [assert] where: "ZimbraHelper_main.mm", "Authenticate", line: 2051

    I'm willing to wait till 4.0, just an FYI

    -jwb

  6. #6
    travisbell is offline Active Member
    Join Date
    Aug 2006
    Posts
    33
    Rep Power
    9

    Default

    Yes, Contacts and the personal calendars seem to work alright, my issue is with a shared calendar as well.

  7. #7
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Guys the best option here is to file a support ticket with support@zimbra.com, and send us a zip file with all the sync logs and the version of the iSync connector your using. This way we can take a look and try to solve it.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    travisbell is offline Active Member
    Join Date
    Aug 2006
    Posts
    33
    Rep Power
    9

    Default

    Thanks Kevin.

    I have emailed support with my log. Hope she gets fixed up soon!

  9. #9
    travisbell is offline Active Member
    Join Date
    Aug 2006
    Posts
    33
    Rep Power
    9

    Default

    Just an update.

    A new version of the iSync connector (0.9.14) was released that seemed to allow me the ability to use shared calendars again. Then starting yesterday (no idea what changed) I can't seem to use it anymore without it erroring out again.

    I have emailed support and here's hoping it an easy fix!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 01:01 PM
  2. Zimbra Mobile fails with Java Exception
    By JasonChase in forum Zimbra Mobile
    Replies: 7
    Last Post: 01-21-2008, 07:25 PM
  3. [SOLVED] iSync issues (calendar sync hangs)
    By mbd in forum CalDAV / CardDAV / iSync
    Replies: 17
    Last Post: 06-11-2007, 11:36 AM
  4. Replies: 4
    Last Post: 01-25-2007, 03:08 PM
  5. iCal sync failing with shared calendars
    By travisbell in forum CalDAV / CardDAV / iSync
    Replies: 10
    Last Post: 10-19-2006, 08:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •