Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: iCal broken in 5.0.6?

  1. #1
    frankske's Avatar
    frankske is offline Senior Member
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default iCal broken in 5.0.6?

    I've recently upgraded a customer's server to 5.0.6 and it seems the upgrade (from 5.0.4) broke iCal usage: existing calendars still work, but subscribing to new ones (using CalDav) doesn't work. I've created a bug report here: Bug 29568 – iCal support with multiple domains completely broken in 5.0.6

    Anyone seeing the same thing? Any things I could try (besides downgrading)?

    Frank

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    First off, a couple of notes.

    1) We've seen this before. We are members of CalConnect, which is the standards setting advisement body for calendaring protocols. We also work closely with Apple, and have had confirmation that the behavior you're seeing is an iCal issue.
    2) Bug hijacking isn't allowed. If you search the forums, you'll see others who will have the same issue as you.
    3) Bugzilla isn't for troubleshooting. It's for bugs. I've determined that yours is not a bug.

    Now to the issue.

    What version iCal are you using? Have you tried lightening or Mulberry? Also, is this 10.5.4 or 10.0.3?

    Next, please provide a screenshot of your config.

  3. #3
    frankske's Avatar
    frankske is offline Senior Member
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default

    1) I do consider it a bug if a perfectly working setup stops working after upgrading to 5.0.6 on 1 server, and still perfectly works on another.

    2) I noticed the other bugs, and determined this is not the same one (you can't seem to believe I do leave out the /, you can't seem to believe this isn't my first ical setup, you can't seem to believe it still works on other servers I manage)

    I am using latest iCal. I was on 10.5.3 until this morning, and upgraded to 10.5.4. Issue appears on both versions.

    When trying Mulberry I get "Method PROPFIND is not defined in RFC 2068 and is not supported by the Servlet API"

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Can you please provide the screenshot? Our hosted demo Zimbra Collaboration Suite Log In is running 5.0.6 and it works fine.

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by frankske View Post
    1) I do consider it a bug if a perfectly working setup stops working after upgrading to 5.0.6 on 1 server, and still perfectly works on another.
    We put in a work around to fix the iCal bug in earlier editions of Zimbra. That's why it did, but doesn't work.

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by frankske View Post
    When trying Mulberry I get "Method PROPFIND is not defined in RFC 2068 and is not supported by the Servlet API"
    Did you follow the setup instructions?
    CalDav and Mulberry - Zimbra :: Wiki

  7. #7
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Also, can you give exact step by step instructions? If Valid and reproducible, I'll reopen.

  8. #8
    frankske's Avatar
    frankske is offline Senior Member
    Join Date
    Jan 2008
    Location
    Gent, Belgium
    Posts
    62
    Rep Power
    7

    Default

    Settings: http://dl.getdropbox.com/u/20810/Picture%207.png (notice the missing / at the end)

    http://dl.getdropbox.com/u/20810/Picture%208.png (error I get as soon as I hit add on the previous dialog box)

    Mulberry now doesn't give an error, but doesn't show the calendars either. I've configured Mulberry to connect to my 5.0.4 server, and it then shows the folders on that account (not only the calendars, but I assume that's normal?)

  9. #9
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Can you provide the http trace from that?

  10. #10
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by frankske View Post
    Settings: http://dl.getdropbox.com/u/20810/Picture%207.png (notice the missing / at the end)

    http://dl.getdropbox.com/u/20810/Picture%208.png (error I get as soon as I hit add on the previous dialog box)

    Mulberry now doesn't give an error, but doesn't show the calendars either. I've configured Mulberry to connect to my 5.0.4 server, and it then shows the folders on that account (not only the calendars, but I assume that's normal?)
    Yeah, it's normal. CalDav is built on the webdav spec.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iCal attendee lookup using Zimbra directory
    By Erik T in forum CalDAV / CardDAV / iSync
    Replies: 17
    Last Post: 09-01-2009, 08:15 PM
  2. [SOLVED] Documents broken? (5.0.6)
    By oliver2uk in forum Administrators
    Replies: 1
    Last Post: 06-03-2008, 11:33 AM
  3. zimbra 5.0.5 -> 5.0.6, multi-server, sasl auth broken
    By spirit in forum Administrators
    Replies: 0
    Last Post: 05-26-2008, 12:48 AM
  4. Replies: 1
    Last Post: 03-24-2008, 02:35 PM
  5. Connect Zimbra iCal without password ?
    By marinew in forum Administrators
    Replies: 4
    Last Post: 10-22-2007, 08:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •