Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: iSync Connector not performing full sync

  1. #1
    jncolin is offline New Member
    Join Date
    Nov 2007
    Posts
    4
    Rep Power
    7

    Unhappy iSync Connector not performing full sync

    Hi

    I have ZCS 4.5.9, and iSync Connector 4.5.9_GA_1450 running on Leopard.
    I keep having problems synchronizing iCal with ZCS; some events are sync'd, other not, in the same calendar. I tried many times to reset everything; reset iSync (from preferences/reset Sync history), force Connector to resync (in Connector prefpane), reinstall connector, remove all preferences... Nothing work. I'm always having only partial syncs; I checked the connector log, and find that missing events (not sync'd ones) do not appear in the log files.

    I also noticed that if I make a change in iCal and do a Sync from the Connector, it gets pushed to ZCS; if I add or remove an event in ZCS, and I do a Sync, changes do not get pulled.

    I really would like a very simple recipe on how to copy my iCal calendars to ZCS.

    Thanks for your help

    Jean-Noel Colin
    Last edited by jncolin; 11-21-2007 at 05:07 AM.

  2. #2
    sculi2000 is offline Contractor
    Join Date
    Oct 2006
    Posts
    115
    Rep Power
    8

    Default

    Hey there. Sorry to hear you're having some problems. Could you do the following for me?

    1) Do a reset sync from the connector prefPane
    2) Attach the logs

    Thanks,

    Scott


    Quote Originally Posted by jncolin View Post
    Hi

    I have ZCS 4.5.9, and iSync Connector 4.5.9_GA_1450 running on Leopard.
    I keep having problems synchronizing iCal with ZCS; some events are sync'd, other not, in the same calendar. I tried many times to reset everything; reset iSync (from preferences/reset Sync history), force Connector to resync (in Connector prefpane), reinstall connector, remove all preferences... Nothing work. I'm always having only partial syncs; I checked the connector log, and find that missing events (not sync'd ones) do not appear in the log files.

    I also noticed that if I make a change in iCal and do a Sync from the Connector, it gets pushed to ZCS; if I add or remove an event in ZCS, and I do a Sync, changes do not get pulled.

    I really would like a very simple recipe on how to copy my iCal calendars to ZCS.

    Thanks for your help

    Jean-Noel Colin

  3. #3
    emalakoff is offline Starter Member
    Join Date
    Nov 2007
    Posts
    2
    Rep Power
    7

    Default

    I am having the exact same issues. I have reset everything on my Mac and rebooted. It will not move all the information to the the web based calendar.

    We are using a trial, and solving this is a big deal for us. Any advice would be helpful.

  4. #4
    skyhorse is offline New Member
    Join Date
    Nov 2007
    Posts
    3
    Rep Power
    7

    Default

    I'm having the same problem.

    Some events are synced some aren't. I have tried:

    - removed Zimbra connector, including files from
    Library/Zimbra/*

    - remove all calendars from iCal, and deleted all files in Library/Calendars/*.calendar
    Library/Calendars/Calendar Sync Changes
    Library/Calendars/Calendar Cache

    - forced re-sync in iSync by running:
    /System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsync.pl full

    - installed Zimbra connector 4.5.9

    - run a manual Reset Sync Data with Pull data from Zimbra option


    The syslog shows all items are retrieved from Zimbra. They just don't make it to Calendar in iCal.

    I'm running leopard with all sw update so far. The only other different thing is the fact I had added automatically a calendar called 'calendar' in iCal that Mail uses for to-do lists (same name but different case as the Calendar Zimbra uses for syncing)

  5. #5
    sculi2000 is offline Contractor
    Join Date
    Oct 2006
    Posts
    115
    Rep Power
    8

    Default

    There seems to be two issues that we've been tracking. The first issue is that appts from iCal are not making it to the zimbra mailbox. This issue is being tracked by bug 21986. There is a workaround for this until the fix comes in a subsequent version.

    1) Verify that there is a calendar folder in zimbra mailbox with same name as iCal calendar
    2) Go to iSync Connector prefPane
    3) Click 'Advanced'
    4) Click 'Reset Sync Data' and choose "Pull all data..."

    The subsequent sync should populate the mailbox with appts from iCal.

    The second issue is that appts from the mailbox are not making it to iCal. What we've noticed so far is that there are exceptions being thrown in the system log from iCal. If you are having this problem, please check Console.app and see if iCal is reporting errors. Because these errors are occurring in the iCal application itself, it's not clear what we can do to fix it. We are looking into it however.

    Thanks,

    Scott

  6. #6
    emalakoff is offline Starter Member
    Join Date
    Nov 2007
    Posts
    2
    Rep Power
    7

    Default One Time Appt

    One thing I have discovered is that the only previous appointments before I installed the isync connector that did not migrate to the web based ZCS site were one-time only appt. All my recurring appts. (like carpool or sports practices or birthdays) that I have set to recur weekly or annually did move over. Just one-time only Dr appt. or meetings did not.

    My work around was to sync and then I manually went through and reentered the appt in ical. I do keep the auto sync tab on and all the new appt made going forward in ical do move over. So the bug is just moving previous one time entries placed iCal before syncing the first time do not move over.

    Luckily, most of my mtg and appt were not to difficult to re-enter. I did take some time....

    I would be nice to fix that.

  7. #7
    skyhorse is offline New Member
    Join Date
    Nov 2007
    Posts
    3
    Rep Power
    7

    Default

    I am experiencing the problem syncing from mailbox -> iCal

    syslog shows some errors from iCal.

    Right at the end of the sync, these are the messages:

    26/11/2007 22:27:52 [0x0-0x4e04e].com.apple.systempreferences[570] [Mon Nov 26 22:27:52 200] about to accept calendar changes (575)
    26/11/2007 22:27:53 [0x0-0x4e04e].com.apple.systempreferences[570] [Mon Nov 26 22:27:53 200] finished syncing (575)
    26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [Mon Nov 26 22:27:53 200] Mac OS X version is 1051 (582)
    26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [Mon Nov 26 22:27:53 200] [assert] error: 35
    26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [assert] where: "ZimbraHelper_main.mm", "ObtainLock", line: 2257
    26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] (582)
    26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [Mon Nov 26 22:27:53 200] [assert] error: (null)
    26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] [assert] where: "ZimbraHelper_main.mm", "main", line: 3953
    26/11/2007 22:27:53 com.apple.syncservices.SyncServer[564] (582)
    26/11/2007 22:30:10 com.apple.launchd[153] ([0x0-0x54054].dotmacsyncclient[585]) Exited with exit code: 113


    After that, the following show up every few minutes (probably when iCal is syncing):

    27/11/2007 10:40:56 iCal[987] Unexpected EOF, returning last token as fallback

    a few times and then this:

    27/11/2007 10:44:34 com.apple.launchd[153] ([0x0-0x91091].dotmacsyncclient[1191]) Exited with exit code: 113


    Hope this helps.....

  8. #8
    skyhorse is offline New Member
    Join Date
    Nov 2007
    Posts
    3
    Rep Power
    7

    Default

    interestingly enough, it started syncing all appointments (at least the ones I knew were not being synced) again this afternoon...

    The only thing I changed was remove the network settings file and create a blank new one by adding a new "location". I had to do this because I had the Missing Sync installed previously and this left hundreds of virtual network devices that I wanted to remove...

    Maybe its a clue...

  9. #9
    isam is offline Starter Member
    Join Date
    Nov 2007
    Posts
    1
    Rep Power
    7

    Default

    I had a problem that might be similar, I am using Zimbra iSync 4.5.1450 .. the problem I am having is that only the events with "attendants" are synced .. all other events in my iCal calendar didn't appear in Zimbra ..

    Is this an issue in the Zimbra iSync connector ? or I am missing a configuration or something ?

  10. #10
    griffon is offline Active Member
    Join Date
    Apr 2007
    Posts
    34
    Rep Power
    8

    Default same issue

    I have two users that have the same issue (4.9GA). Their calendars just stooped updating the other day. Doing a full resync doesn't correct it. I asked for logs and will post them as soon as I get them. I thought the isync was the 'one' zimbra feature that wasn't going haywire on us :P.
    Last edited by griffon; 11-30-2007 at 12:50 PM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Non-Mobile Non-Outlook Palm Sync
    By lapplegate in forum Zimbra Mobile
    Replies: 10
    Last Post: 10-19-2010, 10:37 AM
  2. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 01:01 PM
  3. Zimbra Mobile fails with Java Exception
    By JasonChase in forum Zimbra Mobile
    Replies: 7
    Last Post: 01-21-2008, 07:25 PM
  4. Replies: 0
    Last Post: 09-08-2007, 03:00 AM
  5. [SOLVED] iSync issues (calendar sync hangs)
    By mbd in forum CalDAV / CardDAV / iSync
    Replies: 17
    Last Post: 06-11-2007, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •