Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 46

Thread: [SOLVED] Antivirus not running, sending all mail to deferred queue

  1. #21
    Vipergts is offline Starter Member
    Join Date
    Jul 2007
    Posts
    1
    Rep Power
    7

    Default

    I also had the same problem, but I could solve this rather easily.

    I moved main.cvd to main.cvd and for daily.cvd I did the same. Then I downloaded the files myself from the server.
    Changed the owner and group to zimbra, restarted zimbra and all problems were solved.

  2. #22
    ipguru99 is offline Active Member
    Join Date
    Jun 2006
    Posts
    32
    Rep Power
    9

    Default running fine, as long as clamd isn't

    I think I have the same thing.. but I tried what algogr did, and it never copies over the pid file. I double checked, created the empty file as zimbra user, backed up the zmanti script (good suggestion), then tried to restart clamd.. nothing. I just keeps dying. I also lost power about 14 days ago, but there are only 2 users in the house running zimbra, so it wasn't as noticeable.

    Using Ubuntu 6.06, Ubuntu 4.5.5 Zimbra. I have stopped the antivirus in the web admin console, and restarted Zimbra.. now everything works fine. Deferred messages were re-queued and went through just fine.

    Anybody else help/solved this?

    thanks!

  3. #23
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Just an FYI-
    we're currently investigating a bug where in certain instances, the CLAMAV db can corrupt, causing delivery issues.

    See Bug 18312 - clamd corrupt db

  4. #24
    greywolf is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    Richmond, Virginia
    Posts
    18
    Rep Power
    8

    Default

    I am also unable to get clamd started. It was working earlier today and after a restart of the zimbra processes, it is now unable to bind to the port and does not create a pid. I have tried everything previously posted in the thread to no avail. Currently running without anti virus.

    Version 4.5.6 on Ubuntu 6.10

  5. #25
    greywolf is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    Richmond, Virginia
    Posts
    18
    Rep Power
    8

    Default

    Also I should state that I had no crash of my server or Zimbra.
    -Steve

  6. #26
    greywolf is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    Richmond, Virginia
    Posts
    18
    Rep Power
    8

    Default

    OK found the answer to my issue here:

    http://www.zimbra.com/forums/install...happening.html

    Basically it takes 3 minutes for clamd to read in the db file. Once it does it will bind to the port and start normally. I changed the interval in this file:

    /opt/zimbra/libexec/zmmtaconfig

    from 120 to 180. Now it starts just fine.
    -Steve

  7. #27
    ipguru99 is offline Active Member
    Join Date
    Jun 2006
    Posts
    32
    Rep Power
    9

    Default yep...

    Just going into the web console and starting antivirus fired off everything and it still seemed to fail. Stopping zimbra and starting it worked, though.

    thanks! This did it! Just in case anyone else had an 'almost' underpowered machine... this install is on a pIII 800 with 512mb of memory. I am wondering if anyone else that was having this problem was on a slower machine?.. like maybe that was why it was taking SO long to start?

    Thanks!

  8. #28
    neilmc is offline Active Member
    Join Date
    Nov 2005
    Posts
    44
    Rep Power
    9

    Default

    Quote Originally Posted by greywolf View Post
    ..... snip... I changed the interval in this file:

    /opt/zimbra/libexec/zmmtaconfig

    from 120 to 180. Now it starts just fine.
    That worked on ours too. AV service wouldn't start without changing the interval setting.

    We're using 5 beta 2 where the default seems to be 60 seconds. It's at 180 now, but I might try dropping back to 120 later today.

    We've got an old P4 2.4ghz Dell desktop machine with 768mb ram & about 30 mailboxes on ours. (about 8-10 get regular daily use).

  9. #29
    stormchas3r is offline Active Member
    Join Date
    Feb 2006
    Location
    Media, Pa USA
    Posts
    35
    Rep Power
    9

    Default

    Well. I am having the same problem as all of you, but mine is not working. I rm -R /db and reinstalled with update. Changed the interval to 180 and clam is still failing.

    Anymore thoughts?

  10. #30
    stormchas3r is offline Active Member
    Join Date
    Feb 2006
    Location
    Media, Pa USA
    Posts
    35
    Rep Power
    9

    Default

    Ok, now I am really sweating. i disabled clamav, but now the mail that I am sending is getting deferred. When I look at the deferred mail, it says that my connection to smtp is timing out.

    I am not really sure why this is happening. Is it possible that my ISP is blocking port 25?

    Please let me know when this bug is fixed.
    Last edited by stormchas3r; 08-05-2007 at 07:14 AM.

Page 3 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. Replies: 3
    Last Post: 07-19-2007, 02:00 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •