Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: zmamavisdctl and tomcat are not running (anymore)

  1. #11
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default That's not it

    RE: ORION's Problem:
    The web apps error is trival and can be ignored. The real problem is at the end of catalina.out:
    Code:
    Fatal error: terminating: PrivilegedServlet init failed
    java.net.BindException: Address already in use
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
        at java.net.ServerSocket.bind(ServerSocket.java:319)
        at com.zimbra.cs.util.NetUtil.newBoundServerSocket(NetUtil.java:111)
        at com.zimbra.cs.util.NetUtil.bindServerSocket(NetUtil.java:134)
        at com.zimbra.cs.util.NetUtil.bindTcpServerSocket(NetUtil.java:63)
        at com.zimbra.cs.servlet.PrivilegedServlet.init(PrivilegedServlet.java:94)
        at javax.servlet.GenericServlet.init(GenericServlet.java:211)
        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1105)
        at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:932)
        at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3915)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4176)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
        at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:910)
        at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:873)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:474)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1118)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1020)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1012)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
        at org.apache.catalina.core.StandardService.start(StandardService.java:450)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:275)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:406)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at com.zimbra.cs.launcher.TomcatLauncher.start(TomcatLauncher.java:52)
        at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatLauncher.java:74)
    So, stop what ever's running on port 80.
    Did you start pop3/imap proxy, and forget you did? Because it doesn't take effect until you reboot.
    If you did
    Code:
    su - zimbra
    tomcat stop
    zmperditionctl sop
    tomcat start
    login to the adminui, and uncheck IMAP proxy.

    Good luck
    john

  2. #12
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by sixx View Post
    Hello.

    I'm experiencing exactly the same problem.
    As I was trying to connect to the imap port with Outlook, the Admin interface suddenly crashed. Since then, whatever I try, in the end I get:

    Code:
    [zimbra@enola ~]$ zmcontrol status
    Host some.host.tld
            antispam                Running
            antivirus               Running
            imapproxy               Running
            ldap                    Running
            logger                  Running
            mailbox                 Stopped
                    tomcat is not running
            mta                     Running
            snmp                    Running
            spell                   Running
    catalina.out says:

    Code:
    Jun 9, 2007 7:09:09 AM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-80
    Jun 9, 2007 7:09:10 AM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-7071
    Jun 9, 2007 7:09:10 AM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 1464 ms
    Jun 9, 2007 7:09:10 AM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Jun 9, 2007 7:09:10 AM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.15
    Jun 9, 2007 7:09:10 AM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    log4j:WARN No appenders could be found for logger (org.apache.catalina.startup.TldConfig).
    log4j:WARN Please initialize the log4j system properly.
    Jun 9, 2007 7:09:11 AM org.apache.catalina.core.StandardContext resourcesStart
    SEVERE: Error starting static Resources
    java.lang.IllegalArgumentException: Document base /opt/zimbra/apache-tomcat-5.5.15/server/webapps/host-manager does not exist or is not a readable directory
            at org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:140)
            at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:3812)
            at org.apache.catalina.core.StandardContext.start(StandardContext.java:3983)
            at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
            at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
            at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
            at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:603)
            at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:535)
            at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:470)
            at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1118)
            at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:310)
            at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
            at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1020)
            at org.apache.catalina.core.StandardHost.start(StandardHost.java:718)
            at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1012)
            at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:442)
            at org.apache.catalina.core.StandardService.start(StandardService.java:450)
            at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
            at org.apache.catalina.startup.Catalina.start(Catalina.java:551)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:275)
            at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:406)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at com.zimbra.cs.launcher.TomcatLauncher.start(TomcatLauncher.java:52)
            at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatLauncher.java:74)
    Help ?
    Please post your catalina.out located in /opt/zimbra/tomcat/log/catalina.out

  3. #13
    sixx is offline New Member
    Join Date
    May 2007
    Posts
    3
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    Please post your catalina.out located in /opt/zimbra/tomcat/log/catalina.out

    I did, in my first post.


    Quote Originally Posted by jholder View Post
    Did you start pop3/imap proxy, and forget you did? Because it doesn't take effect until you reboot.
    If you did
    Code:

    su - zimbra
    tomcat stop
    zmperditionctl sop
    tomcat start

    login to the adminui, and uncheck IMAP proxy.
    That did the trick for me. I did in fact (i dont know when and why) enable imap proxy.

    Thank you.

  4. #14
    oerton is offline Member
    Join Date
    Jun 2007
    Posts
    11
    Rep Power
    8

    Default it works

    Hello,

    The last commands worked for me too !
    So, the problem was due to imap/pop proxy activated, and not by hostname change.
    It looks like the script to change hostname worked perfectly.

    Thanks a lot for you help !

    Olivier.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. error message on install
    By jptech in forum Installation
    Replies: 20
    Last Post: 04-01-2007, 01:52 PM
  2. I want to learn the UI design
    By wildhuman in forum Developers
    Replies: 16
    Last Post: 10-05-2006, 05:24 AM
  3. Install problem on Intel iMac...
    By melmaninga in forum Installation
    Replies: 5
    Last Post: 05-28-2006, 08:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •