Results 1 to 9 of 9

Thread: Automatically Drop Deffered Mail -PM to thread

  1. #1
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default Automatically Drop Deffered Mail -PM to thread

    PM converted into thread:

    haniko
    Automatically Drop Deffered Mail
    Dear Sir

    How can I dropped email from deferred email, if destination mail not found.
    Thank

    Regards
    Hendri
    You don't want mail to be re-tried for delivery?
    Keep in mind all the possible things that could be in the way of mail delivery, a net outage on your end, ISP outage, power outages, heavy traffic on either end, someone down for weekend maintenance, etc.

    The mail in the deferred queue will retry for about 4 days (I believe).
    (there's a number of max retries you can set with that-but by default it appears to be spaced out to 4 days.)

    Define 'Automatically Drop Deffered'
    Do you want to lower the number of retries?
    Lower the number of days it attempts those retries?
    Shorten the time that it retries? (ie every minute vs every hr etc)

    You can also delete them manually via the admin console.

  2. #2
    haniko is offline Junior Member
    Join Date
    May 2007
    Posts
    7
    Rep Power
    8

    Default Automatically Drop Deffered Mail

    Dear Sir

    I want this, if the destination mail server not found in 1 day, all
    mail on deferred mail automatically deleted.
    How can I do this option Sir ?
    Thanks.

    Regards
    Hendri

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default Deferred queue lifetime - maximal_queue_lifetime

    maximal_queue_lifetime (default: 5d) The maximal time a message is queued before it is sent back as undeliverable.
    Time units: s (seconds), m (minutes), h (hours), d (days), w (weeks). The default time unit is d (days).
    Specify 0 when mail delivery should be tried only once.

    ---
    You essentially want maximal_queue_lifetime in postfix's main.conf
    However, you cannot edit main.conf directly-it will overwrite on every startup. (essentially you will never get a change to apply it via a postfix refresh.)

    so:

    >su zimbra
    and read up on maximal_queue_lifetime via:
    >man 5 postconf (scroll down/search for the maximal_queue_lifetime section)
    to learn how postconf works also read:
    >man postconf

    ----
    also kinda relevant to you/anyone else searching this thread later:

    queue_run_delay (default: 300s) The time between deferred queue scans by the queue manager; prior to Postfix 2.4 the default value was 1000s.
    This parameter should be set less than or equal to $minimal_backoff_time.
    Time units: s (seconds), m (minutes), h (hours), d (days), w (weeks). The default time unit is s (seconds).

    minimal_backoff_time (default: 300s) The minimal time between attempts to deliver a deferred message; prior to Postfix 2.4 the default value was 1000s.
    This parameter also limits the time an unreachable destination is kept in the short-term, in-memory, destination status cache.
    This parameter should be set greater than or equal to $queue_run_delay.
    Time units: s (seconds), m (minutes), h (hours), d (days), w (weeks). The default time unit is s (seconds).

    maximal_backoff_time (default: 4000s) The maximal time between attempts to deliver a deferred message.
    This parameter should be set to a value greater than or equal to $minimal_backoff_time.
    Time units: s (seconds), m (minutes), h (hours), d (days), w (weeks). The default time unit is s (seconds).
    Last edited by mmorse; 05-29-2007 at 05:55 PM.

  4. #4
    haniko is offline Junior Member
    Join Date
    May 2007
    Posts
    7
    Rep Power
    8

    Default Automatically Drop Deffered Mail

    Dear Sir

    I try using the command line

    postconf -e maximal_queue_lifetime 1d

    but I Found the error message

    /opt/zimbra/postfix-2.2.9/sbin/postconf: fatal: missing '=' after attribute name: "maximal_queue_lifetime"

    what wrong for this command

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    Quote Originally Posted by haniko View Post
    fatal: missing '=' after attribute name: "maximal_queue_lifetime"
    It tells you in the error message, there's a missing '=' sign i.e. = 1d
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    haniko is offline Junior Member
    Join Date
    May 2007
    Posts
    7
    Rep Power
    8

    Default Automatically Drop Deffered Mail -PM to thread

    After I write

    postconf -e maximal_queue_lifetime='1d'

    I run this command :

    $ zmcontrol shutdown
    $ zmcontrol restart
    $ postconf -d

    but

    the parameter in main.cf not change

    maximal_queue_lifetime = 5d

    what wrong sir ?

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    The format of the command is wrong: postconf -e maximal_queue_lifetime = 1d
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    haniko is offline Junior Member
    Join Date
    May 2007
    Posts
    7
    Rep Power
    8

    Default Automatically Drop Deffered Mail -PM to thread

    what the right command line sir ?

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    Quote Originally Posted by haniko View Post
    what the right command line sir ?
    I've already given it to you in the post above. You could always look at the postfix manual for the correct format!
    Last edited by phoenix; 06-01-2007 at 05:52 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •