Results 1 to 8 of 8

Thread: After Install on SuSE 10.2

  1. #1
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    8

    Default After Install on SuSE 10.2

    Reporting-MTA: dns; test-linux.brckntwrks.com
    X-Postfix-Queue-ID: AB1A621C25
    X-Postfix-Sender: rfc822; bill@brocknetworks.com
    Arrival-Date: Thu, 24 May 2007 09:26:19 -0500 (CDT)
    Content-Type: text/plain

    Final-Recipient: rfc822; admin@brckntwrks.com
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; mail for brckntwrks.com loops back to myself

    What would be causing this loopback error upon testing the mail server?

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Alias's, DNS, Hosts file, other redirects the list goes on (i'm gonna go with DNS first)


    Kinda old but I found this interesting via a google search:
    http://www.topology.org/linux/postfixloop.html

  3. #3
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    8

    Default DNS question?

    Will ZCS use the DNS servers which are setup in SuSE's network configuration or does ZCS need to be told what resolver to use?

    I'm using a DNS server other than the ZCS install server for resolution. I know the MX records are setup properly. Thus my question.

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    yes it uses your machines dns settings

    I was refering to brckntwrks.com which returns no answer- at least from the outside world:

    $ dig mx brckntwrks.com
    ; <<>> DiG 9.3.4 <<>> mx brckntwrks.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 53500
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;brckntwrks.com. IN MX
    ;; AUTHORITY SECTION:
    com. 900 IN SOA a.gtld-servers.net. nstld.verisign-grs.com. 1180026449 1800 900 604800 900
    ;; Query time: 4 msec
    ;; SERVER: mine
    ;; WHEN: Thu May 24 12:07:56 2007
    ;; MSG SIZE rcvd: 108


    $ dig brckntwrks.com
    ; <<>> DiG 9.3.4 <<>> brckntwrks.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 63867
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;brckntwrks.com. IN A
    ;; AUTHORITY SECTION:
    com. 878 IN SOA a.gtld-servers.net. nstld.verisign-grs.com. 1180026449 1800 900 604800 900
    ;; Query time: 3 msec
    ;; SERVER: (mine)
    ;; WHEN: Thu May 24 12:08:18 2007
    ;; MSG SIZE rcvd: 105


    However there's tons of stuff on:
    $ dig mx brocknetworks.com
    ; <<>> DiG 9.3.4 <<>> mx brocknetworks.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14478
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 3, ADDITIONAL: 7
    ;; QUESTION SECTION:
    ;brocknetworks.com. IN MX
    ;; ANSWER SECTION:
    brocknetworks.com. 3600 IN MX 4 mail3.brocknetworks.com.
    brocknetworks.com. 3600 IN MX 3 mail2.brocknetworks.com.
    brocknetworks.com. 3600 IN MX 2 webmail.brocknetworks.com.
    brocknetworks.com. 3600 IN MX 1 mail.brocknetworks.com.
    ;; AUTHORITY SECTION:
    brocknetworks.com. 172800 IN NS fs-brock.brocknetworks.com.
    brocknetworks.com. 172800 IN NS fs2k-brock.brocknetworks.com.
    brocknetworks.com. 172800 IN NS macdaddy.mcalestertvandpc.com.

    ;; ADDITIONAL SECTION:
    mail3.brocknetworks.com. 3600 IN A 24.249.6.135
    mail2.brocknetworks.com. 3600 IN A 24.249.6.168
    webmail.brocknetworks.com. 3600 IN A 24.249.6.169
    mail.brocknetworks.com. 3600 IN A 24.249.6.133
    fs-brock.brocknetworks.com. 172800 IN A 24.249.6.62
    fs2k-brock.brocknetworks.com. 172800 IN A 24.249.6.133
    macdaddy.mcalestertvandpc.com. 172800 IN A 65.64.54.13
    ;; Query time: 11 msec
    ;; SERVER: (mine)
    ;; WHEN: Thu May 24 12:07:28 2007
    ;; MSG SIZE rcvd: 341

  5. #5
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    8

    Default It resolves from my inside world.

    Since it is just a test install, I have the start of authority on one of my other DNS servers and have set SuSE to resolve using that server. And since it is a test bed I don't have the domain registered.

    Here is the zone file

    ;
    ; Database file brckntwrks.com.dns for brckntwrks.com zone.
    ; Zone version: 2007052213
    ;

    @ 172800 IN SOA test-linux.brckntwrks.com. root.test-linux.brckntwrks.com. (
    2007052213 ; serial number
    10800 ; refresh
    3600 ; retry
    604800 ; expire
    86400 ) ; minimum TTL

    ;
    ; Zone NS records
    ;

    @ 172800 NS fs-brock.brocknetworks.com.
    @ 172800 NS test-linux.brckntwrks.com.
    @ NS fs2k-brock.brocknetworks.com.
    fs2k-brock.brocknetworks.com. A 24.249.6.133

    ;
    ; Zone records
    ;

    @ MX 10 test-linux.brckntwrks.com.
    localhost A 127.0.0.1
    test-linux 172800 A 192.168.1.199

  6. #6
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    8

    Default "Loop back to myself" solved, BUT

    Now ZCS is telling me admin user doesn't exist as well as a second user I setup.

    This is disheartening. My Windows mail server I've been using for four years installed and worked in 30 minutes. I've spent four day with ZCS and still problems.

    I'm trying hard to Open source but it is leaving a lot of open sores :-)

  7. #7
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    8

    Default Solved "user doesn't exist" issue.

    By default, ZCS listed the domain as the FQDN of the mail server instead of the domain portion. The admin then had an e-mail address of admin@test-linux.brckntwrks.com instead of admin@brckntwrks.com.

    By adding a second domain and naming in simply brckntwrks.com and moving admin to that domain, sending mail to admin@brckntwrks.com no longer generated an error and the mail was delivered.

  8. #8
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    glad you got it working-there's often so many variables it's hard to troubleshoot via forums-it often takes 5 posts just to figure out what the current running setup is

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails to install on SuSE 10
    By penpal in forum Installation
    Replies: 10
    Last Post: 12-07-2007, 02:14 PM
  2. Install on (64bit !) SUSE Linux Entreprise Server 10
    By fillide in forum Installation
    Replies: 1
    Last Post: 07-04-2007, 09:06 AM
  3. ZCS 4.5.4 install failed on openSUSE 10.2
    By ardiederich in forum Installation
    Replies: 1
    Last Post: 04-17-2007, 09:46 AM
  4. Install Help Suse 10.1
    By rusty741 in forum Installation
    Replies: 21
    Last Post: 10-02-2006, 01:05 AM
  5. Install of Zimbra-Apache failed on SUSE 10
    By JeffT in forum Installation
    Replies: 2
    Last Post: 03-08-2006, 12:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •