Results 1 to 6 of 6

Thread: How to update mailmode

  1. #1
    nickteagle is offline Member
    Join Date
    Sep 2006
    Posts
    14
    Rep Power
    8

    Default How to update mailmode

    Hi I'm trying to get ssl working on port 465 so I can get outlook 2003 working as per this posting Trouble sending mail from Outlook

    The mailmode and authurl are set wrong and i wanted to update them but can't see how I can do this ?

    Thanks Nick

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Use zmprov, details can be seen by doing 'zmprov help commands' or look in the wiki for 'mailmode'.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    nickteagle is offline Member
    Join Date
    Sep 2006
    Posts
    14
    Rep Power
    8

    Default zmprov error

    Thanks for your reply. I've just tried to do the update and the modification of MailMode went fine but an update to AuthURL fails with the following:

    zimbra@mail:~> zmprov gs mail.xxx.co.uk | grep AuthURL
    zimbraMtaAuthURL: http://mail.xxx.co.uk/service/soap/
    zimbra@mail:~> zmprov ms mail.xxx.co.uk zimbraMtaAuthURL https://mail.xxx.co.uk/service/soap/
    ERROR: service.INVALID_REQUEST (invalid request: zimbraMtaAuthURL is immutable)

    any idea ?

    Thanks Nick

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Did you restart tomcat? What is the mailmode set to? What exact steps did you take?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    nickteagle is offline Member
    Join Date
    Sep 2006
    Posts
    14
    Rep Power
    8

    Default

    These are the steps I took straight after each other. No i didn't restart inbetween. Just done restart which hasn't changed anything

    zimbra@mail:~> zmprov gs mail.strictlydigital.co.uk | grep MailMode
    zimbraMailMode: http
    zimbra@mail:~> zmprov ms mail.strictlydigital.co.uk zimbraMailMode mixed
    zimbra@mail:~> zmprov gs mail.strictlydigital.co.uk | grep AuthURL
    zimbraMtaAuthURL: http://mail.strictlydigital.co.uk/service/soap/
    zimbra@mail:~> zmprov ms mail.strictlydigital.co.uk zimbraMtaAuthURL https://mail.strictlydigital.co.uk/service/soap/
    ERROR: service.INVALID_REQUEST (invalid request: zimbraMtaAuthURL is immutable)
    zimbra@mail:~> zmprov gs mail.strictlydigital.co.uk | grep AuthURL
    zimbraMtaAuthURL: http://mail.strictlydigital.co.uk/service/soap/

    thanks Nick

  6. #6
    bugsy is offline New Member
    Join Date
    Jun 2007
    Posts
    3
    Rep Power
    0

    Default

    Quote Originally Posted by nickteagle View Post
    ERROR: service.INVALID_REQUEST (invalid request: zimbraMtaAuthURL is immutable)
    Hi Nick,

    to actually set the zimbraMtaAuthURL here is what worked for me:

    Code:
    zmprov ms `zmhostname` zimbraMtaAuthHost `zmhostname`
    This basically resets the zimbraMtaAuthHost value and additionally should also set the zimbraMtaAuthURL variable to the correct value (refers to bug #4244)

    Code:
    zmprov gs `zmhostname` | grep Auth
    Should now show you the correct zimbraMtaAuthURL.

    HTH,
    Dustin

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM
  2. Howto update contacts using REST interface?
    By tigger in forum Administrators
    Replies: 0
    Last Post: 05-23-2007, 03:26 AM
  3. i am so tired for zimbra update too quickly!!
    By nxzwt in forum Administrators
    Replies: 7
    Last Post: 05-08-2007, 09:47 AM
  4. ZCS 3.0 Beta 3 Update 2 Released
    By KevinH in forum Announcements
    Replies: 2
    Last Post: 01-25-2006, 01:36 PM
  5. Install on FC3 (or 4)
    By scottpledger in forum Installation
    Replies: 2
    Last Post: 10-07-2005, 11:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •