Now that Debian/etch has been released, I wanted to post the changes to make the installer work and ask the developers/Zimbra folks whether or not I can expect problems after installation.

There are two changes needed for the installer to work.

1. Change the debian version zcs/bin/get_plat_tag.sh from:

Code:
if [ -f /etc/debian_version ]; then
        grep "3.1" /etc/debian_version > /dev/null 2>&1
        if [ $? = 0 ]; then
                echo "DEBIAN3.1"
                exit 0
        fi
fi
to

Code:
if [ -f /etc/debian_version ]; then
        grep "4.0" /etc/debian_version > /dev/null 2>&1
        if [ $? = 0 ]; then
                echo "DEBIAN3.1"
                exit 0
        fi
fi
The second change would be to change the name of the libgmp package:

Code:
 PREREQ_PACKAGES="sudo libidn11 curl fetchmail libgmp3 libxml2 libstdc++6 openssl"
to

Code:
 PREREQ_PACKAGES="sudo libidn11 curl fetchmail libgmp3c2 libxml2 libstdc++6 openssl"
These should be the only changes required for installation on an etch box.

Devs, can we expect any problems with running the app on etch vice sarge?

Regards,
--Storm