Results 1 to 6 of 6

Thread: Outgoing messages marked as spam

  1. #1
    jimramsey is offline Junior Member
    Join Date
    Feb 2007
    Posts
    9
    Rep Power
    8

    Default Outgoing messages marked as spam

    I've seen a few related posts, but I'm not sure if they solve my problem, so here goes. It appears that when I send email from a mail client like T-bird using my Zimbra server as the SMTP server my mail gets tagged with a pretty high spam score by SpamAssassin.

    Here are my headers:

    X-Spam-Score: 2.864
    X-Spam-Level: **
    X-Spam-Status: No, score=2.864 tagged_above=-10 required=6.6
    tests=[AWL=-0.764, BAYES_00=-2.599, HTML_MESSAGE=0.001,
    RCVD_IN_NJABL_DUL=1.946, RCVD_IN_SORBS_DUL=2.046,
    RCVD_IN_WHOIS_INVALID=2.234]

    I fixed this for my email address by patching the /opt/zimbra/conf/amavisd.conf.in file and forcing it to give me an initial -10 score. However, this seems like a hack to me.

    Part of the problem is that at home I use Comcast as my provider, and therefore it is possible that my IP got put on some blacklist or another, though it seems to be complaining more that my address is dynamic.

    Now, I am authenticating to the SMTP server before I send mail out, so it seems to me that authenticated outgoing email should not be subject to spam filtering in the first place, or at least that this filtering should be configurable.

    I am getting lots of rejected emails because of this because recipients email programs are throwing my emails away when i send them from home. Like I said I can hack it to make my emails score better, but it still leaves in the headers.

    Is there a way to fix this?

    By the way I am using zcs-4.5.1_GA_660 on a Fedora 4 server.

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Please upgrade to 4.5.4
    Then, when you've done that, let's see if we still get the error.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Quote Originally Posted by jimramsey View Post
    Part of the problem is that at home I use Comcast as my provider, and therefore it is possible that my IP got put on some blacklist or another, though it seems to be complaining more that my address is dynamic.
    Your scores would seem to indicate that you're on a blacklist. Having a dynamic IP isn't specifically a problem (unless you're sending to AOL) but the problem may be that someone on your IP block has got on a RBL list and some lists will blacklist a whole IP block. Have you looked at some of the lists to see if you're on them? I have a feeling that there's an RFE for sending authenticated mail without going through spam checking, have a look in bugzilla and vote if there is one.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    jimramsey is offline Junior Member
    Join Date
    Feb 2007
    Posts
    9
    Rep Power
    8

    Default

    I found a potential solution in Bugzilla Bug #14469. The proposed solution was to change @local_domains_maps in amavisd.conf.in, like so:

    $ diff amavisd.conf.in~ amavisd.conf.in
    46c46
    < @local_domains_maps = ( [".$mydomain"] );
    ---
    > %local_domains = ( "bolton.liquidsys.com", "otherdomain.example.com" );

    This causes amavis to add all the X-Spam-blah headers to mail destined to local
    domains only.
    However, when I do that this is what I get:

    [zimbra@mail1 conf]$ zmamavisdctl restart
    umount: /opt/zimbra/amavisd-new-2.4.1/tmp is not mounted (according to mtab)
    [zimbra@mail1 conf]$ Variable "%local_domains_maps" is not imported at /opt/zimbra/conf/amavisd.conf line 47.
    Error in config file "/opt/zimbra/conf/amavisd.conf": Global symbol "%local_domains_maps" requires explicit package name at /opt/zimbra/conf/amavisd.conf line 47.
    I'm not a perl guy, so I'm not sure what this means, though it appears to be complaining about the "@local_domains_maps" changing to "%local_domains_maps".

    Any suggestions, or should I go dust off my perl books?

  5. #5
    legalizenet is offline Junior Member
    Join Date
    Oct 2007
    Posts
    6
    Rep Power
    7

    Default

    It should be @local_domains_maps and not %local_domains_maps.

    Guy who gave this solution was in hurry and looks like everyone is taking his solution string as it is..

  6. #6
    DVan is offline Active Member
    Join Date
    Mar 2007
    Posts
    44
    Rep Power
    8

    Default

    My users are also reporting Outbound authenticated email from our Zimbra server is being marked as spam on 4.5.9 NE. I've added our internal IP range to the whitelist in spamassassin's config, so I am hoping that resolves it, but realistically I can't see this as being desired behavior in any shape or fashion.

    I'll try the other setting posted in here in hope it helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trying to understand Zimbra's anti-spam system
    By TaskMaster in forum Users
    Replies: 11
    Last Post: 01-25-2008, 09:59 AM
  2. Replies: 2
    Last Post: 02-08-2007, 12:49 AM
  3. Training spam and ham
    By Justin in forum Developers
    Replies: 2
    Last Post: 10-31-2006, 03:39 PM
  4. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 01:34 PM
  5. All Messages Being Marked as SPAM
    By techdude550 in forum Administrators
    Replies: 2
    Last Post: 04-15-2006, 11:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •