Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Mail server host name in greeting

  1. #1
    nfear24 is offline Special Member
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Question Mail server host name in greeting

    according to dnsreports I am having this problem:

    If your mailserver sends out E-mail using this domain in its EHLO or HELO, your E-mail might get blocked by anti-spam software. This is also a technical violation of RFC821 4.3 (and RFC2821 4.3.1). Note that the hostname given in the SMTP greeting should have an A record pointing back to the same server. Note that this one test may use a cached DNS record.


    domain.com claims to be host mail.domain.com
    How can I go about fixing this in zimbra.

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Go into the admin ui, and there is an option to use ehlo for the domain. I can't remember if it's in the domain only, or global setting. . or maybe it's in the MTA tab

    Anyway, it's there. You'll need to restart tomcat.

  3. #3
    nfear24 is offline Special Member
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    Go into the admin ui, and there is an option to use ehlo for the domain. I can't remember if it's in the domain only, or global setting. . or maybe it's in the MTA tab

    Anyway, it's there. You'll need to restart tomcat.
    Hmmm, I cant seem to find it anywhere in the admin ui.

  4. #4
    nfear24 is offline Special Member
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default Helo

    Is there an option in a config file where I can change the HELO from mail.domain.com to domain.com.

  5. #5
    Nicrad's Avatar
    Nicrad is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Unhappy

    I'm have the same issue as this also, and I cant find anywhere you change the ehlo or helo in the AI.

    Please can someone help use out here.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    Surely the problem here isn't what your greeting is but whether you have a correct A record and/or reverse DNS that has your domain name in it. Postfix should identify itself as the FQDN of your zimbra server such as '220 xxx.domain.com ESMTP Postfix' where xxx is the machine name and domain.com is your domain name. That shouldn't cause you any problems, anything other than that might be considered 'suspicious' behaviour and could get you identified as sending spam.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Nicrad's Avatar
    Nicrad is offline Intermediate Member
    Join Date
    Apr 2007
    Posts
    24
    Rep Power
    8

    Lightbulb

    phoenix,

    I posted this (Hostname/FQDN - Email Headers) before I sore this post, and this was just a normal install. Let me know what you think. Thankfully this is only on a test box as my new production box should be here today (sometime) and I'll see how that goes.

    Thanks

  8. #8
    nfear24 is offline Special Member
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    Surely the problem here isn't what your greeting is but whether you have a correct A record and/or reverse DNS that has your domain name in it. Postfix should identify itself as the FQDN of your zimbra server such as '220 xxx.domain.com ESMTP Postfix' where xxx is the machine name and domain.com is your domain name. That shouldn't cause you any problems, anything other than that might be considered 'suspicious' behaviour and could get you identified as sending spam.
    I have a split dns setup. My A record on my zimbra machine points to the internal adress along with the mx record. So that is correct right. Then I have my domain.com being pointed to that machine, but the problem is that machine uses mail.domain.com and not domain.com.

    domain.com claims to be host mail.domain.com That is causing the problem. If I could just edit the HELO it should be solved.

    Thanks

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    So are you saying that you have no external DNS A record pointing to your server? What is 'this' domain' that seems to be causing this message from dnsreports?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    nfear24 is offline Special Member
    Join Date
    Jan 2007
    Posts
    121
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    So are you saying that you have no external DNS A record pointing to your server? What is 'this' domain' that seems to be causing this message from dnsreports?
    yes I also have an external DNS A record pointing to the server.

    tickus.com is the domain.

    Everything on my mailserver runs great except there is a couple places I cant send email do to this because of spam blocking.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •