Results 1 to 5 of 5

Thread: IMAP TLS Problems after upgrade to 4.5.3

  1. #1
    shanson is offline Active Member
    Join Date
    Mar 2006
    Location
    Hamburg, Germany
    Posts
    44
    Rep Power
    9

    Default IMAP TLS Problems after upgrade to 4.5.3

    Hi,

    we upgraded to 4.5.3 (from 4.5.1) over the weekend. We first had an issue with plain IMAP, now we have an issue with IMAP with TLS.

    1) Immediately after the upgrade plain IMAP was broken. We had activated the imapproxy for both ports 143 and 993. After activating the imapproxy only for port 993 we were then able to use plain IMAP again.

    2) Now IMAP with TLS doesn't work. Having the clients switch to SSL as a workaround enables them to read mail.

    Since the upgrade we're getting a lot of entries in /opt/zimbra/log/mailbox.log like this:

    Code:
    2007-03-19 10:15:01,686 INFO  [IMAP-143-W5177] [cid=5176;ip=10.10.10.11;] imap - exception occurred during read task
    javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
            at com.sun.net.ssl.internal.ssl.EngineInputRecord.bytesInCompletePacket(EngineInputRecord.java:152)
            at com.sun.net.ssl.internal.ssl.SSLEngineImpl.readNetRecord(SSLEngineImpl.java:759)
            at com.sun.net.ssl.internal.ssl.SSLEngineImpl.unwrap(SSLEngineImpl.java:674)
            at javax.net.ssl.SSLEngine.unwrap(SSLEngine.java:566)
            at com.zimbra.cs.ozserver.OzTLSFilter.handshake(OzTLSFilter.java:146)
            at com.zimbra.cs.ozserver.OzTLSFilter.read(OzTLSFilter.java:244)
            at com.zimbra.cs.ozserver.OzConnection$ReadTask.doTask(OzConnection.java:469)
            at com.zimbra.cs.ozserver.OzConnection$Task.run(OzConnection.java:368)
            at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Thread.java:595)
    What have we done wrong? :-)

    __________________
    Scott Hanson
    Media Ventures GmbH
    Cologne, Germany

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    Have you tried setting it to SSL?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    shanson is offline Active Member
    Join Date
    Mar 2006
    Location
    Hamburg, Germany
    Posts
    44
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix View Post
    Have you tried setting it to SSL?
    Setting what to SSL?

    Having the client use SSL instead of TLS works, but we'd like to have TLS working again.
    Scott Hanson
    Media Ventures GmbH
    Cologne, Germany

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Try to regenerate your certs to see if that helps.

  5. #5
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default IMAP and IMAPs

    Quote Originally Posted by shanson View Post
    Since the upgrade we're getting a lot of entries in /opt/zimbra/log/mailbox.log like this:

    Code:
    2007-03-19 10:15:01,686 INFO  [IMAP-143-W5177] [cid=5176;ip=10.10.10.11;] imap - exception occurred during read task
    javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
            at com.sun.net.ssl.internal.ssl.EngineInputRecord.bytesInCompletePacket(EngineInputRecord.java:152)
            at com.sun.net.ssl.internal.ssl.SSLEngineImpl.readNetRecord(SSLEngineImpl.java:759)
            at com.sun.net.ssl.internal.ssl.SSLEngineImpl.unwrap(SSLEngineImpl.java:674)
            at javax.net.ssl.SSLEngine.unwrap(SSLEngine.java:566)
            at com.zimbra.cs.ozserver.OzTLSFilter.handshake(OzTLSFilter.java:146)
            at com.zimbra.cs.ozserver.OzTLSFilter.read(OzTLSFilter.java:244)
            at com.zimbra.cs.ozserver.OzConnection$ReadTask.doTask(OzConnection.java:469)
            at com.zimbra.cs.ozserver.OzConnection$Task.run(OzConnection.java:368)
            at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Thread.java:595)
    Looks like the proxy is forwarding to the IMAPs port instead of to the IMAP port. This is a problem, because the proxy isn't speaking IMAPs. If you make the proxy speak to the IMAP port, things should work.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3.1 Upgrade Problems
    By dee in forum Administrators
    Replies: 22
    Last Post: 07-13-2009, 05:51 PM
  2. 4.5.4 -> 4.5.5 (Networkd Edition) Upgrade problems
    By spector@zeitgeist.com in forum Administrators
    Replies: 3
    Last Post: 10-18-2007, 05:06 AM
  3. Replies: 6
    Last Post: 04-18-2007, 06:03 AM
  4. upgrade 3.1.4 to 4.5.3
    By ronsterchan in forum Administrators
    Replies: 4
    Last Post: 03-16-2007, 01:24 AM
  5. Replies: 0
    Last Post: 01-03-2007, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •