Trying to solve some spam issues, and every message that passes through my system keeps showing URIBL_BLOCKED=0.001 in the X-Spam-Status header. I've signed up for the data feeds on uribl.com (on a trial right now). I've added my IP to their whitelist. I've gotten confirmation that I'm on the whitelist. Still getting the URIBL_BLOCKED. Am I looking at the wrong thing?

Code:
Return-Path: ScoreReportTeam@score.seenewjulyscores.us
Received: from mail4.******.com (LHLO mail4.******.com)
 (192.168.27.140) by mail4.******.com with LMTP; Fri, 18 Jul 2014
 11:22:54 -0500 (CDT)
Received: from localhost (localhost [127.0.0.1])
	by mail4.******.com (Postfix) with ESMTP id 2A6F34C6A1C
	for <spam@*****.com>; Fri, 18 Jul 2014 11:22:54 -0500 (CDT)
X-Virus-Scanned: amavisd-new at vminnovations.com
X-Spam-Flag: NO
X-Spam-Score: 4.109
X-Spam-Level: ****
X-Spam-Status: No, score=4.109 tagged_above=-10 required=5
	tests=[BAYES_50=0.8, RAZOR2_CF_RANGE_51_100=0.5,
	RAZOR2_CF_RANGE_E8_51_100=1.886, RAZOR2_CHECK=0.922,
	URIBL_BLOCKED=0.001] autolearn=no autolearn_force=no
Received: from mail4.******.com ([127.0.0.1])
	by localhost (mail4.******.com [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id kmYLwBWdPcI3 for <spam@*****.com>;
	Fri, 18 Jul 2014 11:22:50 -0500 (CDT)
Received: from score.seenewjulyscores.us (206-51-235-242.static.hvvc.us [206.51.235.242])
	by mail4.******.com (Postfix) with ESMTP id EE9614C6A0C
	for <boricua83@*****.com>; Fri, 18 Jul 2014 11:22:49 -0500 (CDT)
Date: Fri, 18 Jul 2014 09:18:07 -0700
Content-Transfer-Encoding: 8bit
Content-Disposition: inline
Mime-Version: 1.0
Message-ID: <1562939-460d2ba3931a940395e9a6005cb0f064@20124914.score.seenewjulyscores.us>
To: <boricua83@*****.com>
Content-Type: text/plain; charset=us-ascii
From: CreditReportCenter <CreditReportCenter@seenewjulyscores.us>
Subject: RE: Your-score was recently-changed. Read-new-notice.
The URI in question is http://sub.seenewjulyscores.us in this specific instance, and it's listed in URIBL Black. Any ideas?