Results 1 to 7 of 7

Thread: mysql error

  1. #1
    stepas is offline New Member
    Join Date
    Mar 2007
    Location
    Ireland
    Posts
    3
    Rep Power
    8

    Default mysql error

    Hy lads,
    i am new with zimbra and a great tool. I installed on opensuse 10.2 beside my apache. Everythings running great but if use phpMyAdmin i got the error
    #2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)
    Does zimbra changed anything to musql?

    And a big thanks to bicmudcake for his howto!!!!

    stepas

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Zimbra's mysql bind to port 7306
    Make sure that you set phpmyadmin to that port

  3. #3
    stepas is offline New Member
    Join Date
    Mar 2007
    Location
    Ireland
    Posts
    3
    Rep Power
    8

    Default mysql

    That's great thanks a lot

    Stepas

  4. #4
    rdjurovich is offline Junior Member
    Join Date
    Nov 2006
    Location
    Melbourne, Australia
    Posts
    9
    Rep Power
    8

    Exclamation

    Hi there,

    I think I'm having the same problem, but when I changed my phpmyadmin config to point to the 7306 port, it didn't work.
    Basically, i started with a fresh Ubuntu 6.10 install, installed my Apache, MySQL, etc as per usual (but with Apache on port 8080), and then installed Zimbra.
    So what I'm thinking is maybe Zimbra's MySQL is stopping the Ubuntu MySQL from running?
    Please any help would be much appreciated!

  5. #5
    rdjurovich is offline Junior Member
    Join Date
    Nov 2006
    Location
    Melbourne, Australia
    Posts
    9
    Rep Power
    8

    Default

    I solved my own problem
    For anyone that is interested, I simply specified the socket path in my phpmyadmin conf:
    /var/run/mysqld/mysqld.sock
    Ryan

  6. #6
    stepas is offline New Member
    Join Date
    Mar 2007
    Location
    Ireland
    Posts
    3
    Rep Power
    8

    Default

    I solved the problem bind my mysql server to 127.0.0.2 in my.cnf
    I run joomla so had a lot probs but after switch to 127.0.0.2 all is fine now
    just insert into my.cnf
    bind-address = 127.0.0.2

    and its fine

  7. #7
    rdjurovich is offline Junior Member
    Join Date
    Nov 2006
    Location
    Melbourne, Australia
    Posts
    9
    Rep Power
    8

    Default

    When I applied my testing setup to the live server, I had the same problem and my solution didn't quite work for some reason.
    However, I did figure out another solution: modify my /etc/php5/apache2/php.ini (Ubuntu's PHP INI file), to reflect this setting:

    mysql.default_socket = /var/run/mysqld/mysqld.sock

    Now all is fine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Cannot determine services - exiting
    By tawas in forum Installation
    Replies: 7
    Last Post: 04-25-2006, 02:47 AM
  3. Yet another get.DirectContext issue
    By dccpark in forum Installation
    Replies: 5
    Last Post: 03-08-2006, 01:25 PM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-14-2005, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •